Garuda no longer boots after trying to install nvidia drivers

This is only cosmetic. Not a problem.

Post the terminal output.


Windows allowed you to install with secure boot disabled? :thinking:


So I was able to solve the problem. Whereby that is the wrong term. I was able to solve the problem for me by working around it.

The problems seem to occur in conjunction with the KDE Dragonized Gaming Edition of Garuda. Yesterday I tried Manjaro for testing purposes. The first thing I noticed was that Manjaro (with KDE) was able to live boot with nvidia drivers. This did not work with Dragonized Gaming Edition. The error with the partitions also occurred with Manjaro, but here I know the workaround by now. Manjaro also ran later without problems with the hardware. I also tried different kernels, everything was fine. Installing Manjaro is of course no solution. So in desperation I installed Garuda with LXQT. All the problems I had with KDE do not occur here. The installation could be started with nvidia drivers, there was no bug when creating the partitions and also nvidia drivers worked fine. I had completed the full install on both as well, not just clicked around in live boot. However, I have not really warmed up to LXQT. Then wanted to test Sway next, but I thought more as fun to try it again with the KDE Dragonized Edition so not with the Gaming Edition. The live boot started with nvidia drivers, the error with the partitions also occurred here, workaround made and so far everything runs nicely (with working nvidia drivers). Except for one thing i am not able to install Wine. When I try this I get the message that lib32-jack2 and lib32-pipewire-jack have a conflict. Do I need to keep both?

Manjaro uses pre-compiled driver modules, Garuda uses DKMS.

As I said earlier in the thread, the DKMS driver module is not compiling correctly, and that's why it is failing to load.

This can be diagnosed, but if you're not willing to do this systematically then it's going to be essentially impossible.

If you are interested in getting the NVIDIA driver working in Garuda then you could run this in a terminal and post the output:

sudo pacman -S nvidia-dkms

As I worte with the KDE Dragonized Edition nvidia drivers are working fine. The problme occur only with the Dragonized Gaming Edition. I'm sticking now with the KDE Dragonized Edition. Just want to solve now the issue with Wine :slightly_smiling_face:.

The package conflict has been mentioned elsewhere in the forums, you just need to remove the conflicting version to allow the dependency to install.

                                          :solution 1

1first you can update then is using Konsole by command sudo pacman -Suuy
2 re install garuda linux but selecting boot with NiVidia drivers

I hope it works

Not for nothing, but some of your "advice" is a bit sloppy and unhelpful. Did you even read through the other posts in the thread?


We try to encourage our users to work through their issues on their Garuda install without having to resort to a full reinstall. Reinstallation is only a method of last resort because it teaches the user nothing about repairing or maintaining an Arch based system.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.