Garuda linux not showing up in grub

Greeting all,

This looks like a super interesting distro so I thought Id give it a try. I have 2 other distros on my laptop, MX linux and Linux Mint. In the grub boot up screen there's no Garuda. I've tried the "boot repair" tool from both Mint and MX - also tried fooling about with the advanced settings. I'm amazed the laptop is still booting up for the other distros. I'd love some help as I don't know what to do next. Thanks in advance.

Richard

ps. I tried to paste the text of the boot repair log but it was too long / not allowed. I removed most of it and got the message that new users can only mention 5 users. I don't know what that means.

Try to chroot from the Garuda live USB into your installed Garuda system with the relevant tool or the following tutorial and reinstall and update GRUB
Then you should be able to use the Garuda GRUB, which will probe the other OS's

Edit: First of all, welcome!
Second, before the method above, simply check with efibootmgr if you simply need to put Garuda entry as first with e.g.

sudo efibootmgr -o 0002,2001,2002,2003,0000

The sequence you can take from the first efibootmgr check and change as needed.

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.