Garuda ISO boot stuck on Starting Terminating Plymouth Boot Screen

I'll try that.

Just a question, I'm in the Garuda assistant and I can't find where to switch.

Nevermind, I think I found it in the Garuda Settings Manager

1 Like

I auto installed the drivers and rebooted, it opens and works, but no optimus-manager or Nvidia GPU. I'm doing a system update and I'll try installing the drivers again, but I'm not sure.

Looks like another black screen

Just a suggestion
Check you have fastboot disabled

It is disabled.

Check the suggestions here, especially booting to a tty and then launching startx, to see error messages, logs, etc...

It's not exactly your model, but you may want to try the boot parameter suggested here

1 Like

Where do I add these?

To test it once, when you are in the grub line for Garuda press button E, then add it at the end of the line starting with linux and press ctrl+x


I can now boot into Garuda Linux, however optimus-manager hasn't started and I'm still on my integrated graphics. If I run optimus-manager I get this error:

ERROR: the latest GPU setup attempt failed at Xorg pre-start hook.
Log at /var/log/optimus-manager/switch/switch-20210828T154003.log
Cannot execute command because of previous errors.

This is from the log file:

[25] INFO: # Xorg pre-start hook
[25] INFO: Previous state was: {'type': 'pending_pre_xorg_start', 'requested_mode': 'hybrid', 'current_mode': None}
[26] INFO: Requested mode is: hybrid
[121] INFO: Available modules: ['nouveau']
[121] INFO: Unloading modules ['nouveau'] (if loaded)
[125] INFO: switching=none, nothing to do
[174] INFO: Nvidia card not visible in PCI bus, rescanning
[174] INFO: Rescanning PCI bus
[218] ERROR: Nvidia card not showing up in PCI bus after rescan. Continuing anyways.
[237] INFO: Loading module nvidia
[237] ERROR: Xorg pre-start setup error
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/optimus_manager/hooks/", line 51, in main
    setup_kernel_state(config, prev_state, requested_mode)
  File "/usr/lib/python3.9/site-packages/optimus_manager/", line 22, in setup_kernel_state
    _nvidia_up(config, hybrid=(requested_mode == "hybrid"))
  File "/usr/lib/python3.9/site-packages/optimus_manager/", line 95, in _nvidia_up
    _load_nvidia_modules(config, available_modules)
  File "/usr/lib/python3.9/site-packages/optimus_manager/", line 164, in _load_nvidia_modules
    _load_module(available_modules, "nvidia", options=nvidia_options)
  File "/usr/lib/python3.9/site-packages/optimus_manager/", line 241, in _load_module
    raise KernelSetupError(
optimus_manager.kernel.KernelSetupError: module nvidia is not available for current kernel. Is the corresponding package installed ?
[238] INFO: Removing /etc/X11/xorg.conf.d/10-optimus-manager.conf (if present)
[238] INFO: Writing state {'type': 'pre_xorg_start_failed', 'switch_id': '20210828T154003', 'requested_mode': 'hybrid'}

Do you know why?

Sorry, I don't really know...
Maybe give a look at this hint

Didn't work. Thanks for your help anyway.

My last two dumb hints and I'm crashing into bed :smiley:

  1. Make sure you are with Nvidia drivers, since I see only nouveau above
  2. Maybe check if the Nvidia card is somehow disabled in the BIOS, since invisible in PCI bus...
1 Like

Hi, I'm not entirely sure how to do this. Could you give me some guidance? And by the way, I really appreciate your help :grin:

Don't worry, I think the problem is elsewhere or also elsewhere, but this is too technical for me.
When it unloads nouveau, I think this is done to leave only Nvidia loaded, and this should be fixed. But also the Nvidia card not visible in PCI bus should be part of the problem.
I hope someone else who knows better will jump in...
The only suggestion in the meanwhile would be to check the continuation of the GitHub above, with some Xorg configuration hints, and the FAQ, with logs description.
Check also the output of mhwd -li, as I see it could be useful for further future troubleshooting.
Edit: I just realized that the inxi -Fza was still the one from Gnome.
You should provide the one in the Dr460nized installation.

1 Like
System:    Kernel: 5.13.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2021-08-28_16-22-33/@/boot/vmlinuz-linux-zen 
root=UUID=44050427-6897-438c-abc6-9a8e281d1d52 quiet splash rd.udev.log_priority=3 
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
acpi_osi=! "acpi_osi=Windows 2009" nvidia-drm.modeset=1 
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Alienware product: Alienware m15 R2 v: 1.8.1 serial: <filter> Chassis: 
type: 10 serial: <filter> 
Mobo: Alienware model: Alienware m15 R2 v: A00 serial: <filter> UEFI: Alienware v: 1.8.1 
date: 06/08/2021 
Battery:   ID-1: BAT1 charge: 46.0 Wh (82.3%) condition: 55.9/76.0 Wh (73.5%) volts: 11.2 min: 11.4 
model: COMPAL PABAS0241231 type: Li-ion serial: <filter> status: Discharging 
CPU:       Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake note: check 
family: 6 model-id: 9E (158) stepping: A (10) microcode: EA cache: L2: 12 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399 
Speed: 4258 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 4258 2: 3451 3: 4255 4: 4300 
5: 4283 6: 3337 7: 4293 8: 1705 9: 3730 10: 1132 11: 4091 12: 4301 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell driver: i915 v: kernel 
bus-ID: 0000:00:02.0 chip-ID: 8086:3e9b class-ID: 0300 
Device-2: NVIDIA TU104M [GeForce RTX 2080 Mobile] vendor: Dell driver: N/A alternate: nouveau 
bus-ID: 0000:01:00.0 chip-ID: 10de:1e90 class-ID: 0300 
Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-7:4 
chip-ID: 0bda:5538 class-ID: 0e02 serial: <filter> 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel 
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3 chip-ID: 8086:a348 
class-ID: 0403 
Device-2: NVIDIA TU104 HD Audio driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 
chip-ID: 10de:10f8 class-ID: 0403 
Sound Server-1: ALSA v: k5.13.13-zen1-1-zen running: yes 
Sound Server-2: JACK v: 1.9.19 running: no 
Sound Server-3: PulseAudio v: 15.0 running: no 
Sound Server-4: PipeWire v: 0.3.34 running: yes 
Network:   Device-1: Realtek Killer E3000 2.5GbE vendor: Dell driver: r8169 v: kernel port: 3000 
bus-ID: 0000:3c:00.0 chip-ID: 10ec:3000 class-ID: 0200 
IF: enp60s0 state: down mac: <filter> 
Device-2: Intel Wi-Fi 6 AX200 vendor: Rivet Networks driver: iwlwifi v: kernel port: 3000 
bus-ID: 0000:3d:00.0 chip-ID: 8086:2723 class-ID: 0280 
IF: wlp61s0 state: up mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:7 
chip-ID: 8087:0029 class-ID: e001 
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: intel_nvme_remap v: N/A 
port: 5060 bus-ID: 0000:00:17.0 chip-ID: 8086.282a rev: 10 class-ID: 0104 
Supported mdraid levels: raid0 
Device-1: md126 maj-min: 9:126 type: mdraid level: raid-0 status: active size: 953.88 GiB 
Info: report: N/A blocks: 1000210432 chunk-size: 64k 
Components: Online: 
0: nvme0n1 maj-min: 259:0 size: 476.94 GiB 
1: nvme1n1 maj-min: 259:1 size: 476.94 GiB 
Device-2: md127 maj-min: 9:127 type: mdraid level: N/A status: inactive size: N/A 
Info: report: N/A blocks: 4784 chunk-size: N/A 
Components: Online: N/A Spare: 
0: nvme0n1 maj-min: 259:0 size: 476.94 GiB state: S 
1: nvme1n1 maj-min: 259:1 size: 476.94 GiB state: S 
Drives:    Local Storage: total: raw: 1.44 TiB usable: 523.51 GiB used: 11.58 GiB (2.2%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730 NVMe WDC 512GB 
size: 476.94 GiB block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> 
rev: 11121012 temp: 36.9 C 
ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Western Digital model: PC SN730 NVMe WDC 512GB 
size: 476.94 GiB block-size: physical: 512 B logical: 512 B type: SSD serial: <filter>
rev: 11121012 temp: 36.9 C
ID-3: /dev/sda maj-min: 8:0 type: USB vendor: Samsung model: PSSD T7 size: 465.76 GiB
block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-4: /dev/sdb maj-min: 8:16 type: USB vendor: HP model: v150w size: 57.75 GiB block-size:
physical: 512 B logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 11.58 GiB (2.5%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 11.58 GiB (2.5%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 11.58 GiB (2.5%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 11.58 GiB (2.5%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.42 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 60.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 343 Uptime: 1m wakeups: 4 Memory: 15.42 GiB used: 1.66 GiB (10.8%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1172 lib: 294
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06```
Here is the `inxi -Fza` from a timeshift snapshot, because it refused to boot again.

This is what comes from `mhwd -li`

Installed PCI configs:


video-linux 2021.02.19 true PCI
video-nvidia-prime-render-offload 2021.08.05 false PCI
video-optimus-manager 2021.04.19 false PCI

Once again, thanks for your help

1 Like

I fixed it by switching to the linux-lts kernel! Thanks for all your help! :slightly_smiling_face:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.