Garuda Installation failed, bootloader installation error

I'm trying to install Garuda KDE Dr460nized gaming edition on a second partition, to dual boot with Windows 10.

Everything seems to be alright up to the end, except the installation fails with the following error:

Bootloader installation error
The bootloader could not be installed. The installation command
grub-install --target=i386-pc --recheck --force /dev/sda
returned error code 1.

I haven't found other posts with my same error, I haven't been able to fix it :frowning:

How are you partioning your drive?

2 Likes

In Windows 10, I used Paragon Partition Manager to split the drive and I made a partition for Garuda. Then I booted with the USB to start the install process and I get that error at the end.

Is your BIOS in legacy or uefi mode?

3 Likes

Check as @filo say,s and also check fastboot and secure boot is disabled

3 Likes

I think its on legacy mode, not sure how to confirm, but when I installed windows, I used a USB that was formatted on MBR, so I think that was legacy. I'll check on fast boot and secure boot options on my BIOS and see if I can find it and confirm

I disabled fast boot and secure boot, and I tried to install Garuda again, but I got the same error :frowning:

Try to set your BIOS in UEFI mode and apply this tutorial.
I think your system is installed, you have only to install the GRUB properly.

parted -l | grep -iE "^Disk /|esp" | grep -B1 esp

should tell you hopefully which partition you should use to mount to /boot/efi

3 Likes

Changed my BIOS to UEFI-only, and when using the command you gave me on Konsole, I got, " parted: invalid option -- '1'"

Also when using "lsblk -f" as per the guide's instructions, I can't find anything with dev/<something..

I get:

> NAME FSTYPE FSVER LABEL                    UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0
squash 4.0                                                                       0   100% /run/miso/sfs/livefs
loop1
squash 4.0                                                                       0   100% /run/miso/sfs/mhwdfs
loop2
squash 4.0                                                                       0   100% /run/miso/sfs/desktopfs
loop3
squash 4.0                                                                       0   100% /run/miso/sfs/rootfs
sda                                                                                            
├─sda1
│                                                                                              
└─sda2
ntfs         Storage                  BE84B31284B2CC61                                    
sdb                                                                                            
├─sdb1
│                                                                                              
├─sdb2
│    vfat   FAT32                          804F-2C0D                                           
├─sdb3
│                                                                                              
├─sdb4
│    ntfs         OldSSD                   7CB6CE22B6CDDD30                                    
├─sdb5
│    ntfs                                  08F678D1F678C08C
└─sdb6
ntfs                                  76CE5B21CE5AD8C7
sdc
├─sdc1
│
├─sdc2
│    ntfs         Windows 10               6E8CD22B8CD1ED99
└─sdc3
btrfs                                 1f2895ad-0440-4819-929f-588e1937ec22
sdd
├─sdd1
│
└─sdd2
ntfs         Seagate Expansion Drive  40DA3E14DA3E06A6
sde  iso966 Jolie GARUDA_DR460NIZEDGAMING_HARPYEAG
│                                          2021-09-28-07-23-12-00                     0   100% /run/miso/bootmnt
├─sde1
│    iso966 Jolie GARUDA_DR460NIZEDGAMING_HARPYEAG
│                                          2021-09-28-07-23-12-00
└─sde2
vfat   FAT12 MISO_EFI                 DA10-C9D9
zram0
[SWAP]

If you include terminal outputs in your post please use the proper output format in your post.

Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

It Is

parted -l

not -1
I think your installed system partition should be /dev/sdc3 (the only btrfs one I see).
The ESP partition could be /dev/sdb2
But this needs to be rechecked of course.

2 Likes

Oops! although It does not say anything in return, it just sends the command without anything else. Shouldn't I use /dev/sdc3 ? i mean, that's the one that shows as btrfs

Edit: that was on Konsole, in Chroot it says:
grep: ^Disk /|esp: no such file or directory.
parted: write error: Broken pipe

If parted is not listing anything it is not finding an ESP partition, so I don't think we are going in the right way :pensive:
Just to be sure, try also

lsblk -o name,type,fstype,size,uuid,mountpoint
1 Like

Btw, is it okay for me to be using "Konsole" for all of this? or should it be done through chroot? (I have tried with both)

just tried that, i get this in response:

NAME   TYPE FSTYPE     SIZE UUID                                 MOUNTPOINT
loop0  loop squashfs  13.5M                                      /run/miso/sfs/livefs
loop1  loop squashfs 380.5M                                      /run/miso/sfs/mhwdfs
loop2  loop squashfs   2.6G                                      /run/miso/sfs/desktopfs
loop3  loop squashfs 720.4M                                      /run/miso/sfs/rootfs
sda    disk          931.5G
├─sda1 part            128M
└─sda2 part ntfs     931.4G BE84B31284B2CC61
sdb    disk          223.6G
├─sdb1 part            450M
├─sdb2 part vfat        99M 804F-2C0D
├─sdb3 part             16M
├─sdb4 part ntfs       222G 7CB6CE22B6CDDD30
├─sdb5 part ntfs       549M 08F678D1F678C08C
└─sdb6 part ntfs       487M 76CE5B21CE5AD8C7
sdc    disk          931.5G
├─sdc1 part             16M
├─sdc2 part ntfs       300G 6E8CD22B8CD1ED99
└─sdc3 part btrfs      325G 1f2895ad-0440-4819-929f-588e1937ec22 /mnt/broken
sde    disk iso9660   14.4G 2021-09-28-07-23-12-00               /run/miso/bootmnt
├─sde1 part iso9660    3.8G 2021-09-28-07-23-12-00
└─sde2 part vfat         4M DA10-C9D9
zram0  disk           15.6G                                      [SWAP]

From konsole it is fine.
If you want to try, It could be

sudo mkdir -p /mnt/broken
sudo mount /dev/sdc3 /mnt/broken
sudo garuda-chroot /mnt/broken/@
mount /dev/sdb2 /boot/efi
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
update-grub

If it doesn't work, you could try

lsblk -no PKNAME /dev/sdc3

and see if we find the MBR, and then eg

grub-install /dev/sdc

Or

grub-install /dev/sdb
1 Like

I got something with the parted -l command from chroot, is there a way for me to copy it? it doesn't allow me to use Ctrl C lol

From the terminal you should shift+ctrl+C to Copy. Then past here...

Thank you! This is what I get from chroot and the parted -l command you sent me:

[[email protected] /]# parted -l | grep -iE "^Disk /|esp" | grep -B1 esp
Disk /dev/sdb: 240GB
 2      473MB   577MB  104MB   fat32        EFI system partition          boot, esp
Disk /dev/sdc: 1000GB
 3      322GB   671GB   349GB   btrfs        root                          boot, esp
Disk /dev/sde: 15.5GB
 2      4109MB  4114MB  4194kB  primary               esp

Maybe try to create that /boot/efi when into the chroot, before mounting

mkdir /boot/efi
mount /dev/sdb2 /boot/efi
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
update-grub
2 Likes

Also, check from inside chroot partition mount settings and status

cat /etc/fstab
lsblk -f
1 Like

which partition have you created with Paragon Partition Manager ? unallocated partition or another ?

1 Like