Garuda install stuck at "a start job is running.." after proprietary drivers selected

Hello to the community,

I recently bought a new Dell laptop and I tried to install Garuda Linux again. I burned the ISO file into a usb using the Garuda downloader on windows, but created it on a different machine(win10).

Then, on my new Dell machine, I booted from that usb and it showd me the Garuda boot screen where I chose to boot with proprietary nvidia drivers.
My new Dell laptop had win11 by default and has intergrated gpu as well as a dedicated NVIDIA one. I don't know if this helps.

For now what I'm trying is to create again that bootable usb drive but this time I will create it from my new laptop(Dell), the one that I want to dual boot. I don't know if it will make any difference. My last option is to use open source drivers but I want to get a bit of feedback on the situation here.

Thank you very much!

What is the CPU of the laptop? If it is gen11 or gen12, add ibt=off to your kernel parameters.

It's gen12. But how am I going edit the kernel parameters? thanks in advance

On boot menu choose propriearty drivers (DON'T HIT ENTER), hit "c" navigate to the end of the line beginning witl "linux" with arrow keys and add "ibt=off". Hit F10 to boot.

3 Likes

Will try it and come up with the outcome. It may take a while though. Thanks

@mrvictory
It was 'e' not 'c' and also I maybe have put the "ibt=off" in a wrong place because it said afterwords that that's a wrong file name.

So to be clear, where exactly should I put the "ibt=off"??

Thank you it worked.
I did put the "ibt=off" at the last line which is incorrect if you see the image I provided.

I had to put it at the end of the command starting with "Linux" as you pointed.

Your answer is correct except that I had to press 'E' and not 'C'.

Thank you

Please, post a picture.
Maybe it is better for you not to update your system, you have old, but working grub.
Read Full transparency on the Grub issue – EndeavourOS

1 Like

The screenshot of the E for edit.

My laptop stuck at "Loading initial ramdisk ..."

1 Like

Is this installed system? If it is, you have to add that ibt=off again. Then update, the updater should warn you that the kernel parameter has been automatically added.

2 Likes

Thank you very much.
I logged in and I did update the system but after the restart again the "ibt=off" was absent and I was stuck again on "loading initial ramdisk".

At the end of the update it showed me that the grub did update. I don't if that has to do with the known problem that @SGS pointed out.

Here is a photo of my grub version:

Any update on that? @SGS @mrvictory
Thank you in advance. I can imagine that there are many issued that need assistance. I appreciate the amazing job you are doing, providing assisctance for Garuda !!

That grub version, causing so many problems to so many users has been recently rolled back in our repo to the previously working version. So in my opinion you need to find a way to update.
What I suggest you could do is:

  • chroot into your system with your live USB, either using the relevant tool in the Garuda Welcome or with this manual procedure https://forum.garudalinux.org/t/how-to-chroot-garuda-linux/4004 (only the initial part where you chroot into the system, not yet the grub installation).
  • from inside the chroot, perform a garuda-update. This should downgrade the grub package.
  • from inside the chroot micro /etc/default/grub, add ibt=off at the end of the line starting with GRUB_CMDLINE_LINUX_DEFAULT, save and exit
  • from inside the chroot reinstall the grub into your system and update-grub (the second part of the tutorial, or also with the tools in the iso)
  • exit from the chroot and reboot
4 Likes

I was able to boot into my system so I didn't have to chroot but I had to update grub and add the ibt=off.
Thank you

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.