Garuda install on Beelink SER6 Max

Down the mini PC rabbit hole I go…

I’m planning on replacing the living room Roku with the Beelink 6 Max (Ryzen 7 w/ Radeon 680m) with an extra portable 2 TB SSD drive. Keyboard/ mouse would be wireless. Monitor would be an HDMI connected Samsung TV. The idea is to make a media PC with the ability to play games on Linux instead of Win 11 (no dual boot). Piece of cake right?

Unfortunately, my grand plan ran into a stumble following someone with the same idea…

The solution was a custom ISO?

I am just doing some recon to see if I am going to make something cool or just being a masochist. Physically removing Win 11 drive and replacing with “Linux” drive as primary. I can then swap back if I blow it. I have run Ubuntu and Mint before on laptops for fun but I come from Winworld so please be gentle.

Hope to deliver my little skunkworks project to family for Christmas “unveil”.

That was posted a while ago. Newer Garuda ISOs might work for that model of mini PC now. If not, the XFCE version of Garuda comes with the LTS Kernel, so that should still work as stated in that linked thread.

(P.S. Not sure if helpful, but I have a Beelink SER4 model running dragonized gaming edition.)


KDE dragonized with LTS kernel


@Zaphos are you saying that your ser6 isn’t booting or that you are afraid that it might not? I just double checked with the latest ISO on a USB stick and it boots just fine.

One thing I did discover some time ago is that changing the BIOS settings for video memory from “automatic” to “2GB” or “3GB” or whatever suits your fancy makes the boot problem go away for me.

Good luck :slight_smile:


Great info, I’ll try Dragonized build and fallback to the other installer if I run into trouble. Also, I’ll add fixed memory setting to my checklist.

Thanks for the heads up, these are the things that make all the difference when you get into it.

I’ll start spinning wrenches on it this weekend.


Ok, I made good progress today…

Secure boot - off
Integrated video ram - fixed at 8gb
New Samsung m.2 1Tb drive
Created bootable USB using etcher and dragon gamer ISO following instructions in Garuda download section
Set boot on Beelink BIOS to USB drive first
OS Install ran without a snag
I have two features I am sorting out…

  1. the wireless didn’t come up as it was asking for a KDE wallet password so I selected Blowfish but no love. Here is description of the issue…

I think I’ll bite the bullet tomorrow and run some Ethernet through the attic. Signal was only 30% anyway (turns out running Wi-Fi antennas INSIDE a metal box doesn’t work so good). Looking at you Beelink.

  1. No HDMI audio out… Should be a simple audio out setting, I will follow up tomorrow.

Those issues aside, kicking back on the couch with wireless keyboard/ mouse running Garuda on a giant TV is pretty sweet!

More to come…

Apart from the fact that your WiFi “should” be working (it works for me :-)), I am using these TP-Link AV2000 Powerline adapters in places where I have bad wifi-signal. Works quite well and is much less work than making and pulling cable through walls.

As for the HDMI Audio: Look in the audio settings or just the little speaker-icon on the status bar and make sure you switch the output to HDMI. KDE may not switch it automatically in all cases.

KDE can be fickle on audio. I have my boards audio and HDMI through the video card. I always disable the HDMI under the audio setting, but about every fourth update it gets switched back made the default and the boards audio gets dropped to 40%.

This message is coming to you from my Beelink running Garuda! All issues solved.

  1. Wireless: I had an easy run to the wall I mounted the Beelink to. I much prefer wired connection AND I wanted an Ethernet run to the Roku Soundbar. Connectivity is awesome and leaves more wireless bandwidth for the mobile devices to use the wireless.

2: Sound: I enabled ARC on my Samsung TV (allows HDMI “sound forwarding”) and now the sound is using the Roku Soundbar and is pretty amazing.

  1. Wireless keyboard/ mouse: Not mentioned before but the Beelink seems to be an electrically “noisy” device and my wireless keyboard/ mouse were cutting out and lagging intermittently. I connected the wireless USB FOB to a short USB extender and moved it a few inches away from the Beelink. Now I have no issues. Hopefully that may help someone who runs into the dreaded “wireless mouse lagging” issue. I’ll also post that in Reddit under Beelink.

I updated the packages and now I’m hacking on Garuda to learn it. I have to say, this is one solid distro. I had no issues that weren’t related to hardware. Linux was the easy part, LOL. Hats off to the devs!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.