KWallet doesn't work - a possible solution

KWallet gave a number of issues from a fresh install of Garuda Linux Raptor Eagle, including:

  1. On connecting to Wifi in the Install Garuda Live ISO, it gives a GPG error about no key available, with no steps ahead
  2. On searching for the error, I found that gpg --full-generate-key needs to be run, so ran it and tried again. However, it kept giving the 'GPG error: inappropriate ioctl for device'. For example, Wifi could never connect from restart and I had to keep entering the password each time. Similarly, VSCode authentication had to be redone after every restart.
  3. Following this blog Fixing GPG "Inappropriate ioctl for device" errors helped me fix the above error, but gave a new one - 'GPG error: no data'
  4. Deleting and regenerating a new key also didn't help, and some solutions online pointed to using gnome-keyring instead of kwallet.

After the difficult experience with KWallet, I decided to install and use gnome-keyring instead. Here are the steps I followed:

  1. Install kwalletmanager,gnome-keyring, seahorse, kleopatra.
  2. Open Settings and go to KDE Wallet. If not visible, restart your PC
  3. Uncheck the Enable the KDE wallet subsystem
  4. Open Kleopatra once (just to ensure it is running)
  5. If you have saved Wifi passwords etc. just remember to forget them
  6. Now, when I connected to Wifi, my password was saved properly. Similarly, VSCode authentication works.

Although the issues above occurred with GPG encryption, I faced issues with classic blowfish encryption as well. In that case it simply didn't give access to the saved passwords. This seems to be a joint issue of KWallet and of UI in GPG (maybe something underlying in blowfish as well)

Please suggest any better solutions for this issue. I did not face these issues with my Garuda install before Raptor Eagle.


  Kernel: 6.3.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=b998ca61-5a99-4917-983e-dbafb6d5e19a rw rootflags=subvol=@
    quiet rd.luks.uuid=0627becf-6cd7-4db3-8d12-6ddf9b1277ed quiet splash
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: HP product: HP Laptop 15-dy2xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 87FE v: 57.25 serial: <superuser required> UEFI: AMI
    v: F.31 date: 03/25/2023
  ID-1: BAT0 charge: 37.9 Wh (100.0%) condition: 37.9/41.0 Wh (92.4%)
    volts: 12.9 min: 11.3 model: HP Primary type: Li-ion serial: <filter>
    status: full cycles: 220
  Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xAA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2582 high: 2800 min/max: 400/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2800 2: 2800 3: 2800
    4: 2800 5: 2800 6: 2800 7: 1057 8: 2800 bogomips: 44851
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
    bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: Luxvisions Innotech HP TrueVision HD Camera driver: uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-3:3
    chip-ID: 30c9:0013 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: AU Optronics 0x21ed built: 2019 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: Mesa Intel Xe Graphics (TGL GT2)
    direct-render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  API: ALSA v: k6.3.9-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
    port: 3000 bus-ID: 0000:01:00.0 chip-ID: 10ec:c821 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:6 chip-ID: 0bda:b00e
    class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
  Local Storage: total: 505.59 GiB used: 11.95 GiB (2.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLQ512HBLU-00BH1 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: HPS1NFAV temp: 33.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: Cruzer Blade
    size: 28.65 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
    fw-rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 256.59 GiB size: 256.59 GiB (100.00%)
    used: 11.86 GiB (4.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-0627becf-6cd7-4db3-8d12-6ddf9b1277ed
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 89.5 MiB (35.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 256.59 GiB size: 256.59 GiB (100.00%)
    used: 11.86 GiB (4.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-0627becf-6cd7-4db3-8d12-6ddf9b1277ed
  ID-4: /var/log raw-size: 256.59 GiB size: 256.59 GiB (100.00%)
    used: 11.86 GiB (4.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-0627becf-6cd7-4db3-8d12-6ddf9b1277ed
  ID-5: /var/tmp raw-size: 256.59 GiB size: 256.59 GiB (100.00%)
    used: 11.86 GiB (4.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-0627becf-6cd7-4db3-8d12-6ddf9b1277ed
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.27 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 37.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  Processes: 315 Uptime: 1h 1m wakeups: 15085 Memory: available: 15.27 GiB
  used: 3.48 GiB (22.8%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1444
  libs: 385 tools: octopi,paru Shell: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.27
Garuda (2.6.16-1):
  System install date:     2023-06-25
  Last full system update: 2023-06-25
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

Searched topics: 'kde wallet ioctl', 'gpg ioctl', 'gpg no data', 'kde wallet no data', 'default keyring not opening'

What does the error specifically say?

I don't recall ever seeing a GPG error out of the gate on the back of a fresh install. Did you try running garuda-update?

Hi Bluish,

The exact error is as follows:

  1. First, after entering the WiFi password, it asks me whether I want to use classic blowfish encryption or GPG encryption to create a new wallet
  2. If I choose GPG, it tells me "Seems your system has no keys suitable for encryption. Please set-up at least one encryption key, then try again."

This is what happens in issue number 1 in my original post. After that, I tried step number 2, and due to the issues mentioned ahead, I could not get KDEWallet working well with the system.

Additionally, Blowfish also gave some weird issues, specifically that if I chose Blowfish instead of GPG, my WiFi saved password never worked, and I had to enter it everytime I logged in. I did not investigate this further, as I found the solution in using gnome-keyring.

As this happened in the Live ISO Session, I had not run garuda-update, however, after installing my system I did run it, and GPG continued giving the issues above.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.