Garuda Install Freeze


I wanted to give Garuda a try but I run into following issue: PC always freezes during installation.
Exactly on 79% ( Configure Hardware).

My system:

Nvidea GT730 video card
Broadcom Wifi/BT card
500GB HD

What I tried:

  • Different Image
  • Different USB

I use Etcher to flash the image.

Any help/ advice will be appreciated

Check sha sum also and try Ventoy too.
And wait up to 5-10 minutes mhwd need some time.

and post

inxi -Fza



Thanks for rely.

When it freezes. It stays that way. I have to shut down the PC.

When should I type inxi -Fza ? When in Live Mode?

Start the Installation using the terminal (calamares) and post the output. This will provide more information about where the Installation stalls.

sudo -E calamares -d


sudo calamares -d


sudo -E calamares

something like that :smiley:


Here is output:

inxi -Faz
System:    Kernel: 5.12.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=garuda  
misolabel=GARUDA_DR460NIZEDGAMING_SOARING_ quiet systemd.show_status=1 driver=nonfree  
nouveau.modeset=0 i915.modeset=1 radeon.modeset=1  
Desktop: KDE Plasma 5.22.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop Mobo: Micro-Star model: H410M PRO (MS-7C89) v: 1.0 serial: <filter>  
UEFI: American Megatrends v: 1.60 date: 08/20/2020  
CPU:       Info: Quad Core model: Intel Core i3-10100F bits: 64 type: MT MCP arch: Comet Lake family: 6  
model-id: A5 (165) stepping: 3 microcode: EA cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 57600  
Speed: 4201 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 4201 2: 4294 3: 4201 4: 4203  
5: 4201 6: 4201 7: 4200 8: 4260  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf status: Not affected  
Type: mds status: Not affected  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling  
Type: srbds status: Not affected  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: NVIDIA GK208B [GeForce GT 730] vendor: Gigabyte driver: nvidia v: 465.31  
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1287 class-ID: 0300  
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0  
screens: 1  
Screen-1: 0 s-res: 3840x2160 s-dpi: 162 s-size: 602x341mm (23.7x13.4") s-diag: 692mm (27.2")  
Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 163 size: 600x340mm (23.6x13.4")  
diag: 690mm (27.2")  
OpenGL: renderer: NVIDIA GeForce GT 730/PCIe/SSE2 v: 4.6.0 NVIDIA 465.31 direct render: Yes  
Audio:     Device-1: Intel vendor: Micro-Star MSI driver: snd_hda_intel v: kernel  
alternate: snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a3f0 class-ID: 0403  
Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Gigabyte driver: snd_hda_intel v: kernel  
bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403  
Sound Server-1: ALSA v: k5.12.12-zen1-1-zen running: yes  
Sound Server-2: JACK v: 0.125.0 running: no  
Sound Server-3: PulseAudio v: 14.2 running: yes  
Sound Server-4: PipeWire v: 0.3.30 running: no  
Network:   Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e v: kernel port: efa0  
bus-ID: 00:1f.6 chip-ID: 8086:0d55 class-ID: 0200  
IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>  
Device-2: Broadcom BCM4350 802.11ac Wireless Network Adapter vendor: Dell driver: N/A  
modules: brcmfmac port: 3000 bus-ID: 04:00.0 chip-ID: 14e4:43a3 class-ID: 0280  
IF-ID-1: anbox0 state: down mac: <filter>  
Bluetooth: Device-1: Broadcom BCM2045A0 type: USB driver: btusb v: 0.8 bus-ID: 1-7:4 chip-ID: 0a5c:6412
class-ID: fe01 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 480.36 GiB used: 0 KiB (0.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT500P2SSD8 size: 465.76 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD
serial: <filter> rev: P2CR012 scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Blade size: 14.59 GiB
block-size: physical: 512 B logical: 512 B serial: <filter> rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100)
ID-1: swap-1 type: zram size: 1.95 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0
ID-2: swap-2 type: zram size: 1.95 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1
ID-3: swap-3 type: zram size: 1.95 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2
ID-4: swap-4 type: zram size: 1.95 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3
ID-5: swap-5 type: zram size: 1.95 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4
ID-6: swap-6 type: zram size: 1.95 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5
ID-7: swap-7 type: zram size: 1.95 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6
ID-8: swap-8 type: zram size: 1.95 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7
Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 44 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 43%
Info:      Processes: 238 Uptime: 2m wakeups: 0 Memory: 15.57 GiB used: 4.1 GiB (26.3%) Init: systemd
v: 248 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1654 lib: 488 Shell: fish
v: 3.2.2 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.04

If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Ok, thanks! It started in calamares mode.

Now it froze again, so I cannot copy the output but is is something with Broadcom card.
Last lines say:
modprobe: FATAL: Module bcm43xx and brcm80211 not found

Successfully installed network-broadcom-wl

That is where it freezes

Any ideas?

@tbg just an idea?

1 Like

Yes, this happens because of Broadcom with some adapters. It's the Broadcom wifi halting the install. It needs to be removed from the calamares install script for the update to proceed. I forget which line needs to be edited out for the install to proceed.

Perhaps the user could try turning off wifi at the bios level (if possible) and try an offline install.


Ok, I'll try that.

Is Broadcom bad card of something? Normally I need it for Wireless connection...
Is it known to mess up the system?

Try to give a look also at this one maybe


Um, where do I need to go to edit this config?
While in Live Mode?

I thought that file was available in the USB...

Ok, which lines should I remove in ?

Search for a part of that string.
Or they say
near the bottom of the file, in the run(self) method of the MhwdController class.

If it doesn't work, look also at the solution post.
But the one i linked was referenced in another post


Ok, removing those lines in run(self) method solved the issue!

Install complete.

But now I do not see my wireless connection. Only wired.

Do you know how to fix that?

Please, open new topic, this one is solved :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.