Garuda Dragonized/Dragonized Gaming feedback: Kernel, Searx, Chaotic-AUR

Good morning!

Because I installed Garuda Dragonized on more than 10 devices and this distribution is slowly spreading in my workplace I have decided to give feedback of problems and what could be improved (in my opinion)

  1. Problems with linux-zen on some devices:
  • Problem with and during installation of Garuda Dragonized OS and system start
  • Problem with freezing system after few minutes
  • Problem with shutting down system

I've tried to install Garuda Dragonized Gaming Edition on PC and installation was always freezing on 79% similar to the topic in here:

Removing the suggested lines for 'net' and/or 'video' in /usr/lib/calamares/modules/mhwdcfg/main.py didn't help:

for id in self.identifier['net']:
                self.configure(b, id)

The calamares installation didn't show any error.. The installation simply freezes

sudo -E calamares -d

I've tried Garuda Dragonized edition (this time not the gaming one) and it freezed on 92%... and removing mhwdcfg/main.py lines as above made failed installation, but the time of freezing was almost always the same so my last attempt (which I thought was stupid) was to simply try to get to the installation as fast as I can (I didn't bother with keyboard and other settings) and ... it installed but after restart didn't boot (open source drivers).

The installation (same as above - as fast as I can) with proprietary drivers booted properly and I finally have had installed system... that was freezing in few minutes after installation as below (i have basically broken camera, I know):


And didn't shut down:

Solution for freezing and system not being able to shut down was to immediately (before system would freeze) install lts-kernel. There were no problems after that.

The possible improvement for this could be improvement of zen-kernel or creating installation ISO with lts-kernel for problems above. I can give output from garuda-inxi from PC with problems mentioned above on Monday if requested.

  1. FireDragon - search engine
    With (almost) every installation (if it was on someone else device) I've got response that the garuda searx as default search engine don't work and they can't make it work or change it to google which they want to use as default/have similar results.

I just realized that in the newest update of FireDragon, Google was added as possible option XD...

  1. App installation

I installed once (command sudo pacman -U <package>) mega sync application, which I downloaded from official site (instead with pacman -S), which installed it with additional package database - 'ARCH ...' (dont remember full name) and some apps stopped working correctly after system was updated. After some time I've used snapper and installed it correct way.

I think it would help (at least for me) in some cases, to give warning with remainder to try to find/install app via pacman -S with link to flatpack Archwiki page if you really need to install package not found in Chaotic-AUR.


That took a while...
I hope this feedback will be helpful for you and help with further development of the system :dragon:

Best regards,
Deimos

1 Like
chaotic-aur/megasync 4.6.8.0-1 [8.58MiB 15.07MiB]
    Easy automated syncing between your computers and your MEGA cloud drive

Why not use this?

Also I think this all would fit better into the issues-and-assistance category. Provided you want some help you should probably open a post for the issues alongside your garuda-inxi

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.