Garuda Hyprland Feb ISO's won't boot after install

Greetings fellow Garudians.

I’m left posting here, hoping someone may have had the same problem and found a way to bypass/fix it.

I’ve started playing with the community hyprland edition of the garuda releases a couple of months ago and i’m experiencing a bit of a problem that i’ll get to it shortly.

First, let me share my inxi and specs

  Kernel: 6.7.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us
    tz=Europe/Athens misobasedir=garuda
    root=miso:LABEL=GARUDA_HYPRLAND_SPIZAETUS quiet systemd.show_status=1
    ibt=off driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Desktop: Hyprland v: 0.35.0-13-ge4bb5fa4 with: waybar tools:
    avail: swayidle,swaylock vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
  Type: Desktop System: Gigabyte product: B450M DS3H v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: B450M DS3H-CF serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends LLC. v: F65b
    date: 09/20/2023
  Info: model: AMD Ryzen 9 3900X bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701030
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
    L3: 64 MiB desc: 4x16 MiB
  Speed (MHz): avg: 2402 high: 3630 min/max: 2200/4672 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2200 2: 2200
    3: 2200 4: 2200 5: 3168 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200
    12: 2200 13: 3592 14: 2050 15: 2200 16: 2200 17: 3426 18: 3630 19: 2200
    20: 2200 21: 2200 22: 2196 23: 2200 24: 2200 bogomips: 182057
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Sapphire Nitro+ driver: amdgpu v: kernel arch: GCN-4
    code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: DP-1 empty: DP-2, DVI-D-1,
    HDMI-A-1, HDMI-A-2 bus-ID: 07:00.0 chip-ID: 1002:67df class-ID: 0300
    temp: 51.0 C
  Device-2: Razer USA Gaming Webcam [Kiyo] driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:2
    chip-ID: 1532:0e03 class-ID: 0102
  Display: wayland server: v: with: Xwayland v: 23.2.4
    compositor: Hyprland v: 0.35.0-13-ge4bb5fa4 driver: X: loaded: amdgpu
    unloaded: modesetting alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    display-ID: 1
  Monitor-1: DP-1 model: Samsung C27HG7x serial: <filter> built: 2017
    res: 2560x1440 hz: 144 dpi: 109 gamma: 1.2 scale: 1
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  API: Vulkan v: 1.3.276 layers: 3 device: 0 type: discrete-gpu name: AMD
    Radeon RX 590 Series (RADV POLARIS10) driver: mesa radv v: 23.3.5-arch1.1
    device-ID: 1002:67df surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.3.5-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Sapphire driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 07:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Razer USA Gaming Webcam [Kiyo] driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:2
    chip-ID: 1532:0e03 class-ID: 0102
  API: ALSA v: k6.7.4-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL8152 Fast Ethernet Adapter driver: r8152 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:5 chip-ID: 0bda:8152
    class-ID: 0000 serial: <filter>
  IF: enp2s0f0u6 state: down mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:4
    chip-ID: 0a12:0001 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.0
    lmp-v: 6 status: discoverable: no pairing: no class-ID: 6c0104
  Local Storage: total: 1.62 TiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Seagate model: XPG GAMMIX S5
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: V9002s45 temp: 35.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSD G5 BICS4
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 00WD scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: WDC WDS240G2G0A-00JH30
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 0400 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: SanDisk model: SDSSDH3 500G
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 20RL scheme: GPT
  ID-5: /dev/sdd maj-min: 8:48 vendor: SanDisk model: USB 3.2Gen1
    size: 28.67 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: 1.00 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.26 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 24 dev: /dev/zram0
  System Temperatures: cpu: 49.1 C mobo: 36.0 C gpu: amdgpu temp: 51.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 1644
  Memory: total: 32 GiB available: 31.26 GiB used: 3.36 GiB (10.7%)
  Processes: 444 Power: uptime: 2m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 12.47 GiB Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1255 libs: 365 tools: pacseek,paru Compilers:
    gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.0 running-in: foot
    inxi: 3.3.33
Garuda (2.6.23-1):
  System install date:     2024-02-12
  Last full system update: 2024-02-12 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       <superuser required>
  Failed units:            garuda-live-keyring.service 
CPU = Ryzen 9 (Matisse) AM4 (PGA-1331) 12 core 24 threads
MOBO = GA B450M DS3H-CF / BIOS F65b (09/20/2023)
RAM = 32 gb
GPU = AMD RX 590 8GB / Ellesmere, PCIe Gen3x16

I’ve been using the December iso’ that the link is provided thru the main website downloads without any problems, installs and then boots up nicely.

After trying to use newer community iso’s thru the maintainers (@SGS / @Ankur / etc) from here

(and it happened today, Feb’18th iso, and on Feb’ 11 and Feb’ 12 iso’s that are no longer available)

The following where tested on desktop not virtual machine of any kind, many (many) times on the nvme and today on ext usb ssd disk

  1. Booting the iso thru clean ventoy usb (also tried MediCat USB ventoy, same results, also same via balenEtcher method)

  2. Booting in normal and not grub2 mode


  1. Set’ed up my tz (i’m from Greece), and booted with open source drivers into the installer (a couple of days back i also tried the nvidia option for the fun of it, same result)

  2. As per latest iso’s …


Calamares display’s 2x American English instead of one, that wasn’t there on December ISO, but who cares, it works, it installs just fine.

  1. After successfull install, calamares asks for a reboot, and i did and i interupted the mobo booting process to select my disk and also grub to display the boot commands that are as follows


  1. The only thing i removed was the “quiet” so i can see why it doesn’t go thru with the normal boot sequence … and what i get is →


  1. I’ve tried tampering with the boot flags enough to have spent more than a whole day trying, by installting again and again on the nvme and today on the ext disk.

None of the latest community built iso’s of February will boot after successfully installing the system. But if i use the December iso it works as expected.

My system if fairly good and never had any problems with other installations of Garuda (kde, dragonized) and other distro’s (i’ve distro-hoped like crazy the last couple of months :stuck_out_tongue: )

I’m left posting here, hoping someone may have had the same problem and found a way to bypass/fix it.

1 Like

Could you try install multiple kernels like (linux/linux-hardened) and see if this error would be reproduced with them?

Not a solution to your problem, but sort of just troubleshooting.

Seems the ISO works.

Hello everyone,

i have exactly the same problem with the current version from 18.02.2024.

thought at first it was just the hyprland iso but had the same problem at the weekend with a current
dr460nized version of it but unfortunately I don’t have a log file.

so the last relatively current version of hyprland that i can install on my system is from 13.12.2023

i have a log file from the install today and my inxi

edit 1

here is the install log from the 13.12.2023 iso maybe it helps


Maybe @dalto or @dr460nf1r3 can check if calamares fail, the problem is, it works for other users.

No EFI system

from chroot

[root@garuda-hyprland /]# parted -l | grep -iE "^Disk /|esp" | grep -B1 esp
Disk /dev/nvme0n1: 2000GB
 1      2097kB  317MB   315MB   fat32              boot, esp
[root@garuda-hyprland /]# lsblk -o name,type,fstype,size,uuid,mountpoint
loop0       loop         16.1M
loop1       loop        396.6M
loop2       loop          1.2G
loop3       loop          748M
sda         disk        232.9G
`-sda1      part        232.9G
sdb         disk        120.3G
|-sdb1      part        120.2G
| `-ventoy  dm            2.4G
`-sdb2      part           32M
zram0       disk         31.1G      [SWAP]
nvme0n1     disk          1.8T
|-nvme0n1p1 part          300M      /boot/efi
`-nvme0n1p2 part          1.8T      /var/tmp
[root@garuda-hyprland /]# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=garuda --recheck
Installing for x86_64-efi platform.
Installation finished. No error reported.
[root@garuda-hyprland /]# update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-zen.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdb2.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb2.  Check your
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
No snapshots found.
If you think an error has occurred, please file a bug report at ""
Unmount /tmp/grub-btrfs.DMvrBUMIXx .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
[root@garuda-hyprland /]# cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=B372-375D                            /boot/efi      vfat    defaults,noatime 0 2
UUID=e55ae2b4-0af3-48cd-8f76-be9a1fd4fddc /              btrfs   subvol=/@,defaults,noatime,compress=zstd 0 0
UUID=e55ae2b4-0af3-48cd-8f76-be9a1fd4fddc /home          btrfs   subvol=/@home,defaults,noatime,compress=zstd 0 0
UUID=e55ae2b4-0af3-48cd-8f76-be9a1fd4fddc /root          btrfs   subvol=/@root,defaults,noatime,compress=zstd 0 0
UUID=e55ae2b4-0af3-48cd-8f76-be9a1fd4fddc /srv           btrfs   subvol=/@srv,defaults,noatime,compress=zstd 0 0
UUID=e55ae2b4-0af3-48cd-8f76-be9a1fd4fddc /var/cache     btrfs   subvol=/@cache,defaults,noatime,compress=zstd 0 0
UUID=e55ae2b4-0af3-48cd-8f76-be9a1fd4fddc /var/log       btrfs   subvol=/@log,defaults,noatime,compress=zstd 0 0
UUID=e55ae2b4-0af3-48cd-8f76-be9a1fd4fddc /var/tmp       btrfs   subvol=/@tmp,defaults,noatime,compress=zstd 0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
[root@garuda-hyprland /]# lsblk -f
| `-ventoy
zram0                                              [SWAP]
|-nvme0n1p1                          298.8M     0% /boot/efi
`-nvme0n1p2                            1.8T     0% /var/tmp
[root@garuda-hyprland /]# efibootmgr
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0000,0004,0005
Boot0000* garuda	HD(1,GPT,937971b1-5bec-4ca3-ab5f-11314ba2880f,0x1000,0x96000)/\EFI\garuda\grubx64.efi
Boot0004* UEFI: SanDisk SanDisk 3.2 Gen1DL17, Partition 2	PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(1,0)/HD(2,GPT,d0abff5d-50cf-c5e9-df69-01d1caf913aa,0xf07ffd8,0x10000)0000424f
Boot0005* UEFI OS	HD(1,GPT,937971b1-5bec-4ca3-ab5f-11314ba2880f,0x1000,0x96000)/\EFI\BOOT\BOOTX64.EFI0000424f
[root@garuda-hyprland /]#
1 Like

Did you come up with anything?
I had the same issue last weekend. I haven’t tried with the ISO from the 22nd yet.

1 Like

no unfortunately not, even different kernels do not change the error message which remains the same.

i haven’t tested the new iso yet, maybe tomorrow when i have time.

Good news, the 240222 ISO works.
I tried it using manual partitioning & with the erase disk option. Both methods boot normally afterwards.


Will be tested this weekend! Thank you for reporting it!

Maybe calamares doesn’t call the partitioning sub-process properly in latest revisions ?

I got the same error as in OP

Will try manual partitioning tomorrow

I have just tried again with the iso from 29.02.2024 and it works.
but only if I partition manually
I did it like this

/boot/efi      300MB
/boot         1024MB
/             the rest 

the iso from last december worked without the /boot partition.


 ╰─λ lsblk -o name,type,fstype,size,uuid,mountpoint
NAME        TYPE FSTYPE   SIZE UUID                                 MOUNTPOIN
sda         disk        232,9G                                      
└─sda1      part ext4   232,9G c514dcce-1c9f-45d4-8bdd-dd9adfde6324 
sdb         disk        120,3G                                      
├─sdb1      part exfat  120,2G 2EC8-8CDD                            
└─sdb2      part vfat      32M 3F32-27F5                            
zram0       disk         31,1G                                      [SWAP]
nvme0n1     disk          1,8T                                      
├─nvme0n1p1 part vfat     301M 9F9C-D43B                            /boot/efi
├─nvme0n1p2 part vfat       1G 9EBD-8FBF                            /boot
└─nvme0n1p3 part btrfs    1,8T e0b1dcee-2ccc-454c-a45b-16ab07b6667d /var/tmp
1 Like

Just asking, can someone who have installed Feb ISO of garuda Hyprland and not able to login can use tty and then replace hyprland-git xdg-desktop-portal-hyprland-git wlroots-git to their non-git versions and then try to log in ??

1 Like

hi, i can test it, but since i have no problems with the login, it probably won’t help you.

I didn’t manually partition, instead I installed it next to my current install.
resulting in this partition table.
And this doesn’t boot hyprland. dragonized kde garuda, no problem.

NAME        TYPE FSTYPE   SIZE UUID                                 MOUNTPOIN
nvme0n1     disk          1,8T                                      
├─nvme0n1p1 part vfat     100M 0A63-6F70                            
├─nvme0n1p2 part           16M                                      
├─nvme0n1p3 part ntfs     1,8T 52E6691BE6690099                     
└─nvme0n1p4 part ntfs     522M BC6EC7D76EC7891A                     
nvme1n1     disk          1,8T                                      
├─nvme1n1p1 part vfat     300M 09EA-3511                            /boot/efi
├─nvme1n1p2 part btrfs  914,2G d2b955fb-a894-4104-918e-c396f6eaa41f /var/tmp
├─nvme1n1p3 part swap    34,4G 7b733153-98bd-4124-9c44-3ec296a201da [SWAP]
└─nvme1n1p4 part btrfs  914,2G c6e3560c-1b2f-4e2b-9437-b4e6636cab12 

nvme0n1 contains my windows
nvme1n1 contains both garuda linux installs

Why is our main partition mounted under /var/tmp.
shouldn’t it be / ?

1 Like

Installed on an optiplex, nothing else on the ssd.
Worked without problems

1 Like

Actually some while ago after updating my system I faced the log in problem so that’s why I asked , I was able to make my system workable again by simply replacing those packages from git to non-git once


tried the march iso, straight up erased the disk instead of install next to it.
Still doesn’t work.

It did work on an optiplex.
I feel that it’s hardware related, but I wouldn’t know what exactly.

Please, open new help request and follow the template.
Use live ISO to post your garuda-inxi.

1 Like

try it like i did with an extra /boot partition that should actually work.

this is the only way it works for me at the moment with the installation whether it is the hyprland or dr460nized iso does not matter for me without the extra /boot partition it does not work.


i can’t answer why this is the case with me or us, my knowledge is not sufficient for that, at most i have better basic knowledge. :grin:

but if creating an extra /boot partition is all it takes then i can live with it :crazy_face:

1 Like