Garuda Hyprland Feb ISO's won't boot after install

FWIW, I’ve been running various garuda linux variants for a couple years, mostly sway and hyprland since they became available. I have two nearly identical Acer Swift 3 with AMD Ryzen 7 4700U with Radeon Graphics, one has 8 GB RAM, the other 16 GB RAM. I’ve not been able to install and boot either hyprland or Sway variants for a few months. I download the ISOs in pairs and install on each of these two machines, where I’d run sway for years previously without issue. There is definitely a root cause shared by these variants, whatever it is. I just did this today on both and both failed. I’m sure the manual partitioning works fine as I’ve done that before. But I don’t feel safe enough to continue working on either when the install is so flaky. I’ll try last year’s iso again too but I’ve seen that fail similarly. Hope the hardware information helps with debugging. I don’t have any other spare boxes to install on or I’d A/B test on Intel just for kicks.

Is your SATA controller set to AHCI mode?

There is not enough information here to know what’s going on (specifically: how is the installation failing?), but probably you should open a separate topic so we can dig in a bit more without derailing this discussion.

1 Like

Thanks for your response. Sorry for the oversight. SATA has been set to AHCI mode for years and is now. The installation completed successfully with no errors; however, upon reboot, the GUI boot mode would appear, hit enter on Garuda Linux, then it would power cycle and the TUI boot mode would apper, hit enter on Garuda Linux again, then it would power cycle again and crash on boot with “Loading Linux linux-zen… Loading initial ramdisk… error: you need to load the kernel first. Press any key to continue…” but it was frozen and only functioned by holding the power key to power off.Thanks for your help.

What is your method for preparing the installation media? Ventoy, dd, etc.

What installation method are you using (erase disk, install alongside, etc)? Is the installer setting up an EFI partition, or installing in legacy/BIOS mode?

What is the keyboard layout you have selected in the installer?

What is the TUI boot mode? Is it Grub, or something else? What options do you see in it? Maybe you can take a picture.


Same issue here.
Clean install on nvme drive.
March iso on a ventoy usb. Installs fine but upon reboot it is dead.
All amd system 7950x cpu, 7900xtx gpu and 32gigs ram.

Older iso’s before 2024 have worked just fine. March 9 iso had the issue.

Please, can you check the size of initramfs?

ls -la /boot/
drwxr-xr-x    - root 11 Mär 11:07  .
drwxr-xr-x    - root 23 Jan 19:14  ..
drwxr-xr-x    - root  6 Jul  2023  efi
drwxr-xr-x    - root 12 Mär 11:13  grub
drwxr-xr-x    - root  9 Jan 03:04  memtest86+
.rw-------  61M root 11 Mär 11:07  initramfs-linux-zen-fallback.img
.rw-------  19M root 11 Mär 11:07  initramfs-linux-zen.img
.rw-r--r-- 7,4M root  1 Feb 17:16  intel-ucode.img
.rw-r--r--  14M root 11 Mär 11:07  vmlinuz-linux-zen
1 Like

Having same problem, after installing Hyprland (latest March iso) and rebooting, I get to:

Loading linux-zen
Loading initial ramdisk

But eventually I get thrown back to Grub. Also at this point, selecting anything in grub just goes to a black screen and then laptop reboots and then I can select the Garuda KDE entry and can boot without issues!


ls -la /boot/
drwxr-xr-x   - root 14 Mar 23:55  .
drwxr-xr-x   - root  8 Mar 13:58  ..
drwxr-xr-x   - root  1 Jan  1970  efi
drwxr-xr-x   - root 15 Mar 13:31  grub
drwxr-xr-x   - root  8 Mar 14:03  memtest86+
.rw-r--r-- 82k root 13 Mar 17:04  amd-ucode.img
.rw------- 44M root 12 Mar 20:02  initramfs-linux-xanmod-fallback.img
.rw------- 22M root 12 Mar 20:01  initramfs-linux-xanmod.img
.rw-r--r-- 11M root  8 Mar 14:07  vmlinuz-linux-xanmod


Kernel: 6.7.9-x64v-xanmod1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: hpet avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-xanmod
root=UUID=54c5c7d7-38c7-4d58-af2f-6a9b1cfed11b rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.2 tk: Qt v: N/A info: frameworks v: 6.0.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: LENOVO product: 80XV v: Lenovo ideapad 320-15AST
serial: <superuser required> Chassis: type: 10 v: Lenovo ideapad 320-15AST
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <superuser required>
part-nu: LENOVO_MT_80XV_BU_idea_FM_ideapad 320-15AST
uuid: <superuser required> UEFI: LENOVO v: 5PCN15WW date: 06/01/2017
ID-1: BAT0 charge: 27.7 Wh (96.5%) condition: 28.7/35.0 Wh (82.1%)
power: 8.6 W volts: 8.2 min: 7.5 model: SMP L16M2PB2 type: Li-poly
serial: <filter> status: discharging
Info: model: AMD E2-9000 RADEON R2 4 COMPUTE CORES 2C+2G bits: 64 type: MCP
arch: Excavator level: v3 note: check built: 2015 process: GF 28nm
family: 0x15 (21) model-id: 0x70 (112) stepping: 0 microcode: 0x6006704
Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 192 KiB
desc: d-2x32 KiB; i-2x64 KiB L2: 2 MiB desc: 2x1024 KiB
Speed (MHz): avg: 1197 min/max: 1200/1800 boost: enabled scaling:
driver: acpi-cpufreq governor: powersave cores: 1: 1197 2: 1197
bogomips: 7186
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Lenovo
driver: amdgpu v: kernel arch: GCN-3 code: Volcanic Islands
process: TSMC 28nm built: 2014-19 ports: active: eDP-1 empty: HDMI-A-1
bus-ID: 00:01.0 chip-ID: 1002:98e4 class-ID: 0300
Device-2: Syntek EasyCamera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.3:4 chip-ID: 174f:241a
class-ID: 0e02
Display: wayland server: v: with: Xwayland v: 23.2.4
compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
Monitor-1: eDP-1 res: 1366x768 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: radeonsi
wayland: drv: radeonsi x11: drv: radeonsi
API: OpenGL v: 4.5 vendor: amd mesa v: 24.0.3-arch1.1 glx-v: 1.4
direct-render: yes renderer: AMD Radeon R2 Graphics (radeonsi stoney LLVM
17.0.6 DRM 3.57 6.7.9-x64v-xanmod1-1) device-ID: 1002:98e4 memory: 500 MiB
unified: no display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 3 device: 0 type: integrated-gpu name: AMD
Radeon R2 Graphics (RADV STONEY) driver: mesa radv v: 24.0.3-arch1.1
device-ID: 1002:98e4 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.0.3-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:01.1
chip-ID: 1002:15b3 class-ID: 0403
Device-2: AMD Family 15h Audio vendor: Lenovo driver: snd_hda_intel
v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a class-ID: 0403
API: ALSA v: k6.7.9-x64v-xanmod1-1 status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 01:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 1000
bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.2:3 chip-ID: 0cf3:e500
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 4.2 lmp-v: 8
status: discoverable: no pairing: no
Local Storage: total: 931.51 GiB used: 15.18 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: LVM2 scheme: GPT
ID-1: / raw-size: 488.05 GiB size: 488.05 GiB (100.00%)
used: 11.16 GiB (2.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 62.5 MiB (20.9%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 488.05 GiB size: 488.05 GiB (100.00%)
used: 11.16 GiB (2.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 488.05 GiB size: 488.05 GiB (100.00%)
used: 11.16 GiB (2.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 488.05 GiB size: 488.05 GiB (100.00%)
used: 11.16 GiB (2.3%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
zswap: no
ID-1: swap-1 type: zram size: 7.16 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 2 dev: /dev/zram0
System Temperatures: cpu: 39.2 C mobo: N/A gpu: amdgpu temp: 39.0 C
Fan Speeds (rpm): N/A
Memory: total: 8 GiB note: est. available: 7.16 GiB used: 2.34 GiB (32.7%)
Processes: 258 Power: uptime: 26m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 2.85 GiB services: org_kde_powerdevil,upowerd
Init: systemd v: 255 default: graphical tool: systemctl
Packages: pm: pacman pkgs: 1283 libs: 384 tools: paru Compilers:
gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.0 running-in: konsole
inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2024-03-02
Last full system update: 2024-03-15 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

If they are not deleted yet, we need the hyprland data, we don’t offer this kernel :slight_smile:


How do I do that? :face_with_peeking_eye:
(genuin question as with the current knowledge I have, I will have to get into tty to do that?)

1 Like

It is a dual boot, right?

Just mount/open with a file browser, copy the path to boot.
Here it is /run/media/sgs/Hyprland/@/boot/

ls /run/media/sgs/Hyprland/@/boot/
drwxr-xr-x    - root 13 Dez  2023  efi
drwxr-xr-x    - root 14 Mär 12:29  grub
drwxr-xr-x    - root  9 Jan 16:51  memtest86+
.rw-r--r--  82k root 13 Mär 12:34  amd-ucode.img
.rw-------  44M root 12 Mär 14:10  initramfs-linux-amd-znver3-fallback.img
.rw-------  19M root 12 Mär 14:10  initramfs-linux-amd-znver3.img
.rw-r--r-- 3,7M root 12 Mär 11:02 
.rw-r--r--  11M root 12 Mär 14:10  vmlinuz-linux-amd-znver3
ls /run/media/archit/0220aae6-5ded-473d-8278-6967e4ed66b9/@/boot/
drwxr-xr-x   - root 15 Mar 12:57  efi
drwxr-xr-x   - root 15 Mar 13:09  grub
drwxr-xr-x   - root  9 Mar 16:54  memtest86+
.rw-r--r-- 82k root 21 Feb 01:00  amd-ucode.img
.rw------- 19M root 15 Mar 13:07  initramfs-linux-zen.img
.rw-r--r-- 14M root  9 Mar 16:54  vmlinuz-linux-zen
1 Like

I have used both ventoy and etcher

And i have used both erase disk and install next to

In all cases it doesn’t boot.
Only when manually creating the partitions does it work

It is a dual boot but windows is on a seperate nvme drive

1 Like

Seems like I gotta try this then :eyes:

1 Like

Since I had joined this conversation 20 days ago and replied back and forth with SGS on the subject here, I thought I owed it to those who had helped me when I reported that I’d not had much luck working with any of the Garuda iso variants that I use after 1/1/24, including Sway and Hyprland while the October 23 iso’s continued to work. The problem seemed to stem from selection of the automatic disk partitioning and formatting along with swap creation.

The good news is this: today I was able to boot and install a USB stick burnt from popsicle on my Garuda Sway box (none of this has changed since I discovered popsicle via a question here a couple years ago, specifically the build dated 3/25/24 from the iso community builds here:

I’m not sure what the issue was but these same Acer Ryzen variants continued booting and installing with the other Garuda iso builds, as long as I partitioned and formatted the disk manually. The problem was always the same, install worked flawlessly, then after completion, the machine failed to boot, and entered an endless loop cycle when boot failed.

I’m happy to report that I have Garuda Hyprland booted and working flawlessly installed from the 3/25 iso linked above.

Not sure if git bisect between the prior revision delta would help here. This is likely a needle in a haystack, but the outcome was the same every time through dozens of installs across two machines identical save for RAM configuration - the Acer Ryzens in question.

My eyes are thankful given font rendering alone is better and I’m an older person wearing bi-focals.

Hope this helps someone, somewhere.



As i personally reported to @SGS yes the 240325 iso works as expected.
perfectly installed and booted directly into the system!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.