Garuda doesn't boot after changing GPU

I just upgraded my GPU to an AMD RX 6800. Now I can't boot Garuda, the grub appears but after that it just won't boot. I thought the problem was the tkg kernel but I tried it with the default one and it didn't work too. I am writing this from windows 10 and it works perfectly. Unfortunately I can't upload garuda-inxi from obvious reasons.

change from what?

If you've changed from Nvidia (or haven't used an AMD card before in general) and using Xorg it could be that you need the xf86-video-amdgpu package to use the GPU. If that is the case, boot into Garuda-install-medium, chroot into the installation and install the package.

Can you boot with nomodeset parameter?

I'd try with MHWD (either chrooting or booting to a TTY).
Assuming (from your previous topics) you had a Nvidia card, I'd try:

sudo mhwd -r pci video-nvidia-dkms
sudo mhwd -i pci video-linux

Before the first command, maybe you'd better check what you have installed with

mhwd -li

To remove everything Nvidia-related.


I tried everything you told me but nothing worked, still can't boot.

Were there any error messages?
Could you chroot from the live USB and provide

mhwd -li

There were no error messages

> Installed PCI configs:
NAME               VERSION          FREEDRIVER           TYPE
video-linux            2021.08.29                true            PCI

Do you have anything Nvidia related in xorg, like /etc/X11/xorg.conf.d/20-nvidia.conf ?
Maybe also look into /etc/X11/xorg.conf
After that, if you are still unable to boot, you could try the configuration like here

1 Like

This is my /etc/X11/xorg.conf file

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 515.48.07

Section "ServerLayout"
Identifier     "Layout0"
Screen      0  "Screen0" 0 0
InputDevice    "Keyboard0" "CoreKeyboard"
InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

Section "InputDevice"

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

Section "Monitor"
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "Unknown"
Option         "DPMS"

Section "Device"
Identifier     "Device0"
VendorName     "NVIDIA Corporation"
ChipId          0x0
ChipRev         0x0
IRQ             0

Section "Screen"
Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Coolbits" "8"
SubSection     "Display"
Depth       24

I don't have any /etc/X11/xorg.conf.d/20-nvidia.conf file
Sorry, I don't know why it didn't copied it all.

I just rebooted and now it works, I created a conf file as it says on the link you gave me.
Thank you!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.