Garuda breaks after update

After updating and reboot all works fine. Shutdown and restart later the following happens:-
No networks available, network icon in panel is red, no networks configured. Manually configure no response.
Timeshift not opening. Attempted to use to rollback. Not opening from menu or start screen or dock.
Sudo command not working. Tried to rollback from command line. Sudo not responding wrong pid etc.
maybe other things as well but this is the second time this has happened. First reinstalled and all ok. Then faults as above.. I do not have enough experience as yet to troubleshoot these.
Anyone give me some clues? Have tried to search in wiki but no answers I can see. (maybe wrong search terms). Sending this via backup Arco system.
Thanks

Read

please
and post

inxi -Fza

and
:slight_smile:

2 Likes

Try booting to a snapshot from GRUB. If it boots, restore it.

2 Likes

Tried that as explained. Timeshift does not open to enable restore.

Not sure if this is a bug or just a prob on my system as I have not seen any other report on this. As explained I know about snapshots but system will not let me restore one.
Thanks for the welcome.

1 Like

No. What you explained was different than what I asked.

I asked,

*At GRUB BOOT SCREEN

Did this also fail?

2 Likes

Understood. Maybe I didn't explain properly. Sorry. Selected snapshot from grub screen, selected kernel and booted. After booting system (popup) told me to restore. That's when I found that timeshift was not responding, neither was it possible from command line.
Does that make sense.

OK. Please post what SGS asked:

inxi -Fza
2 Likes

Will do, Have to reboot into garuda.

╭─[email protected] in ~ took 503ms
[🔍] × inxi -Fza
System:    Kernel: 5.12.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=3519364a-0880-40f0-8c83-df3ee6d48001 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.22.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B460M PRO (MS-7C88) v: 1.0 serial: <filter> 
UEFI: American Megatrends v: 1.50 date: 10/16/2020 
CPU:       Info: 6-Core model: Intel Core i5-10400 bits: 64 type: MT MCP arch: Comet Lake family: 6 
model-id: A5 (165) stepping: 3 microcode: EA cache: L2: 12 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 69597 
Speed: 800 MHz min/max: 800/4300 MHz Core speeds (MHz): 1: 800 2: 800 3: 4055 4: 3298 5: 2449 
6: 1771 7: 1121 8: 800 9: 800 10: 800 11: 800 12: 800 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: Micro-Star MSI driver: i915 
v: kernel bus-ID: 00:02.0 chip-ID: 8086:9bc8 class-ID: 0300 
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: intel 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: DP1 res: 1920x1080 hz: 60 dpi: 102 size: 480x270mm (18.9x10.6") diag: 551mm (21.7") 
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CML GT2) v: 4.6 Mesa 21.1.2 direct render: Yes 
Audio:     Device-1: Intel vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
alternate: snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a3f0 class-ID: 0403 
Sound Server-1: ALSA v: k5.12.12-zen1-1-zen running: yes 
Sound Server-2: JACK v: 0.125.0 running: no 
Sound Server-3: PulseAudio v: 14.2 running: no 
Sound Server-4: PipeWire v: 0.3.30 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI 
driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: enp2s0 state: down mac: <filter> 

Hope this is ok


If you include terminal outputs in your post please use the proper output format in your post. Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Ok. Please be aware that garuda install has no networking or internet at present. Had to run command and save to a usb stick to transfer and post from arco install.

1 Like

No problem but there are only ~~~ in first and last line.
That must work on arco too :wink:

1 Like

Maybe you could try using a live USB.
You could see if timeshift works from there.
Alternatively. you could try to chroot from the live USB and try to execute the restore from terminal after chrooting.

4 Likes

Will try that. Back soon.

1 Like

Tried both methods. no joy. Keeps asking me to restore snapshot but timeshift still not responding.

Just a stupid idea... The sudo not working sounds crucial to me here...
Did you happen to use chown lately, and maybe unwillingly changing ownership of files or folders owned by root?

4 Likes

no. First install worked for about 6+ months. Reinstall worked until first update. beginning to think it may be authentication problems as I could not open my arco install in thunar which always worked before.
Me now very confused, out of my limited depth, but loving it.
Many thanks to all.

Timeshift not opening, sudo not working, etc. seems you are not logged into admin account. Are you sure you didn't log into guest account or any other?

4 Likes

Can you log into root?

2 Likes

No. Have autologin enabled and unable to change, same reason authentication failure. User always states terry (me).
Have just been informed that I have reached new user limit. Will post any other answers tomorrow.
Many thanks to all.