Garuda black-arch audio not work

I have dual boot windows 10 and garuda dragonized kde blackarch. Tried to install and remove all combination of pipewire, pulseaudio and alsa, nothing.

System:
Kernel: 5.16.0-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3d996005-fa9e-48ea-b470-56234a98cdc6 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 intel_pstate=disable
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: LightDM 1.30.0, SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Micro-Star product: GP75 Leopard 9SD v: REV:1.0
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Micro-Star model: MS-17E2 v: REV:1.0 serial: <superuser required>
UEFI: American Megatrends v: E17E2IMS.10E date: 03/28/2019
Battery:
ID-1: BAT1 charge: 39.2 Wh (100.0%) condition: 39.2/51.6 Wh (76.0%)
volts: 12.0 min: 10.9 model: MSI BIF0_9 type: Li-ion serial: N/A
status: Full
CPU:
Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 2600 min/max: N/A cores: 1: 2600 2: 2600 3: 2600
4: 2600 5: 2600 6: 2600 7: 2600 8: 2600 9: 2600 10: 2600 11: 2600 12: 2600
bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile]
vendor: Micro-Star MSI driver: nvidia v: 495.46
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2191
class-ID: 0300
Device-3: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 1-13:5
chip-ID: 5986:211c class-ID: 0e02
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: modesetting,nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 128
size: 381x214mm (15.0x8.4") diag: 437mm (17.2")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a348 class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:1aeb
class-ID: 0403
Sound Server-1: ALSA v: k5.16.0-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.20 running: no
Sound Server-4: PulseAudio v: 15.0 running: no
Sound Server-5: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet
vendor: Micro-Star MSI driver: alx v: kernel port: 3000 bus-ID: 05:00.0
chip-ID: 1969:e0a1 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
driver: btusb v: 0.8 bus-ID: 1-14:6 chip-ID: 8087:0aaa class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 1.61 TiB used: 44.49 GiB (2.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Silicon Power
model: SPCC M.2 PCIe SSD size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: ECFM22.5 temp: 40.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Kingston
model: RBUSNS8154P3256GJ size: 238.47 GiB block-size: physical: 512 B
logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
rev: E8FK11.C temp: 44.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: SDM1
scheme: GPT
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 44.49 GiB (9.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 580 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 44.49 GiB (9.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 44.49 GiB (9.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 44.49 GiB (9.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.42 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 61.0 C pch: 58.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 335 Uptime: 0m wakeups: 1 Memory: 15.42 GiB
used: 2.56 GiB (16.6%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 2261 lib: 422 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.11

Is the audio working in the lockscreen? Check with your media & volume buttons.

I tried with browser, with telegram, and with keyboard shortcut, nothing works.
If i install alsa i put: alsamixer, switch to PCH intel audio and i have to turn on all master volume. Alsactl store works, but REstore not.

Why aren't you trying what I'm just asking? Use your keyboard volume buttons, and check if audio is detected and working there or not?

Because i already said that nothing works. All audio is detected, nothing sound on.

It's not working even on lockscreen? Because I have faced it a lot, sound works properly in my login screen but not anymore after logging in.

In the lockscreen i look the "100%" of volume bar, if i go up remain the same of when i turn down, my english is very bad, sorry. Audio doesn't work

Well, as I'm not a black-arch user, let's see what others say. Devs kindly help him @sgs @dr460nf1r3 @librewish

Do not ping admins, its rude.
Black-Arch is not supported like barebones.

You are on your own.

Times change :slight_smile:

5 Likes

Sorry, sir, didn't know that. Apology.

1 Like

Hi, first of all, update your BIOS. There is one update available.

I have the blackarch edition original downloadable from the official garuda site, and i have the same problem with ALL other garuda edition, i tried the kde dragonized no arch, the problem is the same.

Thank you a lot for the link, when i tried i had some toruble, i will try again.

Also, after updating BIOS, if it is not fixed, see discussion

https://bugzilla.kernel.org/show_bug.cgi?id=204159

It is very similar to your issue.

Sadly, as there are a lot of different MSI products and not much Linux users, and generally proprietary hardware, it is not very easy to find solutions for a particular model. Also msi doesn't have very good Linux support at all.

But I guess they must have used same audio device in particular series laptops in particular generation.

I tried to upload the error mex of the updating firmware, i will try with other method, thank you for all this infos, with archlinux or other distro i never had this problem... i tried around 15 / 20 distros

Have you already tried with a different kernel, e g. linux-lts?

4 Likes

You should have told this earlier, I guess.

So, try different kernel, like Linux-LTS and the kernel used in your earlier Arch installation.

PS: I and @ filo posted at same time. I swear I didn't copy him :sweat_smile:

5 Likes

i don't know much things about kernel, i tried to start garuda with hardened or linux mainline, i don't know what can change, and then i did a total system update, nothing

We just can read each other mind. Nothing strange... :smiley:

1 Like

Filo ho visto solo ora che sei italiano, scusami ahaha. Con kernel LTS niente, scrivo in inglese per l'altra persona, o ci provo.
Now i have pipewire, if i write "pipewire" in terminal: [E][00438.782981] mod.protocol-native | [module-protocol-: 610 lock_socket()] server 0x563d736a6c60: unable t
o lock lockfile '/run/user/1000/pipewire-0.lock': Risorsa temporaneamente non disponibile (maybe another daemo
n is running)
[E][00438.783138] pw.conf | [ conf.c: 412 load_module()] 0x563d73669800: could not load mandato
ry module "libpipewire-module-protocol-native": Risorsa temporaneamente non disponibile
[E][00438.783250] default | [ pipewire.c: 123 main()] failed to create context: Risorsa temporaneam
ente non disponibile

I installed all types of pipewire lib or packages that i found in octopus "store", nothing.
i tried to download this modules, i understood nothing XD

1 Like