Garbled text from keyboard

Hello, would appreciate some help with this. Right from install stage , almost half of alphabet on keyboard come out as numbers. The letter 'o' always comes out as a 6 etc. And yet typing from the on screen keyboard comes out as expected? I have had Deepin and Manjaro previously installed on the same system without any issues at all. Diagnosis and solution appreciated. TIA

System:
  Kernel: 5.17.2-zen3-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=96ee02a6-884f-4cde-9ce8-a545846ecfc4 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: Cinnamon v: 5.2.7 tk: GTK v: 3.24.33 wm: muffin vt: 7
    dm: LightDM v: 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Aspire S3 v: 1.13
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Acer model: Aspire S3 v: 1.13 serial: <superuser required>
    BIOS: INSYDE v: 1.13 date: 09/06/2011
Battery:
  ID-1: BAT0 charge: 4.1 Wh (100.0%) condition: 4.1/37.7 Wh (10.9%)
    volts: 12.4 min: 11.1 model: SANYO AP11D3F type: Li-ion serial: <filter>
    status: full
CPU:
  Info: model: Intel Core i5-2467M bits: 64 type: MT MCP arch: Sandy Bridge
    family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 823 high: 852 min/max: 800/2300 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 852 2: 847 3: 798
    4: 798 bogomips: 12770
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Acer Incorporated ALI driver: i915 v: kernel ports: active: LVDS-1
    empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0116
    class-ID: 0300
  Device-2: Suyin 1.3M HD WebCam type: USB driver: uvcvideo bus-ID: 1-1.5:3
    chip-ID: 064e:c321 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: intel
    unloaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 mapped: LVDS1 model: AU Optronics 0x102c built: 2011
    res: 1366x768 hz: 60 dpi: 120 gamma: 1.2 size: 290x160mm (11.42x6.3")
    diag: 336mm (13.2") ratio: 16:9 modes: 1366x768
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.2-zen3-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.50 running: yes
Network:
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Lite-On
    driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 02:00.0 chip-ID: 168c:0032 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Drives:
  Local Storage: total: 316.73 GiB used: 11.25 GiB (3.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS543232A7A384
    size: 298.09 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: A90B scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 model: SATA SSD size: 18.64 GiB block-size:
    physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter>
    rev: M011 scheme: MBR
Partition:
  ID-1: / raw-size: 18.64 GiB size: 18.64 GiB (100.00%)
    used: 11.13 GiB (59.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-2: /home raw-size: 298.09 GiB size: 298.09 GiB (100.00%)
    used: 116.9 MiB (0.0%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-3: /var/log raw-size: 18.64 GiB size: 18.64 GiB (100.00%)
    used: 11.13 GiB (59.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
  ID-4: /var/tmp raw-size: 18.64 GiB size: 18.64 GiB (100.00%)
    used: 11.13 GiB (59.7%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.69 GiB used: 256 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 48.0 C mobo: 36.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 249 Uptime: 13m wakeups: 1 Memory: 3.69 GiB
  used: 2.02 GiB (54.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: pacman: 1293 lib: 313 Shell: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.15
Garuda (2.6.1-1):
  System install date:     2022-04-13
  Last full system update: 2022-04-14
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       <superuser required>
  Snapshots:               Snapper
  Failed units:            systemd-vconsole-setup.service

Fn+F11 will toggle numlock to fix your issue.
Disabling fast boot in BIOS might help it from turning numlock on by default.

3 Likes

First off, welcome in! :wave:

If this doesn't work:

Is there anything you've already tried? What is your keyboard layout normally set to // supposed to be? Also, could you show the output of the locale command and printenv | grep LANG? This might shed some light if a variable is getting set wrong and telling something else to use the wrong locale for input, not sure.

I'm noticing:

This unit, I believe, calls loadkeys during boot which sets the at least the console keymap, so could be related. Could you share the output of cat /etc/vconsole.conf and sudo systemctl status systemd-vconsole-setup.service as well?

Next I'd try just running sudo systemctl restart systemd-vconsole-setup.service from your terminal, then check if the keyboard behavior has changed, and include anything that command spits outs when you run it.

Also relevant are the systemd logs. I'm not really a journalctl wizard so this may not be the optimum way to do this, but the output of journalctl -b --no-pager --no-hostname | grep vconsole will show all the logs since last boot containing the relevant vconsole. If it's long, put it in a pastebin instead of pasting it into the thread.

For future reference, do try to do a little digging before coming to the forums with an issue. I personally wanted to show a lil hospitality first but generally speaking just describing an issue and dropping your inxi with no indication that you've done anything is going to get you hit with significantly less helpful comments than this one. No shade, just saying - it's the nature of both small Linux communities and Arch-based communities.

6 Likes

Thanks very much for your response. Having explored many of your suggestions, it seems that changing language and locale was just close to impossible.
I tried the dragonized version for a minute, but even at setup, it was impossible to enter user name or password due to garbled text.

I am typing this in Garuda Cinnamon ,having done the following differently.

At partition stage of install I now chose Erase disk and not manual partition. Also, I have not used a separate home partition. A step or two later I have selected en_US_utf8 ignoring suggestions for my locale/language (en_NG).

You certainly helped point me in the right direction. What I wanted was a problem free installation not one i had to start hacking at from the get go.

Thanks

Oh, that's odd. I guess since you've kinda sorted it out it may not be relevant, but did you save any of those outputs I mentioned? I'm curious if they could shed a little light on what was going on.

The partitioning schema shouldn't have an impact on this, but I will say that one of the really great things about Garuda is the default filesystem configuration.

I get the desire to not want to, but if you did want to hack at it a little more for future reference/posterity - What is your physical keyboard layout? (if you're not sure, instead: is it QWERTY or something else, and what is the currency symbol and its positioning?) and, what did you select on the 1st, 2nd, and 3rd installer screens (system language, timezone, and keyboard layout) with each install?

If nothing else, glad I could at least point ya in the right direction!

1 Like

Check your laptop user manual and don't make us looking for a ghost, please. :person_shrugging:
This is a familiar case where a laptop does not have a separate full numpad, so there is a key combination or other way to swap this behavior.
PEBKAC issue.

1 Like

Here you go

```
FONT=ter-220n
KEYMAP=ng

systemd-vconsole-setup.service - Setup Virtual Console
     Loaded: loaded (/usr/lib/systemd/system/systemd-vconsole-setup.service; static)
     Active: failed (Result: exit-code) since Thu 2022-04-14 16:14:38 WAT; 19min ago
       Docs: man:systemd-vconsole-setup.service(8)
             man:vconsole.conf(5)
    Process: 276 ExecStart=/usr/lib/systemd/systemd-vconsole-setup (code=exited, status=1/FAILURE)
   Main PID: 276 (code=exited, status=1/FAILURE)
        CPU: 21ms

sudo systemctl restart systemd-vconsole-setup.service
Job for systemd-vconsole-setup.service failed because the control process exited with error code.
```

It is a US Keyboard layout but on most distributions even when locale comes up as en_NG it is still basically the US layout and in most distributions it has never been a problem. Even changing locale.conf did not have any effect, and I saw a couple of posts indicating as much.

Please read and edit your post.

Understood
Thanks

The service fails normally, since the keymap you set does not exist.
(Arch)Linux is not exactly responsible for the correctness of the used keymap, because they just use international standards. The user (in need) has to declare/find and set the desired proper keymap, which will work as designed (following ISO standards).
For keyboard layout, if your keyboard is an US/English standard keyboard, you should use en_US.UTF-8 for Xorg/GUI and us for console. For a secondary keyboard layout, follow Archwiki instructions to (first) find your proper one and then apply it as instructed in Archwiki.
Use localectl for Xorg kbd layout and, for console, add KEYMAP_TOGGLE= in vconsole.conf.
Read manuals and wikis for all the above. Sometimes GUI installers are not as smart as they declare they are. :wink:

If you have difficulties, post what you have done and failed and any questions.

2 Likes

I believe the issue arises from accepting the defaults associated with my Location/TZ setting (Lagos,NG). Accepting those defaults causes problems I have not experienced in Manjaro, Deepin or Mint.