Fresh install first update using garuda update

just downloaded and installed garuda . Restart. first thing update with Garuda update. Cannot update....this is the error
error: failed to commit transaction (conflicting files)
libretro-mame: /usr/lib/libretro/mame_libretro.so exists in filesystem (owned by libretro-mame-git)
Errors occurred, no packages were upgraded.

i have tried following the tutorial you offer.....it didnt work .... but im am not proficient with terminal...... i can follow specific instructions though
garuda-inxi
╭─[email protected] in ~ as :mage:[:red_circle:] × garuda-inxi
System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=184128f2-1585-459e-bc4d-b49ab568709f rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.1 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 81W1 v: IdeaPad 3 15ADA05
serial: Chassis: type: 10 v: IdeaPad 3 15ADA05
serial:
Mobo: LENOVO model: LNVNB161216 v: SDK0R32866WIN
serial: UEFI: LENOVO v: E8CN20WW date: 04/10/2020
Battery:
ID-1: BAT0 charge: 15.3 Wh (49.0%) condition: 31.2/35.0 Wh (89.1%)
volts: 7.4 min: 7.6 model: LGC L16L2PB3 type: Li-poly serial:
status: discharging cycles: 85
CPU:
Info: model: AMD Ryzen 3 3250U with Radeon Graphics bits: 64 type: MT MCP
arch: Zen/Zen+ note: check gen: 1 level: v3 note: check built: 2019
process: GF 12nm family: 0x17 (23) model-id: 0x18 (24) stepping: 1
microcode: 0x8108109
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 192 KiB desc: d-2x32 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 2312 high: 2336 min/max: 1400/2600 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2325 2: 2255
3: 2333 4: 2336 bogomips: 20761
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed mitigation: untrained return thunk; SMT vulnerable
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5 code: Vega
process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:15d8
class-ID: 0300 temp: 42.0 C
Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-5.1:5 chip-ID: 04f2:b6ce class-ID: 0e02 serial:
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x08e5 built: 2019
res: 1366x768 hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: max: 1366x768 min: 640x480
OpenGL: renderer: AMD Radeon Vega 3 Graphics (raven2 LLVM 14.0.6 DRM 3.48
6.0.2-zen1-1-zen) v: 4.6 Mesa 22.2.1 direct render: Yes
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 03:00.1 chip-ID: 1002:15de class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
driver: snd_pci_acp3x v: kernel
alternate: snd_rn_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_rpl_pci_acp6x,snd_sof_amd_renoir
pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 03:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:c822
class-ID: 0280
IF: wlp2s0 state: up mac:
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-6:4 chip-ID: 0bda:c123 class-ID: e001 serial:
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address:
Drives:
Local Storage: total: 119.24 GiB used: 15.66 GiB (13.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
model: HFM128GDHTNG-8310A size: 119.24 GiB block-size: physical: 512 B
logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial:
rev: 80070C00 temp: 30.9 C scheme: GPT
Partition:
ID-1: / raw-size: 31.31 GiB size: 31.31 GiB (100.00%) used: 15.65 GiB
(50.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 9.2 MiB
(3.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 31.31 GiB size: 31.31 GiB (100.00%) used: 15.65 GiB
(50.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 31.31 GiB size: 31.31 GiB (100.00%) used: 15.65
GiB (50.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 31.31 GiB size: 31.31 GiB (100.00%) used: 15.65
GiB (50.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 5.67 GiB used: 506.5 MiB (8.7%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 43.2 C mobo: N/A gpu: amdgpu temp: 43.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 225 Uptime: 56m wakeups: 1 Memory: 5.67 GiB used: 2.31 GiB
(40.7%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1808 libs: 510
tools: octopi,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.8-1):
System install date: 2022-12-10
Last full system update: 2022-12-10
Is partially upgraded: No
Relevant software: NetworkManager
Windows dual boot: Probably (Run as root to verify)
Snapshots: Snapper
Failed units: systemd-vconsole-setup.service

╭─[email protected] in ~ as :mage: took 2s
╰─λ

1 Like
Hidden by a moderator for incorrect instructions

Came across this error earlier too with the MAME package. Troubleshooting post from here helped as usual: Package installation says FILENAME exists in filesystem; “Failed to commit transaction (conflicting files)”

What I did was this:
sudo mv /usr/lib/libretro/mame_libretro.so /usr/lib/libretro/mame_libretro.so.backup
and then ran garuda-update again.

However, garuda-update -- --overwrite '*' should work too.

This is an issue another user on telegram had a couple minutes ago too.
Run this command in the terminal and then try updating again: sudo pacman -Rdd libretro-mame-git

NOTE: Do not blindly make -Rdd commands yourself unless you really really know what you're doing. This one is safe, however.

2 Likes

apologies TNE if I did the incorrect fix for this. I will try to see if I need to correct any files on my side.

(fixing stuff while having a fever really sucks)

Yeah, no worries, I hid your post above to make it clear people shouldn't run that.

In general, you never want to use --overwrite if two packages own the same file.

@Kayo was the mame package installed by default for you?

1 Like

Yes, I believe it was apart of the dragonized gaming edition. I seem to have both the Community's non-git variant and Chaotic's git variant both installed somehow? doubtful that was like that by default though. I can try verifying that by seeing if I can find old ISO package lists.

Edit: Did just a little digging around for now. Newer dragonized gaming editions just have libretro-mame-git. Not sure why my older installation has both.

thanks .... i was going to use octopi to remove libretro mame git.... but that was going to remove another 14 packages that mostly affected gaming

Alright, garuda-update 3.3.2 will now take care of this automatically, thanks for reporting!

@Kayo can you test this for me? In theory garuda-update should replace libretro-mame-git with libretro-mame automatically now if libretro-meta is installed.

Ok, TNE, Just ran garuda-update and got this:

looking for conflicting packages...
:: libretro-meta and libretro-mame are in conflict. Remove libretro-mame? [y/N]

libretro-mame git has been removed from octopi. there was 3 different entries for libretro mame. the git version was the garuda specific install.
now there are just 2 entries in octopi

and yes im on gaming version

Oops, should be fixed now. Can you try it again for me?

1 Like

Looks like that did it this time:

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
:: libretro-meta and libretro-mame-git are in conflict. Remove libretro-mame-git? [y/N] y

Packages (5) discord-0.0.22-1  garuda-hooks-2.9.2-1  grub-2:2.06.r403.g7259d55ff-1
libretro-mame-git-84544.5526dd0fbf6-1 [removal]  libretro-meta-1-7

Total Download Size:     64.43 MiB
Total Installed Size:   214.75 MiB
Net Upgrade Size:      -241.67 MiB

:: Proceed with installation? [Y/n]
1 Like

so....after following -rdd command i ran an update and it did so successfully.
5 mins later i used the setup assistant and updated again, this time it just said dependancy librtro meta wass missing and offered to install it. i said Yes and it did so successfully

alls good, thanks guys

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.