Flatpak No Space on Device

inxi
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "pt_BR.UTF-8",
        LC_NAME = "pt_BR.UTF-8",
        LC_MONETARY = "pt_BR.UTF-8",                                                                                                   
        LC_PAPER = "pt_BR.UTF-8",                                                                                                      
        LC_IDENTIFICATION = "pt_BR.UTF-8",                                                                                             
        LC_TELEPHONE = "pt_BR.UTF-8",                                                                                                  
        LC_MEASUREMENT = "pt_BR.UTF-8",                                                                                                
        LC_TIME = "pt_BR.UTF-8",                                                                                                       
        LC_NUMERIC = "pt_BR.UTF-8",                                                                                                    
        LANG = "en_US.UTF-8"                                                                                                           
    are supported and installed on your system.                                                                                        
perl: warning: Falling back to the standard locale ("C").                                                                              
System:                                                                                                                                
  Kernel: 5.15.65-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0                                                                  
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts                                                                                   
    root=UUID=33da784c-6400-4145-99e3-93bc3c7463b2 rw [email protected]                                                               
    quiet                                                                                                                              
    cryptdevice=UUID=5b16040e-5d39-4cd0-80b7-423ffe50eaff:luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff                                    
    root=/dev/mapper/luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff splash                                                                  
    rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 ibt=off                                                               
  Desktop: LXQt v: 1.1.0 tk: Qt v: 5.15.5 info: cairo-dock, lxqt-panel                                                                 
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux                                                                  
Machine:                                                                                                                               
  Type: Desktop Mobo: INTEL model: HM65DESK serial: <superuser required>                                                               
    UEFI: American Megatrends v: 4.6.5 date: 02/23/2019                                                                                
CPU:                                                                                                                                   
  Info: model: Intel Core i7-2620M bits: 64 type: MT MCP arch: Sandy Bridge                                                            
    gen: core 2 built: 2010-12 process: Intel 32nm family: 6                                                                           
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F                                                                                    
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 2187 high: 2660 min/max: 800/3400 scaling:
    driver: intel_cpufreq governor: performance cores: 1: 2289 2: 2660 3: 2107
    4: 1694 bogomips: 21552
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GM107 [GeForce GTX 750] driver: nvidia v: 515.65.01
    alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
    2022-07) arch: Maxwell code: GMxxx process: TSMC 28nm built: 2014-19
    pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 2 speed: 5 GT/s
    lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1381 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1360x768 s-dpi: 90 s-size: 384x300mm (15.12x11.81")
    s-diag: 487mm (19.18")
  Monitor-1: HDMI-0 res: 1360x768 hz: 60 dpi: 49
    size: 708x398mm (27.87x15.67") diag: 812mm (31.98") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 750/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
    class-ID: 0403
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0fbc class-ID: 0403
  Sound Server-1: ALSA v: k5.15.65-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.78 TiB used: 690.02 GiB (24.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 model: SATA SSD size: 55.9 GiB block-size:
    physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter>
    rev: Sb10 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3000NM0053
    size: 2.73 TiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: G00A scheme: GPT
Partition:
  ID-1: / raw-size: 558.79 GiB size: 558.79 GiB (100.00%) used: 143.05 GiB
    (25.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff
  ID-2: /boot/efi raw-size: 5.59 GiB size: 5.58 GiB (99.80%) used: 240.8
    MiB (4.2%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 558.79 GiB size: 558.79 GiB (100.00%) used: 143.05
    GiB (25.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff
  ID-4: /var/log raw-size: 558.79 GiB size: 558.79 GiB (100.00%) used: 143.05
    GiB (25.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff
  ID-5: /var/tmp raw-size: 558.79 GiB size: 558.79 GiB (100.00%) used: 143.05
    GiB (25.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-5b16040e-5d39-4cd0-80b7-423ffe50eaff
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 3.79 GiB used: 286.5 MiB (7.4%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A gpu: nvidia temp: 38 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 33%
Info:
  Processes: 234 Uptime: 36m wakeups: 0 Memory: 3.79 GiB used: 1.66 GiB
  (43.7%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1793 pacman: 1762 lib: 545
  flatpak: 31 Shell: Bash v: 5.1.16 running-in: qterminal inxi: 3.3.20
Garuda (2.6.6-2):
head: cannot open '/var/log/pacman.log' for reading: No such file or directory
  System install date:     
  Last full system update: 2022-09-09
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            shadow.service 

Hi everyone o/ I'm having a little issue with Flatpak, it says it's out of space ¿ocasionally?
Apparently I can open 1 flatpak app per login session. If I try to run bottles, fine, it runs, but then if I try to run Dust3D:

flatpak run org.dust3d.dust3d
error: Failed to write file ?/run/user/1001/.flatpak/3157103008/info.YS9VR1?: write() failed: No space left on device

And so it's the opposite, it's not an app issue, it's a flatpak one. Doesn't seem to matter if the 1st app is open or not, I opened one app, the second won't run, regardless.

I tried searching online, I found a thread on fedora about this, but it was a BIOS issue IG, I didn't fully understand xD

I also found this on reddit

But then again, I have no clue about what

tmpfs 1048576 1048504 72 100% /home/mthw/.cache

even means, let alone do something about it.

So I'm here for any insights on the stuff, if anyone faced it before or anything, I'll be amazed to hear your thoughts.

Thanks in advance : 3

1 Like

if you'll do the research flatpak and snaps are not supported on garuda :slightly_smiling_face:

2 Likes

Check available RAM before launching an application.

2 Likes

Looks like you're out of space in this temporary location.

That's showing the amount of used space in that user's .cache directory. This is not a default setup in Garuda, so it's unlikely to be helpful.

However, there was something else in the linked page that you missed, which was:

This is worth doing to check the available disk space across all areas of your system.

3 Likes

Well, the post is under unsupported stuff, so... no one is being held accountable on that matter xD
There's still a few apps that I can only get through flatpak tho

Yeah, I did, there's way more than enough ram on any case :confused:

Do you know how to clean this then?

df ; df -i
Filesystem     1K-blocks      Used Available Use% Mounted on
dev              1943196         0   1943196   0% /dev
run              1988432      9592   1978840   1% /run
/dev/dm-0      585935872 149327676 436050980  26% /
tmpfs            1988432     13588   1974844   1% /dev/shm
tmpfs            1988436      1792   1986644   1% /tmp
/dev/dm-0      585935872 149327676 436050980  26% /var/log                                                                             
/dev/dm-0      585935872 149327676 436050980  26% /srv                                                                                 
/dev/dm-0      585935872 149327676 436050980  26% /var/cache                                                                           
/dev/dm-0      585935872 149327676 436050980  26% /var/tmp                                                                             
/dev/dm-0      585935872 149327676 436050980  26% /home                                                                                
/dev/sda2        5848908    246612   5602296   5% /boot/efi                                                                            
/dev/dm-0      585935872 149327676 436050980  26% /root                                                                                
tmpfs             397684    397644        40 100% /run/user/1001                                                                       
/dev/dm-1      960106528 436021364 475240724  48% /mnt/Archieves                                                                       
Filesystem       Inodes IUsed    IFree IUse% Mounted on                                                                                
dev              485799   579   485220    1% /dev                                                                                      
run              497108   920   496188    1% /run                                                                                      
/dev/dm-0             0     0        0     - /                                                                                         
tmpfs            497108    31   497077    1% /dev/shm                                                                                  
tmpfs           1048576    29  1048547    1% /tmp                                                                                      
/dev/dm-0             0     0        0     - /var/log                                                                                  
/dev/dm-0             0     0        0     - /srv                                                                                      
/dev/dm-0             0     0        0     - /var/cache                                                                                
/dev/dm-0             0     0        0     - /var/tmp                                                                                  
/dev/dm-0             0     0        0     - /home                                                                                     
/dev/sda2             0     0        0     - /boot/efi                                                                                 
/dev/dm-0             0     0        0     - /root                                                                                     
tmpfs             99421  6054    93367    7% /run/user/1001                                                                            
/dev/dm-1      61038592 47401 60991191    1% /mnt/Archieves  

WOW why is my "tmpfs" at 100%? How can I make it less used? xD Or is that a noobie question and it should be at 100? o.o

Agent-whoogle-02-sgs-250

3 Likes

Open that location in a file manager and see what's in there.

2 Likes

Yeah, there's like 25 items, most of them folders of software stuff, like firedragon, pipewire, garuda maintenance, pulse, systemd... On the .flatpak there's like 800 bytes and the whole '1001' folder is ~350mb, but then again it tells me nothing about the issue.
Inside my .flatpak the apps have locked files like 'app', 'bus', 'info', etc, also unhelpful

My best guess would be to wipe the '1001' folder clean, but that seems far from being a wise move xD

~btw it's not like I don't want to do research, it's more like, I do the research and understand basic concepts, but far from knowing what to do. If anyone have a helpful noobie-friendly link I couldn't find, feel free to throw it at me.

This tmpfs is around 350MB total size, so it is full.

Have you made any changes to your system configuration since installing?

You can use du to get a readout of disk usage. Running it as du -h -d1 may be useful.

Apart from installing flatpak as in "paru -Su flatpak"... no, nothing, I don't even know how to modify stuff

du -h -d1
2.4G    ./.cache
6.1G    ./.config
936K    ./.icons
24K     ./.kde4
17G     ./.local
100K    ./Desktop
1.2M    ./Downloads                                                                                                                    
52K     ./Templates                                                                                                                    
4.0K    ./Public                                                                                                                       
42M     ./Documents                                                                                                                    
0       ./Music                                                                                                                        
1.9G    ./Pictures                                                                                                                     
0       ./Videos                                                                                                                       
68K     ./.pki                                                                                                                         
40K     ./.mcfly                                                                                                                       
2.1M    ./.nv                                                                                                                          
8.0K    ./.clamtk                                                                                                                      
663M    ./.firedragon                                                                                                                  
13G     ./.var                                                                                                                         
4.0K    ./.anthy                                                                                                                       
20K     ./.psensor                                                                                                                     
4.0K    ./.dvdcss                                                                                                                      
232K    ./.ssr                                                                                                                         
48K     ./.steam                                                                                                                       
0       ./3DC2Blender                                                                                                                  
64K     ./.gnome                                                                                                                       
8.0K    ./.gnupg                                                                                                                       
84K     ./.audacity-data                                                                                                               
742M    ./Games                                                                                                                        
704M    ./.wine                                                                                                                        
393M    ./.meshmixer                                                                                                                   
40K     ./.eteks                                                                                                                       
176K    ./.java                                                                                                                        
42G     .

Alright, how should I clean it up?

Firstly, it seems small.

Secondly, the du command I mentioned was intended to be run in that directory to identify where the space was being used.

1 Like

Oh my bad xD

cd /run/user/1001 ; du -h -d1

274M    ./juju-vivaldi
0       ./at-spi
0       ./gvfs
0       ./gvfsd
115M    ./juju-firedragon-jne4otsh.default-release
0       ./dconf
0       ./doc                                                                                                                          
4.0K    ./juju-firedragon-a7mtiln8.default                                                                                             
0       ./dbus-1                                                                                                                       
4.0K    ./pulse                                                                                                                        
0       ./p11-kit                                                                                                                      
0       ./keyring                                                                                                                      
0       ./gcr                                                                                                                          
0       ./gnupg                                                                                                                        
du: cannot read directory './systemd/inaccessible/dir': Permission denied                                                              
96K     ./systemd                                                                                                                      
389M    .       

Alright, seems to me like a browser problem. I tried uninstalling Vivaldi rn and then rebooting and well, it still shows up O.O

Also, should I look on how to increase the tmpfs then? Something like this (How to resize tmpfs in Linux. How to adjust available space in tmpfs… | by George Shuklin | OpsOps | Medium)?

This sounds like a Snap thing - are you using Snaps?

Or, is this profile-sync-daemon... ? :thinking:

Ahahahshshs oh no, it's my user name, Jujuba is a nickname of mine so :V my user is "juju"

It looks like your browser profiles are being held in this tmpfs area - I don't know what you have installed that is doing this, but it looks similar to profile-sync-daemon.

2 Likes

Yeah, I don't know. Perhaps it's a vivaldi thing or smth, it was pretty buggy these last few months to tell you the truth.

But anyways, I uninstalled vivaldi and it seems to have de-clogged my flatpak stuff even tho it still shows up on the du command. I'll also increase the tmpfs size to something sensible like 1gb because there are some greedy monster softwares out there and call it a day.
I think I bothered you enough for a day, Jonathon, thank you so much for keeping up with me on the issue today : 3

If you want to mark your tip about the du stuff and the resizing as a solution, feel free to do it.
[unless you want to keep digging ofc, we could look after what the profiles are doing]