[FIXED] KDE becomes unresponsive but mouse can still move

inxi -Faz
System:    Kernel: 5.13.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=cf8bfd82-2ed5-4d37-9551-1f15f1966218 rw  
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Acer product: Aspire A715-75G v: V2.03 serial: <filter>  
Mobo: CFL model: Azalea_FMS v: V2.03 serial: <filter> UEFI: Insyde v: 2.03 date: 04/08/2021  
Battery:   ID-1: BAT1 charge: 37.8 Wh (79.7%) condition: 47.4/47.9 Wh (98.9%) volts: 12.3 min: 11.4  
model: Murata AP18C4K type: Li-ion serial: <filter> status: Unknown  
CPU:       Info: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6  
model-id: 9E (158) stepping: A (10) microcode: EA cache: L2: 8 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38400  
Speed: 4101 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 4101 2: 4102 3: 4040 4: 4058 5: 4097  
6: 4100 7: 4100 8: 4101  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Acer Incorporated ALI driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
Device-2: NVIDIA TU117M vendor: Acer Incorporated ALI driver: nvidia v: 470.63.01
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f99 class-ID: 0300
Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 1-5:3 chip-ID: 04f2:b64f
class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
Sound Server-1: ALSA v: k5.13.12-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.33 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI
driver: r8169 v: kernel port: 3000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp7s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 3000 bus-ID: 08:00.0 chip-ID: 8086:2723
class-ID: 0280
IF: wlp8s0 state: up mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:5 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 15.86 GiB (3.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM512GDJTNG-8310A size: 476.94 GiB
block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
rev: 80002C00 temp: 40.9 C scheme: GPT
Partition: ID-1: / raw-size: 47.03 GiB size: 47.03 GiB (100.00%) used: 15.8 GiB (33.6%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 60.2 MiB (62.7%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 47.03 GiB size: 47.03 GiB (100.00%) used: 15.8 GiB (33.6%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 47.03 GiB size: 47.03 GiB (100.00%) used: 15.8 GiB (33.6%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 47.03 GiB size: 47.03 GiB (100.00%) used: 15.8 GiB (33.6%) fs: btrfs
dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.6 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 56.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 282 Uptime: 3m wakeups: 1 Memory: 7.6 GiB used: 2.14 GiB (28.1%) Init: systemd v: 249
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1192 lib: 295 Shell: fish
v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06




I have tried reinstalling garuda twice but it still freezes abruptly

EDIT- I managed to solve it
Apparently my Kscreen log was writing continuously and managed to hang the os
Running
"export QT_LOGGING_RULES="*=false"
Seems to fix it for now

Update
It stuck again. I initially thought it might be similar to the garuda stuck after sleep issue but this time it was stuck simply while I was trying to install a new theme

Hi there, welcome!
I'm not an expert on graphic cards, but let me try...
First thing you could try is to boot with another kernel, if available, Eg lts.
The second thing you could do is to try to fully update your system.
Can you open a terminal with ctrl+shift+t?
If not, you could boot to a TTY: press button E at the grub line you use, add a 3 (with a space before...) at the end of the line starting with linux and press ctrl+x.
Finally, I think you could also try reinstalling starting with free drivers, update and then use the Garuda assistant to install the proprietary drivers.

3 Likes

I tried Linux lts and it got stuck too, all I was doing was watching YouTube, ctrl+alt+t didn't work. Although I did manage to play/pause audio(video was stuck) via kde connect on my phone

Is the problem specific to Garuda? Could you try Manjaro if you haven't already as it is also Arch based? I won't be much help but good to know if it's across multiple Arch based distros or not.

Use htop/top in terminal, check which "app" use lot of CPU/RAM

Baloo in action?

Which GPU is used?

Good that you didn't write M$, bad that it had to be this one, what about Arch, what about EnOS?

I switched to manjaro but I had to switch back because the sweet theme integration that I got used to is a bit hard to completely implement (with Latte integration)

Because Manjaro has more support and a bigger community so likely more work done meaning likely to have drivers in place where they may be missing in pure Arch or other less used Arch based distributions. Ain't anything wrong with me suggesting Manjaro considering its popularity

Facebook is wildly popular. . .

If I were me, I'd probably avoid the big M.

edit: I do actually go on their forums - it's amazing how many help threads are there.

3 Likes

I m using a GTX 1650

I can't access htop/top when it's stuck
And after reboot it doesn't show any abnormalities

If it was memory overload, doesn't garuda have nohang already in place to deal with it?

After boot, open terminal and start htop. Not if the problem already exists.

Test

systemctl status nohang
1 Like

I think nohang might be the culprit all along

╭─[email protected] in ~ took 8ms
╰─λ systemctl status nohang
○ nohang.service - Sophisticated low memory handler
Loaded: loaded (/usr/lib/systemd/system/nohang.service; disabled; vendor preset: disabled)
Active: inactive (dead)
Docs: man:nohang(8)
https://github.com/hakavlad/nohang

how do i enable it?

systemctl enable --now nohang

read man systemctl, please :slight_smile:

5 Likes

i tried enabling nohang in autostart
after reboot when i checked

systemctl status nohang
○ nohang.service - Sophisticated low memory handler
Loaded: loaded (/usr/lib/systemd/system/nohang.service; enabled; vendor preset: disabled)
Active: inactive (dead) since Sun 2021-08-22 00:54:04 IST; 38s ago
Docs: man:nohang(8)
https://github.com/hakavlad/nohang
Process: 484 ExecStart=/usr/bin/nohang --monitor --config /etc/nohang/nohang.conf (code=exited, status=0/SUCCESS)
Main PID: 484 (code=exited, status=0/SUCCESS)
CPU: 123ms

Aug 22 00:53:51 Chris-Aspire7 systemd[1]: Started Sophisticated low memory handler.
Aug 22 00:53:51 Chris-Aspire7 nohang[484]: Starting nohang with config /etc/nohang/nohang.conf
Aug 22 00:53:51 Chris-Aspire7 nohang[484]: Monitoring has started!
Aug 22 00:54:04 Chris-Aspire7 systemd[1]: Stopping Sophisticated low memory handler...
Aug 22 00:54:04 Chris-Aspire7 nohang[484]: Got the SIGTERM signal
Aug 22 00:54:04 Chris-Aspire7 nohang[484]: No corrective actions applied in the last 12.4s
Aug 22 00:54:04 Chris-Aspire7 nohang[484]: Process time: 0.11s (average: 0.89%); exit.
Aug 22 00:54:04 Chris-Aspire7 systemd[1]: nohang.service: Deactivated successfully.
Aug 22 00:54:04 Chris-Aspire7 systemd[1]: Stopped Sophisticated low memory handler.

╭─[email protected] in ~ took 212ms

What am i doing wrong here
And do you need any other info to help?

Are you on barebones? If yes, then try dr460nized.

I m running Dragonised kde

Are performance tweaks active?
Check garuda-assistent

1 Like

i have powersave tweaks enabled instead
i read its better for laptops
or should i enable performance tweaks
(will it drain battery faster)
is it possible to create an exception for this service only?

I thought more about overheating but this also happens when the notebook is lying on the lap/blanket.

Then the PC "freezes".

i always make sure to have proper air flow and low pc temps
also i dont really use heavy apps for it to overheat

I'll try performance tweaks for now and see if my battery takes a hit or not

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.