First boot stuck at "loading initial ramdisk"


I have a Threadripper 1950X and Nvidia 1050 system with 128Gb RAM and UEFI that has previously run Ubuntu without a problem. I have also installed Garuda on three other machines with no problems whatsoever.

I'm trying to install Garuda (Gnome) on this Threadripper machine and the problem I have is that, after what looked like a trouble-free install from the Live image, upon bootup the only thing I see is "Loading Linux linux-zen" then "Loading initial ramdisk".

I tried boot repair using the Live disk and I get the same issue. I was able to chroot into the installation from the live CD but I'm not sure what to do there.

I tried using the "backup initramfs" under Advanced Options in GRUB but that got me the same result.

I tried pressing F2 to show more startup text but that didn't do anything.

Please let me know other things I can try. Thank you!


Thank you. I was able to use CTRL-ALT-F2 to get a text prompt. I logged in, and did a full system update successfully with pacman. Now it even has the 5.16.7 zen kernel. I rebooted, but got the same hang.

Next, I tried to "startx", and I know see there is an error: "Fatal Server error" "No screens found". It references a log file, which has a lot of text in it, including error messages that a bunch of modules do not exist, like nouveau, nv, fbdev, vesa. Here is a picture of it:

Should I go to the dkms step, or is there something obvious here I can try?

The dkms step fixed the problem!!! Yay! Thank you so much for the pointer.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.