Black screen after entering password on Gnome login screen

Hello.

I posted this problem earlier that was fixed with "sudo dkms autoinstall") here. But it only fixed it one time -- and I still can't boot into Gnome.

Here is the problem.

I have a Threadripper 1950X and Nvidia 1050 system with 128Gb RAM and UEFI that has run Ubuntu without a problem. I have also installed Garuda on three other machines with no problems whatsoever. I installed Garuda (Gnome) on this Threadripper machine and the problem I have is that, upon bootup I see my account but when I enter my password I get a black screen.

I am able to access the terminal with CTRL-ALT-F3. I can log in to my user account, and update all packages to their latest without an issue. But when I try "startx" I get a black screen.

I tried boot repair using the Live disk and I get the same issue.

I tried using the "backup initramfs" under Advanced Options in GRUB but that got me the same result.

The one thing that worked -- but one time only -- was "sudo dkms install". Once I did this, I was able to do a graphical login to the Gnome desktop. Then I started installing things with no issues. But when I rebooted, I was faced with the same problem as I started with. But this time, sudo dkms install didn't do anything.

The output of "mhwd -li" shows:

video-nvidia-dkms, version 2022.01.29, freedriver false, type pci.

I tried "systemctl stop gdm" followed by "systemctl start gdm" and it just showed me the graphical login screen, but entering my password just goes to the black screen again.

Anything else I can try?

did this happen after an update via pacman by any chance?

Yes. Though the sequence was this:

  • install Garuda Gnome using Live USB
  • reboot -> black screen
  • sudo dkms autoinstall then startx --> login works!! yay!
  • use pacman (paru) to install a bunch of packages and update everything
  • reboot -> black screen (can't be fixed now)

right, as you have successfully booted at least once before the last update, i reckon the nvid is the problem, so reboot, on grub screen choose "garuda linux snapshots" and choose the one before the last update but after the successful login - lets see if that gets you in first

I went to the very earliest snapshot available which was a week ago when the system was working. I chose one of the two options (the one without the "fallback img"), and I get the same issue. I see black screen with text saying "Loading snapshot ... " "Loading Kernel...." and then "Loading Microcode...". But nothing until I do CTRL-ALT-F3 for a TTY.

just to double check, the type is "pre" and not "post", i'm guessing it was, and another snap just before it all went a bit black (the most recent time it dd) does nothing either?

Correct. It was a "pre". But it is snapshot 93 from the day the machine was running -- so I installed a whole lot of software and I guess the earlier snapshots are gone now.

You might already have seen this, and it looks like you've tried many of the steps already, but linking just in case:

This means the X server is working (unless you've forced Wayland compatibility?), so it's something in your user's settings, for example a GNOME extension. Also check which session you're logging into (bottom-right cog menu).

Yes that was the link I looked at first.

There is no cog menu when I see the graphical GNOME login screen. I never selected Wayland in the one session I was able to log into.

Interestingly when I look at "systemctl status gdm" it is running. Yet I do see some errors after "Started GNOME Display manager". One is "pam_systemd_home: systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found", and then another one "gkr-pam: unable to locate daemon control file".

Maybe you could check your modules in mkinitcpio.conf (or try with the delay time) as suggested here
https://wiki.archlinux.org/title/GDM#GDM_does_not_start_until_switching_TTY_and_back