Firewall after restarting PC is turn to off

Hi , first sorry my English . I installed firewall from software manager and after restarting and switching off PC , firewall always turn to off and I must turn on manually . I have Garuda XFCE . Thanks

Which one?

Which one?

As always, please, post your garuda-inxi like the template ask for.

2 Likes

System:

  Kernel: 5.17.5-hardened1-1-hardened arch: x86_64 bits: 64 compiler: gcc
    v: 11.2.0 parameters: pti=on page_alloc.shuffle=1
    BOOT_IMAGE=/@/boot/vmlinuz-linux-hardened
    root=UUID=83831e1e-494d-4bba-b53c-25620a550594 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X571GD_X571GD
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: X571GD v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X571GD.312 date: 09/15/2021
Battery:
  ID-1: BAT1 charge: 26.0 Wh (96.7%) condition: 26.9/42.3 Wh (63.6%)
    volts: 12.8 min: 11.6 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: charging
CPU:
  Info: model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 800 min/max: 800/4000 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 36812
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: ASUSTeK
    driver: i915 v: kernel ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK
    driver: nvidia v: 510.68.02 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0
    chip-ID: 10de:1c92 class-ID: 0302
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-7:4 chip-ID: 13d3:56a8 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting,nvidia gpu: i915 display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x0563 built: 2018 res: 1920x1080
    dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.5-hardened1-1-hardened running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: AzureWave driver: rtw_8821ce v: N/A modules: rtw88_8821ce pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 03:00.0
    chip-ID: 10ec:c821 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
Bluetooth:
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-14:5 chip-ID: 13d3:3529 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 6060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A
    class-ID: 0104
Drives:
  Local Storage: total: 1.14 TiB used: 10.1 GiB (0.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFM256GDJTNG-8310A size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter>
    rev: 80001C00 temp: 33.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1J scheme: GPT
Partition:
  ID-1: / raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
    used: 10.1 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
    used: 10.1 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
    used: 10.1 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 238.17 GiB size: 238.17 GiB (100.00%)
    used: 10.1 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.62 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 46.0 C pch: 49.0 C mobo: 27.8 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 305 Uptime: 27m wakeups: 1 Memory: 7.62 GiB used: 2 GiB (26.3%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.2.0 Packages:
  pacman: 1344 lib: 362 Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.15
Garuda (2.6.2-1):
  System install date:     2022-05-10
  Last full system update: 2022-05-10 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:

I formatted the post according to

Please give a look at it :slight_smile:

This means you still have to reboot after the last update (not linked to your issue probably, just FYI).
Still open questions from above: what did you install and how...

1 Like

I installed today newly Garuda XFCE . I installed firewall from add/remove software from official repositaire . Thanks

Which firewall did you install?

If you searched for firewall, it must have shown you several possible packages.
E.g. if you selected firewalld (very similar spelling), this should be enabled from terminal with

sudo systemctl enable --now firewalld

If it was e.g. ufw (another very famous one)

sudo ufw enable

...

3 Likes

Thanks firewall still after restarting is turning off .

Do not use pamac, just use terminal and pacman.

1 Like

  

4 Likes

Good , thanks , now firewall works automatically on startup of system. Thank you

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.