Firefox starts on boot up (XFCE)

I have checked the start up group and FF is not in it. I have checked the firefox about:config and there is nothing there for start up. Anyone know how to stop this? Thanks

If you had posted your garuda-inxi as requested in the forum template, we would know what desktop environment is in use.

1 Like

I am a complete Gnubee. If I knew how to do that I would. I am trying Linux as an alternative to Windoze. I am using the XFCE destop, I think. I am trying Garuda because the picture on the desktop looks neat. Should I try something easier and what would you suggest. Endeavor was number 2 on Distrowatch and I could not get that started. Even MXLinux was difficult. Friends have told me that linux is easy and a good alternative to Windoze, but I guess that I am not that smart. Sorry, I guess I will just go back to Windoze or try a Chrome Book. Thanks for answering anyways. I guess linux is not really that easy after all.

Like anything new, there is a learning curve. A lot of stuff in Linux has to be completely relearned because it is much different than Windows or other operating systems. If you have patience and a willingness to learn, it is likely Linux can work for you.

Open the terminal and run the command garuda-inxi. If you are not sure where to find the terminal, I think on XFCE it is in the menu under "system" apps. Technically it is called xfce4-terminal, but in the menu it might just say "Terminal".

When it opens up, run this command:


Copy and paste the output here into the forum as a comment. You can copy from the terminal with Ctrl+Shift+C (and paste however you normally would paste into a browser), or highlight the text in the terminal with the mouse and "click" the scroll wheel of the mouse to copy and paste.


Add three tildes (~) before and after the text
like this
to format in a code block so it is more readable in the forum.

1 Like

I'm not sure if @Knine9 is coming back to the forum or not, but I guess I will describe the solution for this issue anyway, in case another XFCE user stumbles on this thread while searching after the same problem.

In Settings, open Settings Manager -> Session and Startup -> General and make sure "Automatically save session on logout" is not checked.

A couple tabs down in that same menu is the "Saved Sessions" tab (if you have any saved sessions. If you do not, the tab disappears). Go ahead and delete them if you have any in there.


Next, find your log out button in the launcher and click it:

In the menu that opens up, untick the checkbox that says "Save session for future logins".


Optionally, reboot or log out/log back in to confirm the issue is resolved.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.