FireDragon not saving settings

I have a minor bug with FireDragon. It’s not saving the settings properly.

  1. The “Open new Tab” button is not where it supposed to be.

  2. Changes search engine after update. Not sure if it is supposed to do that.

Everything else seems to work.

garuda-inxi:

System:
  Kernel: 6.7.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=4e384f16-0b74-4432-bb6f-69659831f5f9 rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_wayland tools: avail: cinnamon-screensaver vt: 1
    dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-A v: Rev X.0x
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI: American Megatrends v: 3604 date: 02/25/2022
CPU:
  Info: model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ gen: 2
    level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
    model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 2385 high: 3695 min/max: 2200/3700 boost: disabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2439 2: 2114
    3: 2200 4: 3695 5: 2126 6: 2116 7: 2167 8: 2200 9: 2696 10: 2114 11: 2200
    12: 3522 13: 2126 14: 2121 15: 2129 16: 2196 bogomips: 118391
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: ASUSTeK
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: DP-1,DP-3 empty: DP-2,HDMI-A-1 bus-ID: 0b:00.0 chip-ID: 1002:73ff
    class-ID: 0300
  Device-2: Logitech Webcam C270 driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:4 chip-ID: 046d:0825
    class-ID: 0102 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu d-rect: 3840x1200 display-ID: 0
  Monitor-1: DP-1 pos: primary,left res: 1920x1200 size: N/A modes: N/A
  Monitor-2: DP-3 pos: right res: 1920x1200 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.5-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6600 (radeonsi navi23
    LLVM 16.0.6 DRM 3.57 6.7.4-zen1-1-zen) device-ID: 1002:73ff
    memory: 7.81 GiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.276 layers: 7 device: 0 type: discrete-gpu name: AMD
    Radeon RX 6600 (RADV NAVI23) driver: mesa radv v: 23.3.5-arch1.1
    device-ID: 1002:73ff surfaces: xcb,xlib,wayland device: 1 type: cpu
    name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
    v: 23.3.5-arch1.1 (LLVM 16.0.6) device-ID: 10005:0000
    surfaces: xcb,xlib,wayland
Audio:
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0b:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0d:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media CM6631A Audio Processor
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-8:3 chip-ID: 0d8c:0004 class-ID: 0300
  Device-4: Logitech Webcam C270 driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:4 chip-ID: 046d:0825
    class-ID: 0102 serial: <filter>
  API: ALSA v: k6.7.4-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 08:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager,systemd-timesyncd
Drives:
  Local Storage: total: 3.44 TiB used: 469.31 GiB (13.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Silicon Power
    model: SPCC M.2 PCIe SSD size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: H211011a temp: 42.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD20EARX-00PASB0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: N/A serial: <filter> fw-rev: AB51
    scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 046 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Kingston model: SUV400S37240G
    size: 223.57 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 96R9 scheme: GPT
  ID-5: /dev/sdd maj-min: 8:48 vendor: Wilk model: USB DISK 3.0
    size: 28.91 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 229.72 GiB (48.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 27.1 MiB (9.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 229.72 GiB (48.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 229.72 GiB (48.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
    used: 229.72 GiB (48.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 15.52 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 39.6 C mobo: N/A gpu: amdgpu temp: 37.0 C
    mem: 32.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Info:
  Memory: total: 16 GiB available: 15.53 GiB used: 4.3 GiB (27.7%)
  Processes: 403 Power: uptime: 0m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 6.2 GiB services: org_kde_powerdevil,upowerd
    Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1483 libs: 436 tools: octopi,pacseek,paru,yay
    Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: garuda-inxi default: Bash
    v: 5.2.26 running-in: kitty inxi: 3.3.33
Garuda (2.6.23-1):
  System install date:     2023-12-25
  Last full system update: 2024-02-11
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            mx500.service 

I just checked about a missing template in this section, it’s there, please apart from the rest

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)

  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

2 Likes

Done.

1 Like

Where is it?
Mine is located at the proper location on all machines.

Sort of… we’d prefer NOT to, but setting a default search engine with Floorp required a few tweaks and at the moment the downside is that is resets to SearX on every update. Sorry about that.

1 Like

Regarding search engine, I get it.

The New Tab button has really odd behavior. It changes position with maximize minimize sometimes.

Let me show you.

I just captured this bug now.

It starts up new windows of FD, and the button moves from the far right to next to the tabs.

:wink:

4 chars.

2 Likes

Have you created a new profile. To test

2 Likes

This did the trick. :wink:

1 Like

Yes make sure you follow the troubleshooting steps.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.