File retrieval errors during update, can't update

Fresh install of Garuda with Gnome as of today.

Having an issue with updating regardless if through the startup assistant or upd in the terminal.

Can't seem to find solutions to the issue that is arising with the update.
(Scroll all the way to the bottom of the terminal output to see my issue. I provided the whole thing for context as I am new and not sure if its needed.)

If there is further information I can provide I will update this post.

################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With:       reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacm
an.d/mirrorlist
# When:       2021-07-20 03:48:14 UTC
# From:       https://www.archlinux.org/mirrors/status/json/
# Retrieved:  2021-07-20 03:47:30 UTC
# Last Check: 2021-07-20 03:31:33 UTC

Server = https://arch.mirror.square-r00t.net/$repo/os/$arch
Server = https://mirrors.neusoft.edu.cn/archlinux/$repo/os/$arch
Server = https://mirror.telepoint.bg/archlinux/$repo/os/$arch
Server = https://mirror.chaoticum.net/arch/$repo/os/$arch
Server = https://archlinux.thaller.ws/$repo/os/$arch
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 chaotic-aur                    1297.4 KiB   176 KiB/s 00:07 [--------------------------------] 100%
:: Starting full system upgrade...
:: Replace garuda-settings-manager-notifier-git with chaotic-aur/garuda-system-maintenance? [Y/n]
resolving dependencies...
looking for conflicting packages...
:: garuda-common-settings and systemd-swap are in conflict. Remove systemd-swap? [y/N] y

Packages (209) alsa-card-profiles-1:0.3.31-1  android-tools-31.0.0-4  at-spi2-core-2.40.3-1
               bat-0.18.2-1  beautyline-20210718-1  bluez-5.60-1  bluez-hid2hci-5.60-1
               bluez-libs-5.60-1  bluez-plugins-5.60-1  bluez-utils-5.60-1  brltty-6.3-3
               btrfs-progs-5.13-1  ca-certificates-mozilla-3.68-1  ceph-libs-15.2.12-3
               chaotic-mirrorlist-20210716-1  clang-12.0.1-1  compiler-rt-12.0.1-2
               downgrade-10.1.0-1  enchant-2.3.0-1  ethtool-1:5.13-1  evince-40.3-1
               firedragon-90.0.1-1  fish-3.3.1-1  flameshot-0.10.0-1  fmt-8.0.0-2
               fontconfig-2:2.13.94-1  fprintd-1.92.0-1  fwupd-1.6.1-2  garuda-assistant-1.0.7-1
               garuda-common-settings-1.4.4-1  garuda-fish-config-1.3.6-1  garuda-gamer-1.0.2-1
               garuda-hotfixes-1.0.0-2
               garuda-settings-manager-notifier-git-r25.eb0ea49-1 [removal]
               garuda-setup-assistant-1.0.13-1  garuda-system-maintenance-1.1.3-1
               garuda-wallpapers-r55.0e16ac2-1  gd-2.3.2-4  gdbm-1.20-1  geoip-database-20210622-1
               glslang-11.5.0-1  glu-9.0.2-1  gnome-disk-utility-40.2-1  gnome-shell-1:40.3-1
               gnome-shell-extensions-40.3-1  gnome-terminal-transparency-3.40.3-1  gnupg-2.2.29-1
               gpgme-1.16.0-1  groff-1.22.4-6  gst-plugin-pipewire-1:0.3.31-1
               gst-plugins-bad-1.18.4-9  gst-plugins-bad-libs-1.18.4-9  gtk3-1:3.24.30-1
               harfbuzz-2.8.2-1  harfbuzz-icu-2.8.2-1  hwinfo-21.75-1  hwloc-2.5.0-1
               iana-etc-20210624-1  iio-sensor-proxy-3.1-1  imagemagick-7.1.0.4-1  imath-3.1.0-1
               intel-gmmlib-21.2.1-1  intel-media-driver-21.2.3-1  inxi-3.3.05.1-1
               iproute2-5.13.0-1  js78-78.12.0-1  karchive-5.84.0-1  kauth-5.84.0-1
               kbookmarks-5.84.0-1  kcodecs-5.84.0-1  kcompletion-5.84.0-1  kconfig-5.84.0-1
               kconfigwidgets-5.84.0-1  kcoreaddons-5.84.0-1  kcrash-5.84.0-1  kdbusaddons-5.84.0-1
               kded-5.84.0-1  kglobalaccel-5.84.0-1  kguiaddons-5.84.0-1  ki18n-5.84.0-1
               kiconthemes-5.84.0-1  kio-5.84.0-2  kitemmodels-5.84.0-1  kitemviews-5.84.0-1
               kjobwidgets-5.84.0-1  knotifications-5.84.0-1  kservice-5.84.0-1
               ktextwidgets-5.84.0-1  kvantum-theme-sweet-git-r196.5a95ad4-1  kwallet-5.84.0-1
               kwidgetsaddons-5.84.0-1  kwindowsystem-5.84.0-1  kxmlgui-5.84.0-1  less-1:590-1
               lib32-clang-12.0.1-1  lib32-libdrm-2.4.107-1  lib32-libldap-2.4.59-1
               lib32-libva-mesa-driver-21.1.5-1  lib32-libxcrypt-4.4.23-1  lib32-llvm-libs-12.0.1-1
               lib32-mesa-21.1.5-1  lib32-mesa-vdpau-21.1.5-1  lib32-opencl-mesa-21.1.5-1
               lib32-vulkan-icd-loader-1.2.184-1  lib32-vulkan-intel-21.1.5-1
               lib32-vulkan-mesa-layers-21.1.5-1  lib32-vulkan-radeon-21.1.5-1  libavif-0.9.2-1
               libcanberra-0.30+2+gc0620e4-5  libcap-2.51-1  libclc-12.0.1-1  libdrm-2.4.107-1
               libfprint-1.92.0-1  libgit2-1:1.1.1-1  libhandy-1.2.3-1  libksba-1.6.0-1
               libldap-2.4.59-1  libmfx-21.2.3-1  libnm-1.32.2-1  libplacebo-3.120.3-2
               libuv-1.41.1-1  libva-mesa-driver-21.1.5-1  libwacom-1.11-1  libxcrypt-4.4.23-1
               linux-zen-5.12.15.zen1-1  linux-zen-headers-5.12.15.zen1-1  llvm-libs-12.0.1-1
               lollypop-1.4.22-1  lua-5.4.3-1  man-db-2.9.4-2  man-pages-5.12-1  mercurial-5.8.1-1
               mesa-21.1.5-1  mesa-vdpau-21.1.5-1  mkinitcpio-30-2  modem-manager-gui-0.0.20-2
               mpg123-1.28.2-1  mtools-1:4.0.33-1  mutter-40.3-1  networkmanager-1.32.2-1
               nm-cloud-setup-1.32.2-1  noto-fonts-emoji-20210625-1  nspr-4.32-1  nss-3.68-1
               opencl-mesa-21.1.5-1  openexr-3.0.5-2  openldap-2.4.59-1  pacman-6.0.0-5
               pacman-contrib-1.4.0-4  pacman-mirrorlist-20210718-1  pango-1:1.48.7-1  paru-1.7.3-1
               pcre-8.45-1  perl-file-basedir-0.09-1  perl-http-message-6.33-1  pipewire-1:0.3.31-1
               pipewire-alsa-1:0.3.31-1  pipewire-jack-1:0.3.31-1
               pipewire-media-session-1:0.3.31-1  pipewire-pulse-1:0.3.31-1
               plymouth-git-0.9.5.r84.ge554475-4  poppler-21.07.0-1  poppler-glib-21.07.0-1
               profile-sync-daemon-6.44-2  protobuf-3.17.3-1  python-3.9.6-1  python-cffi-1.14.6-1
               python-pillow-8.3.1-1  python-urllib3-1.26.6-1  qt5-base-5.15.2+kde+r210-1
               qt5-declarative-5.15.2+kde+r29-1  qt5-wayland-5.15.2+kde+r29-1  reflector-2021.7.8-1
               rpcbind-1.2.6-1  samba-4.14.6-1  shaderc-2021.1-1  smbclient-4.14.6-1
               sof-firmware-1.8-1  solid-5.84.0-1  sonnet-5.84.0-1  sqlite-3.36.0-1
               starship-0.56.0-1  systemd-249-3  systemd-libs-249-3  systemd-swap-4.4.0-2 [removal]
               systemd-sysvcompat-249-3  talloc-2.3.3-1  tdb-1.4.4-1  tealdeer-1.4.1-6
               texinfo-6.8-1  totem-pl-parser-3.26.6-1  vulkan-headers-1:1.2.184-1
               vulkan-icd-loader-1.2.184-1  vulkan-intel-21.1.5-1  vulkan-mesa-layers-21.1.5-1
               vulkan-radeon-21.1.5-1  vulkan-swrast-21.1.5-1  vulkan-tools-1.2.184-1
               webkit2gtk-2.32.2-1  wireplumber-0.4.1-2  xapp-2.2.2-1  xf86-input-libinput-1.1.0-1
               xorg-server-1.20.12-1  xorg-server-common-1.20.12-1  xorg-server-xephyr-1.20.12-1
               xorg-xwayland-21.1.2-1  yaru-sound-theme-21.10.1-1  zimg-3.0.2-1
               zram-generator-0.3.2-1

Total Download Size:    373.54 MiB
Total Installed Size:  2545.63 MiB
Net Upgrade Size:         1.64 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 sonnet-5.84.0-1-x86_64 is up to date
 ktextwidgets-5.84.0-1-x86_64 is up to date
 fprintd-1.92.0-1-x86_64         139.8 KiB   102 KiB/s 00:01 [--------------------------------] 100%
 flameshot-0.10.0-1-x86_64       559.2 KiB   358 KiB/s 00:02 [--------------------------------] 100%
 reflector-2021.7.8-1-any         26.7 KiB  63.1 KiB/s 00:00 [--------------------------------] 100%
 libfprint-1.92.0-1-x86_64       306.4 KiB   173 KiB/s 00:02 [--------------------------------] 100%
 fwupd-1.6.1-2-x86_64              3.0 MiB  2.61 MiB/s 00:01 [--------------------------------] 100%
 harfbuzz-icu-2.8.2-1-x86_64       7.7 KiB  25.5 KiB/s 00:00 [--------------------------------] 100%
 profile-sync-daemon-6.44-2-any   24.3 KiB  44.8 KiB/s 00:01 [--------------------------------] 100%
 libuv-1.41.1-1-x86_64           222.9 KiB   124 KiB/s 00:02 [--------------------------------] 100%
 zram-generator-0.3.2-1-x86_64   393.9 KiB   341 KiB/s 00:01 [--------------------------------] 100%
 webkit2gtk-2.32.2-1-x86_64       23.0 MiB  7.00 MiB/s 00:03 [--------------------------------] 100%
 geoip-database-20210622-1-any  1610.5 KiB   539 KiB/s 00:03 [--------------------------------] 100%
 tealdeer-1.4.1-6-x86_64        1386.8 KiB  4.62 MiB/s 00:00 [--------------------------------] 100%
 libgit2-1:1.1.1-1-x86_64        595.7 KiB  3.11 MiB/s 00:00 [--------------------------------] 100%
 starship-0.56.0-1-x86_64       1598.7 KiB  3.55 MiB/s 00:00 [--------------------------------] 100%
 garuda-common-settings-1.4...    58.0 KiB  22.7 KiB/s 00:03 [--------------------------------] 100%
 garuda-fish-config-1.3.6-1-any    8.7 KiB  9.21 KiB/s 00:01 [--------------------------------] 100%
 garuda-assistant-1.0.7-1-any    115.3 KiB  27.2 KiB/s 00:04 [--------------------------------] 100%
 garuda-gamer-1.0.2-1-any          2.1 MiB  1639 KiB/s 00:01 [--------------------------------] 100%
 garuda-system-maintenance-...    44.6 KiB  45.4 KiB/s 00:01 [--------------------------------] 100%
 garuda-hotfixes-1.0.0-2-any       2.4 KiB  1352   B/s 00:02 [--------------------------------] 100%
 garuda-setup-assistant-1.0...    13.3 KiB  23.4 KiB/s 00:01 [--------------------------------] 100%
 libavif-0.9.2-1-x86_64          103.9 KiB   190 KiB/s 00:01 [--------------------------------] 100%
 gd-2.3.2-4-x86_64               160.7 KiB   264 KiB/s 00:01 [--------------------------------] 100%
 glslang-11.5.0-1-x86_64           3.5 MiB  2.57 MiB/s 00:01 [--------------------------------] 100%
 glu-9.0.2-1-x86_64              142.5 KiB   112 KiB/s 00:01 [--------------------------------] 100%
 gnome-disk-utility-40.2-1-...  1028.5 KiB  3.14 MiB/s 00:00 [--------------------------------] 100%
 pipewire-1:0.3.31-1-x86_64     1310.5 KiB  1962 KiB/s 00:01 [--------------------------------] 100%
 xorg-server-common-1.20.12...    27.7 KiB  52.3 KiB/s 00:01 [--------------------------------] 100%
 xorg-xwayland-21.1.2-1-x86_64   882.5 KiB  1268 KiB/s 00:01 [--------------------------------] 100%
 libnm-1.32.2-1-x86_64          1064.6 KiB   379 KiB/s 00:03 [--------------------------------] 100%
 pipewire-media-session-1:0...    98.9 KiB  34.8 KiB/s 00:03 [--------------------------------] 100%
 pipewire-alsa-1:0.3.31-1-x...     4.6 KiB  1474   B/s 00:03 [--------------------------------] 100%
 pipewire-pulse-1:0.3.31-1-...   125.2 KiB  42.9 KiB/s 00:03 [--------------------------------] 100%
 mutter-40.3-1-x86_64              2.5 MiB  1808 KiB/s 00:01 [--------------------------------] 100%
 gst-plugin-pipewire-1:0.3....    43.3 KiB  30.0 KiB/s 00:01 [--------------------------------] 100%
 gst-plugins-bad-libs-1.18....  2027.3 KiB   765 KiB/s 00:03 [--------------------------------] 100%
 vulkan-headers-1:1.2.184-1-any  725.9 KiB   237 KiB/s 00:03 [--------------------------------] 100%
 gnome-terminal-transparenc...  1619.3 KiB  1379 KiB/s 00:01 [--------------------------------] 100%
 gnome-shell-1:40.3-1-x86_64    1603.6 KiB  1002 KiB/s 00:02 [--------------------------------] 100%
 gnome-shell-extensions-40....   160.1 KiB  81.7 KiB/s 00:02 [--------------------------------] 100%
 groff-1.22.4-6-x86_64             2.1 MiB   333 KiB/s 00:07 [--------------------------------] 100%
 openexr-3.0.5-2-x86_64         1041.2 KiB   356 KiB/s 00:03 [--------------------------------] 100%
 imath-3.1.0-1-x86_64              4.7 MiB   187 KiB/s 00:26 [--------------------------------] 100%
 garuda-wallpapers-r55.0e16...    15.0 MiB   290 KiB/s 00:53 [--------------------------------] 100%
 Total ( 46/119)                 373.5 MiB  6.20 MiB/s 01:00 [--------------------------------] 100%
error: failed retrieving file 'garuda-fish-config-1.3.6-1-any.pkg.tar.zst' from geo-mirror.chaotic.cx : Failed to connect to mirror.theash.xyz port 443: Connection refused
error: failed retrieving file 'garuda-gamer-1.0.2-1-any.pkg.tar.zst' from geo-mirror.chaotic.cx : Failed to connect to mirror.theash.xyz port 443: Connection refused
error: failed retrieving file 'gnome-terminal-transparency-3.40.3-1-x86_64.pkg.tar.zst' from geo-mirror.chaotic.cx : Failed to connect to mirror.theash.xyz port 443: Connection refused
warning: too many errors from geo-mirror.chaotic.cx, skipping for the remainder of this transaction
error: failed retrieving file 'gnome-shell-extensions-40.3-1-any.pkg.tar.zst.sig' from arch.mirror.square-r00t.net : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'groff-1.22.4-6-x86_64.pkg.tar.zst.sig' from arch.mirror.square-r00t.net : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'openexr-3.0.5-2-x86_64.pkg.tar.zst' from arch.mirror.square-r00t.net : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: too many errors from arch.mirror.square-r00t.net, skipping for the remainder of this transaction
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

Looks like you need to update your mirrors.
The command/alias upd will do all the work for you.

2 Likes

The upd alias uses -Syu as the final command though, and I found previously that even after I refreshed my keys and mirrors, the -Syu was not enough to force a full refreshing of package lists.

On my Garuda VM, I changed the final command in the alias to -Syyu after which it worked.

2 Likes

Just to confirm, this means the mirror server is refusing connections. This is not a local issue (or a problem with Garuda itself).

As has been said, choose a different set of mirrors.

4 Likes

It's about the mirrors sync (between them) again... (like in my previous distro :wink: ).
Default chaotic-mirrorlist uses a geo-mirror service, which uses potentially a different server each time a transaction is called. This is a potential reason it needs a confirmed sync (yy) each time you use it.

But I haven't done testing on this. Just speculating from (bad) experience :stuck_out_tongue_winking_eye:

As for OT, it can also be a bad network connection at the time this happens.

3 Likes

Am facing the same issue since more than 2 weeks. I selected all mirror countries (including Worldwide) but that doesnt seem to work...

╭─vicky@vicky in ~
 ╰─λ sudo pacman -Syu
[sudo] password for vicky:
:: Synchronizing package databases...
 core                            135.3 KiB  11.5 KiB/s 00:12 [################################] 100%
 extra                               751.9 KiB  10.2 KiB/s 01:20 [#################-------------------]   extra                             1566.4 KiB  15.7 KiB/s 01:40 [##################################] 100%
 community                            5.6 MiB  20.4 KiB/s 04:41 [##################################] 100%
  17%
 chaotic-aur                    1348.3 KiB  31.6 KiB/s 00:43 [################################] 100%
:: Starting full system upgrade...
:: Replace jack with extra/jack2? [Y/n] y
resolving dependencies...
looking for conflicting packages...

Packages (179) 0ad-a24.b-7  alsa-card-profiles-1:0.3.32-1  ananicy-git-2.2.1.r49.g549fa41-1
               android-tools-31.0.2-1  aom-3.1.2-1  aqbanking-6.3.0-2  beautyline-20210718-1
               bitwarden-1.27.1-2  bluedevil-1:5.22.4-1  breeze-5.22.4-1  breeze-gtk-5.22.4-1
               btrfs-progs-5.13-1  celt-0.11.3-4  ceph-libs-15.2.13-2  cfitsio-1:4.0.0-1
               chaotic-mirrorlist-20210716-1  ctemplate-2.4-2  curl-7.78.0-1  dbus-python-1.2.18-1
               drkonqi-5.22.4-1  ethtool-1:5.13-1  extremetuxracer-0.8.1-1  f2fs-tools-1.14.0-2
               firefox-90.0.2-1  firefox-i18n-en-us-90.0.2-1  flameshot-git-r1382.4e406ec8-1
               fmt-8.0.1-1  garuda-common-settings-1.4.5-1  garuda-dr460nized-1.5.5-1
               garuda-fish-config-1.3.6-1  garuda-setup-assistant-1.1.1-1
               garuda-system-maintenance-1.1.3-1  gdk-pixbuf2-2.42.6-2  gnome-desktop-1:40.3-1
               gnupg-2.2.29-1  go-2:1.16.6-1  google-chrome-92.0.4515.107-1  gparted-1.3.1-1
               graphviz-2.48.0-2  gst-plugin-pipewire-1:0.3.32-1  handbrake-1.4.0-1  hwloc-2.5.0-1
               imagemagick-7.1.0.4-1  imath-3.1.1-1  intel-gmmlib-21.2.1-1  intel-media-driver-21.2.3-1
               inxi-3.3.06.1-1  jack-0.125.0-9 [removal]  jack2-1.9.19-2  jemalloc-1:5.2.1-3
               jre-openjdk-16.0.2.u7-1  jre-openjdk-headless-16.0.2.u7-1  kactivitymanagerd-5.22.4-1
               kde-cli-tools-5.22.4-1  kde-gtk-config-5.22.4-1  kdecoration-5.22.4-1
               kdeplasma-addons-5.22.4-1  kgamma5-5.22.4-1  khotkeys-5.22.4-1  kinfocenter-5.22.4-1
               kmenuedit-5.22.4-1  kscreen-5.22.4-1  kscreenlocker-5.22.4-1  ksshaskpass-5.22.4-1
               ksystemstats-5.22.4-1  kvantum-qt5-0.20.1-1  kwallet-pam-5.22.4-1
               kwayland-integration-5.22.4-1  kwayland-server-5.22.4-1  kwin-5.22.4-1  kwrited-5.22.4-1
               latte-dock-git-0.9.91.r144.g71f9e891-1  layer-shell-qt-5.22.4-1  ldb-1:2.4.0-1
               lib32-curl-7.78.0-1  lib32-libva-mesa-driver-21.1.5-1  lib32-libxfixes-6.0.0-1
               lib32-mesa-21.1.5-1  lib32-mesa-vdpau-21.1.5-1  lib32-opencl-mesa-21.1.5-1
               lib32-util-linux-2.37.1-1  lib32-vulkan-icd-loader-1.2.184-1  lib32-vulkan-intel-21.1.5-1
               lib32-vulkan-mesa-layers-21.1.5-1  lib32-vulkan-radeon-21.1.5-1
               libadwaita-1.0.0alpha.2-1  libbytesize-2.6-1  libgdm-40.1-1  libidn-1.38-1
               libjcat-0.1.8-1  libkscreen-5.22.4-1  libksysguard-5.22.4-1  libldap-2.4.59-2
               libmm-glib-1.16.8-1  libmwaw-0.3.20-1  libnghttp2-1.44.0-1  libnm-1.32.4-1
               libreoffice-fresh-7.1.5-1  libuv-1.42.0-1  libva-mesa-driver-21.1.5-1
               libva-utils-2.12.0-1  libxmlb-0.3.2-1  libxnvctrl-470.57.02-1
               linux-firmware-20210716.b7c134f-1  linux-lts-5.10.53-1  linux-lts-headers-5.10.53-1
               linux-zen-5.13.5.zen1-1  linux-zen-headers-5.13.5.zen1-1  lollypop-1.4.22-1
               man-pages-5.12-2  mesa-21.1.5-1  mesa-vdpau-21.1.5-1  mhwd-db-garuda-git-r54.c233ab1-1
               milou-5.22.4-1  modemmanager-1.16.8-1  mtools-1:4.0.34-1  networkmanager-1.32.4-1
               networkmanager-strongswan-1.5.2-2  nm-cloud-setup-1.32.4-1  opencl-mesa-21.1.5-1
               openfortivpn-1.17.0-1  openldap-2.4.59-2  oxygen-5.22.4-1  pacman-mirrorlist-20210718-1
               perl-5.34.0-2  perl-http-message-6.33-1  pipewire-1:0.3.32-1
               pipewire-media-session-1:0.3.32-1  plasma-browser-integration-5.22.4-1
               plasma-desktop-5.22.4-1  plasma-disks-5.22.4-1  plasma-firewall-5.22.4-1
               plasma-integration-5.22.4-1  plasma-nm-5.22.4-1  plasma-pa-5.22.4-1
               plasma-systemmonitor-5.22.4-1  plasma-thunderbolt-5.22.4-1  plasma-vault-5.22.4-1
               plasma-workspace-5.22.4-1  plasma-workspace-wallpapers-5.22.4-1
               plasma5-applets-window-appmenu-0.7.1-1  polkit-kde-agent-5.22.4-1  poppler-21.07.0-3
               poppler-glib-21.07.0-3  poppler-qt5-21.07.0-3  powerdevil-5.22.4-1
               python-more-itertools-8.8.0-1  python-pep517-0.11.0-1  python-requests-2.26.0-1
               python-setuptools-1:57.4.0-1  python-tomli-1.1.0-1  rpcbind-1.2.6-1  sddm-kcm-5.22.4-1
               skypeforlinux-stable-bin-8.74.0.152-1  starship-0.56.0-1  strongswan-5.9.3-1
               systemd-249.2-1  systemd-libs-249.2-1  systemd-sysvcompat-249.2-1
               systemsettings-5.22.4-1  talloc-2.3.3-1  tdb-1.4.5-1  tealdeer-1.4.1-6
               telegram-desktop-2.8.11-2  tevent-1:0.11.0-1  util-linux-2.37.1-1
               util-linux-libs-2.37.1-1  vpnc-1:0.5.3.r496.r153-2  vulkan-headers-1:1.2.185-1
               vulkan-icd-loader-1.2.185-1  vulkan-intel-21.1.5-1  vulkan-mesa-layers-21.1.5-1
               vulkan-radeon-21.1.5-1  vulkan-swrast-21.1.5-1  vulkan-tools-1.2.184-1
               webkit2gtk-2.32.3-1  xdg-desktop-portal-kde-5.22.4-1  zimg-3.0.2-1  zoom-5.7.4-1

Total Download Size:   1327.13 MiB
Total Installed Size:  4818.87 MiB
Net Upgrade Size:        69.49 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 kdecoration-5.22.4-1-x86_64         73.2 KiB  13.5 KiB/s 00:05 [##################################] 100%
 libnghttp2-1.44.0-1-x86_64          94.9 KiB  15.9 KiB/s 00:06 [##################################] 100%
 libbytesize-2.6-1-x86_64            24.2 KiB  2.64 KiB/s 00:09 [##################################] 100%
 bluedevil-1:5.22.4-1-x86_64        298.8 KiB  32.2 KiB/s 00:09 [##################################] 100%
 libldap-2.4.59-2-x86_64            303.6 KiB  17.8 KiB/s 00:17 [##################################] 100%
 breeze-gtk-5.22.4-1-any            228.0 KiB  7.03 KiB/s 00:32 [##################################] 100%
 breeze-5.22.4-1-x86_64              31.2 MiB  36.5 KiB/s 14:34 [##################################] 100%
 Total (  7/144)                   1327.1 MiB  1543 KiB/s 14:41 [##################################] 100%
error: failed retrieving file 'libbytesize-2.6-1-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'bluedevil-1:5.22.4-1-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'libldap-2.4.59-2-x86_64.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: too many errors from america.mirror.pkgbuild.com, skipping for the remainder of this transaction
error: failed retrieving file 'breeze-gtk-5.22.4-1-any.pkg.tar.zst.sig' from america.mirror.pkgbuild.com : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

You can always select mirror servers manually. Archlinux mirror site has useful tools for that.
https://archlinux.org/mirrorlist/

2 Likes

Am sorry to bother but am a newbie... So what should i do? I had tried a couple of mirrors thro "Garuda Welcome' and then selected all mirrors but still unable to update using sudo pacman - Syu

Appreciate the help and the forum.

Read

man reflector

Maybe there will be errors in the terminal when you try reflector. Sort atleast 150 mirrors with it.

1 Like

Tried with 200 using this command

reflector --latest 200 --protocol http,https --sort rate --save /etc/pacman.d/mirrorlist

But i get 'Download timed out after 5 second(s)' error for all of them e,g

[2021-07-27 23:46:55] WARNING: failed to rate http(s) download (https://mirrors.n-ix.net/archlinux/community/os/x86_64/community.db): Download timed out after 5 second(s).

Seems that you might need a higher download timeout.
In this case, it takes longer than 5 seconds, so it times out.

reflector --latest 200 --protocol http,https --sort rate --save /etc/pacman.d/mirrorlist --download-timeout 15

In this example I have put the --download-timeout as 15 seconds.
Try adjusting the download timeout, so it neither takes too long (overestimated) nor times out (underestimated).

Actually that error doesn't really matter and can be disregarded as the mirror won't be included in the final generated mirrorlist.
Edit: if this happens for every mirror the issue is probably not the mirrorlist.

5 Likes

Yes - this happened for every mirror.

i could be wrong but you are missing your multilib repo in your pacman config
enable and try again

2 Likes

Therefore, this implies there's an issue with your network connection.

Useful for things like Steam, but not related to the specific issue of mirrors timing out.

5 Likes

You could try

sudo pacman -Syu --disable-download-timeout

2 Likes

Thanks but as @dr460nf1r3 pointed out if this is happening for every mirror , the issue is probably not the mirrorlist. Incidentally increasing the timeout to even 15 of 20 seconds hasnt helped and the update doesnt happen :frowning:

Currently there seem 144 packages to be updated but unable to find out how to. Though no issue in stability of any packages so using the distro perfectly. Even using the Garuda Assistant for any System update doesnt work.

Thanks everyone for your support and timely responses. :+1:

Have you tried individually updating a package ie

sudo pacman -S package name

Also clear your cache

1 Like

Have you disabled your download timeout like @TilliDie said?
Most likely it will take many hours, but I think it will update.

Do you have any vpn/firewall things configured?

2 Likes

If the issue is not the mirrorlists, then IMHO it is either your DNS configuration, or certification/gpg configuration.
Don't you have other network issues browsing web pages?
Have you checked for journal errors?

1 Like