File ealready exists in filesystem

Good Morning from the Philippines. Last night I installed Garuda Gnome for the fist time. This looks to be an amazing destro. After install I did an update and and it failed. It was garuda-gnome-settings that was hanging the update installs up. I ended up removing garuda-gnome-settings and the updates completed. I tried again to update garuda-gnome-settings and failed: conflicting files:

  • garuda-gnome-settings: /etc/skel/.zshrc already exists in filesystem (owned by garuda-zsh-config)
    I do not understand what the problem is. I cannot find (.zshrc) … Not sure if I need garuda-gnome-settings installed in the first place. Any help on this would be appreciated.
1 Like

Welcome

@dr460nf1r3 changed yesterday something.

Use

sudo pacman -Syu --overwrite "*"

If file exist error come up.

Hide .zshrc file

# If you come from bash you might have to change your $PATH.
# export PATH=$HOME/bin:/usr/local/bin:$PATH

# Set $PATH if ~/.local/bin exist
if [ -d "$HOME/.local/bin" ]; then
    export PATH=$HOME/.local/bin:$PATH
fi

# Path to your oh-my-zsh installation.
ZSH=/usr/share/oh-my-zsh/

# Set name of the theme to load --- if set to "random", it will
# load a random theme each time oh-my-zsh is loaded, in which case,
# to know which specific one was loaded, run: echo $RANDOM_THEME
# See https://github.com/ohmyzsh/ohmyzsh/wiki/Themes
ZSH_THEME="half-life"

# Set list of themes to pick from when loading at random
# Setting this variable when ZSH_THEME=random will cause zsh to load
# a theme from this variable instead of looking in $ZSH/themes/
# If set to an empty array, this variable will have no effect.
# ZSH_THEME_RANDOM_CANDIDATES=( "robbyrussell" "agnoster" )

# Uncomment the following line to use case-sensitive completion.
# CASE_SENSITIVE="true"

# Uncomment the following line to use hyphen-insensitive completion.
# Case-sensitive completion must be off. _ and - will be interchangeable.
# HYPHEN_INSENSITIVE="true"

# Uncomment the following line to disable bi-weekly auto-update checks.
DISABLE_AUTO_UPDATE="true"

# Uncomment the following line to automatically update without prompting.
# DISABLE_UPDATE_PROMPT="true"

# Uncomment the following line to change how often to auto-update (in days).
# export UPDATE_ZSH_DAYS=13

# Uncomment the following line if pasting URLs and other text is messed up.
# DISABLE_MAGIC_FUNCTIONS=true

# Uncomment the following line to disable colors in ls.
# DISABLE_LS_COLORS="true"

# Uncomment the following line to disable auto-setting terminal title.
# DISABLE_AUTO_TITLE="true"

# Uncomment the following line to enable command auto-correction.
# ENABLE_CORRECTION="true"

# Uncomment the following line to display red dots whilst waiting for completion.
# COMPLETION_WAITING_DOTS="true"

# Uncomment the following line if you want to disable marking untracked files
# under VCS as dirty. This makes repository status check for large repositories
# much, much faster.
# DISABLE_UNTRACKED_FILES_DIRTY="true"

# Uncomment the following line if you want to change the command execution time
# stamp shown in the history command output.
# You can set one of the optional three formats:
# "mm/dd/yyyy"|"dd.mm.yyyy"|"yyyy-mm-dd"
# or set a custom format using the strftime function format specifications,
# see 'man strftime' for details.
# HIST_STAMPS="mm/dd/yyyy"

# Would you like to use another custom folder than $ZSH/custom?
# ZSH_CUSTOM=/path/to/new-custom-folder

# Which plugins would you like to load?
# Standard plugins can be found in $ZSH/plugins/
# Custom plugins may be added to $ZSH_CUSTOM/plugins/
# Example format: plugins=(rails git textmate ruby lighthouse)
# Add wisely, as too many plugins slow down shell startup.
plugins=(git git-extras archlinux adb cp python docker)


# User configuration

# export MANPATH="/usr/local/man:$MANPATH"

# You may need to manually set your language environment
# export LANG=en_US.UTF-8

# Preferred editor for local and remote sessions
# if [[ -n $SSH_CONNECTION ]]; then
#   export EDITOR='vim'
# else
#   export EDITOR='mvim'
# fi

# Compilation flags
# export ARCHFLAGS="-arch x86_64"

# Set personal aliases, overriding those provided by oh-my-zsh libs,
# plugins, and themes. Aliases can be placed here, though oh-my-zsh
# users are encouraged to define aliases within the ZSH_CUSTOM folder.
# For a full list of active aliases, run `alias`.
#
# Example aliases
# alias zshconfig="mate ~/.zshrc"
# alias ohmyzsh="mate ~/.oh-my-zsh"

ZSH_CACHE_DIR=$HOME/.cache/oh-my-zsh
if [[ ! -d $ZSH_CACHE_DIR ]]; then
  mkdir $ZSH_CACHE_DIR
fi

source $ZSH/oh-my-zsh.sh

## Plugins section: Enable fish style features
# Use syntax highlighting
source /usr/share/zsh/plugins/zsh-syntax-highlighting/zsh-syntax-highlighting.zsh
# Use autosuggestion
source /usr/share/zsh/plugins/zsh-autosuggestions/zsh-autosuggestions.zsh
ZSH_AUTOSUGGEST_BUFFER_MAX_SIZE=20
# Use history substring search
source /usr/share/zsh/plugins/zsh-history-substring-search/zsh-history-substring-search.zsh
# bind UP and DOWN arrow keys to history substring search
zmodload zsh/terminfo
bindkey "$terminfo[kcuu1]" history-substring-search-up
bindkey "$terminfo[kcud1]" history-substring-search-down
bindkey '^[[A' history-substring-search-up			
bindkey '^[[B' history-substring-search-down

HISTFILE=~/.zhistory
HISTSIZE=10000
SAVEHIST=5000

# Use fzf
source /usr/share/fzf/key-bindings.zsh
source /usr/share/fzf/completion.zsh

# Activate powerlevel10k theme
source /usr/share/zsh-theme-powerlevel10k/powerlevel10k.zsh-theme

echo $(lsb_release -is) $(uname -srm) 

# Add useful aliases 
alias aup="pamac upgrade --aur"
alias grubup="sudo update-grub"
alias orphaned="sudo pacman -Rns $(pacman -Qtdq)"
alias fixpacman="sudo rm /var/lib/pacman/db.lck"
alias ..='cd ..'
alias ...='cd ../..'
alias ....='cd ../../..'
alias .....='cd ../../../..'
alias ......='cd ../../../../..'
alias ls='ls --color=auto'
alias dir='dir --color=auto'
alias vdir='vdir --color=auto'
alias grep='grep --color=auto'
alias fgrep='fgrep --color=auto'
alias egrep='egrep --color=auto'
alias path='echo -e ${PATH//:/\\n}'
# Set your countries like --country France --country Germany -- or more.
#alias upd='sudo reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirrorlist && cat /etc/pacman.d/mirrorlist && sudo pacman -Syu'

Hope that help. :slight_smile:

3 Likes

That did the trick and now garuda-gnome-settings is installed. Thank you for your help… :grinning: :grinning: :grinning:

3 Likes

This is fixed now. Packages only build once a day from source so it took some time get the fix into the repo.
If you want to use the gnome edition the garuda-gnome-settings package is needed - it contains things such as the wallpaper, extensions and its settings :smiley:
Last but not least: welcome aboard! :grin:

2 Likes

Hi again… Your default wallpaper keeps overriding my wallpaper every time I open the Terminal. How to stop your default wallpaper? Under backgrounds the wallpaper doesn’t show up. Only my added wallpaper is listed in Backgrounds.
Again, thanks.

1 Like

open the .zshrc and delete the “wal -i…” line at the end. (the reason behind this is that the wal command used to theme the terminal also sets wallpaper. Thats why this is removed now)
This is also solved in the new version :blush:

2 Likes

Oh! I forgot to inform you that I am Ryzen AMD. I have NO intel or nvidia but yet I see intell and nvidia drivers installed. With Manjaro there was no intel or nvidia installed. I am not sure if I should uninstall the nvidia and intel drivers? Please advise on this also.

There should be no harm in removing these files if you are running AMD, there might be some meta-packages though which pull them in
@librewish should have some more information on that :face_with_monocle:

2 Likes

Give us out put of

mhwd -l

And

mhwd -li
2 Likes

Hi, Ok… Wallpaper issue fixed… lolololol Thank goodness for that… lololol

OK, I do see that other files are dependent of some of the Intel and Nvidia installed. If it doesn’t hurt my system I think I will leave them alone for now. I think gimp is dependent on intel.

BTW, I am really enjoying garuda linux… Again, well done!

3 Likes

Here is the output you requested:
mhwd -l

0000:07:00.0 (0300:1002:15dd) Display controller ATI Technologies Inc:


              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2020.08.01                true            PCI
 video-modesetting            2020.06.13                true            PCI
        video-vesa            2017.03.12                true            PCI

0000:06:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:


              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2020.05.22                true            PCI

19:21:30  [email protected]  ~ 
$ mhwd -li

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2020.08.01                true            PCI

Warning: No installed USB configs!

1 Like

Okay from this output no nvidia

Stuff is installed

It might be some packages require nvidia as a dep

So you dont need to worry

3 Likes

Ok, Thank you… It seems all is well then… Thank for your time…

3 Likes