Fastfetch | garuda-fastfetch-git | Flashfest for Garuda Linux

Wow, that's some broken jpeg right there, even though I seem to save it in PNG

1 Like

New Year, new logos :smiley:
I accidentally deleted fastfetch in git, age does not pass me by without a trace :wink:

Newly created and supplemented with two logo variants.

fastfetch --list-logos
fastfetch -l garudadragon
fastfetch -l garuda

Just pushed to github.

You can remove the color palette with #Colors in

--structure Title:Separator:OS:Host:Kernel:Uptime:Packages:Shell:Resolution:DE:WM:WMTheme:Theme:Icons:Font:Cursor:Terminal:TerminalFont:GPU:Memory:Battery:LocalIP:OpenGL:OpenCL:Processes:Disk:CPUUsage:CPU

There are many more modification options there. :slight_smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

Just kitty :slight_smile:


So with the pictures I like it better than with the ascii stuff :smiley:


You bet!!! It's like a totally different (much better) look.

Hey all,

I really like "the blue eagle", the second one in the picture above.
But i dont know how to have it in Konsole.
I tried this

╭─jacques@jacques in ~
╰─λ fastfetch --load-config garuda
Error: couldn't find config: garuda

But with no luck. Do i have to install something special ?
Or do you have a link to a wiki page for that ?

Here is the end of my

## Run fastfetch if session is interactive
if status --is-interactive && type -q fastfetch
   fastfetch --load-config dr460nized

Thanks in forward for your response.

Which Garuda DE are you using?

With i3wm it works only with Kitty, you can configure various, but also has weaknesses (copy and paste does not work with the mouse).

And you need the pictures and presets :slight_smile:

1 Like


I'm using Konsole in kde. Here's my inxi...

  Kernel: 6.2.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=5a2ed686-9f3f-4d1c-a51e-41bbeea7c18c
    rw rootflags=subvol=@ quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.1 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
  Type: Convertible System: LENOVO product: 20FRS08T00 v: ThinkPad X1 Carbon 4th
    serial: <superuser required> Chassis: type: 31 serial: <superuser required>
  Mobo: LENOVO model: 20FRS08T00 v: SDK0J40697 WIN serial: <superuser required> UEFI: LENOVO
    v: N1FET80W (1.54 ) date: 07/29/2022
  ID-1: BAT0 charge: 46.8 Wh (100.0%) condition: 46.8/52.1 Wh (89.9%) volts: 17.1 min: 15.2
    model: SMP 00HW029 type: Li-poly serial: <filter> status: full
  Device-1: wacom_battery_0 model: Wacom Pen and multitouch sensor serial: N/A charge: 0%
    rechargeable: yes status: N/A
  Info: model: Intel Core i7-6600U bits: 64 type: MT MCP arch: Skylake gen: core 6 level: v3
    note: check built: 2015 process: Intel 14nm family: 6 model-id: 0x4E (78) stepping: 3
    microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 3201 high: 3207 min/max: 400/3400 scaling: driver: intel_pstate
    governor: powersave cores: 1: 3198 2: 3200 3: 3200 4: 3207 bogomips: 22399
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 v: kernel arch: Gen-9
    process: Intel 14n built: 2015-16 ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-8:5 chip-ID: 04f2:b531
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x04aa built: 2015 res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2
    size: 309x174mm (12.17x6.85") diag: 355mm (14") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel HD Graphics 520 (SKL GT2)
    direct-render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
  Sound API: ALSA v: k6.2.1-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.66 running: yes
  Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:156f class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 04:00.0 chip-ID: 8086:24f3 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 1-7:4
    chip-ID: 8087:0a2b class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
  Local Storage: total: 462.07 GiB used: 90.34 GiB (19.6%)
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: 00000 size: 238.5 GiB block-size: physical: 512 B
    logical: 512 B type: SSD serial: <filter> scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-2: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSCKGF240A5L size: 223.57 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: LV8i scheme: GPT
ID-1: / raw-size: 58.11 GiB size: 58.11 GiB (100.00%) used: 14 GiB (24.1%) fs: btrfs
    dev: /dev/sda6 maj-min: 8:6
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 612 KiB (0.1%) fs: vfat
    dev: /dev/sda5 maj-min: 8:5
  ID-3: /home raw-size: 58.11 GiB size: 58.11 GiB (100.00%) used: 14 GiB (24.1%) fs: btrfs
    dev: /dev/sda6 maj-min: 8:6
  ID-4: /var/log raw-size: 58.11 GiB size: 58.11 GiB (100.00%) used: 14 GiB (24.1%) fs: btrfs
    dev: /dev/sda6 maj-min: 8:6
  ID-5: /var/tmp raw-size: 58.11 GiB size: 58.11 GiB (100.00%) used: 14 GiB (24.1%) fs: btrfs
    dev: /dev/sda6 maj-min: 8:6
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.62 GiB used: 914.5 MiB (11.7%) priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 55.0 C pch: 51.5 C mobo: N/A
  Fan Speeds (RPM): fan-1: 3452
  Processes: 243 Uptime: 7h 35m wakeups: 3 Memory: 7.62 GiB used: 5.93 GiB (77.9%) Init: systemd
  v: 253 default: graphical tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1334
  libs: 369 tools: octopi,paru Client: shell wrapper v: 5.1.16-release inxi: 3.3.25
Garuda (2.6.15-1):
  System install date:     2022-12-02
  Last full system update: 2023-02-28 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

Thats good. Work

fastfetch --load-config dr460nized

for you?

We can edit the preset or add the garuda version and upload the picture.


Hey again,

fastfetch --load-config dr460nized

Worked very well for me, but is there a possibility to have the blue eagle instead of the red dragon ?

Coming soon :wink:




Should this show on Alacritty? Fonts are differently colored and the logo doesn't show. On konsole it looks just like in these pictures...

I'm afraid not, I believe the image relies on the Kitty graphics protocol. It is not a widely adopted protocol; Kitty, Konsole, and WezTerm use it but not many other terminals.


I have kinda grown fond of Alacritty. Is there a way to put a "normal" ASCII-logo to it?

I suppose, one can make a same kind of statement to the fish config, so that it only uses it on Alacritty?

I was referring to this:

## Run fastfetch if session is interactive
if status --is-interactive && type -q fastfetch
   fastfetch --load-config dr460nized

Yes, just take out the part that says "--load-config dr460nized".

Aside from that, you can configure the colors and output options in a Fastfetch config file if you like (check fastfetch --help for more information).


Ok, I'll be checking Fastfetch config out.

What I meant about using that ASCII-logo is, that it would keep using the picture one on the Konsole and would use the ASCII one on Alacritty... So, like without knowing the actual syntax, something like....

If Alacritty true use fastfetch else use that --load-config dr460nized


Well, I got it figured out.
First I added an env variable to Alacritty.yml.


  TERM: xterm-256color
  # TERM: alacritty
  TERM_PROGRAM: Alacritty

Then I added the following to the end of fish config:

if [ $TERM_PROGRAM = "Alacritty" ]

Alacritty again shows the ASCII-art and although fish nags a little...

[: Missing argument at index 3
= Alacritty
~/.config/fish/ (line 162):
if [ $TERM_PROGRAM = "Alacritty" ]
from sourcing file ~/.config/fish/
called during startup

I can take it :smiley: