Failed update - grub now broken

Hi, I ran upd today and let it do an update but I was distracted and timed out at the password prompt when everything was installed.

I rebooted later that day after shutting down my machine and I’ve now got grub issues. I see the welcome to grub message in the top-left but then my system drops into the bios. I don’t see a grub menu. Perhaps the EFI bios is set as the default entry?

I’ve done the following, using a live-usb (although one that doesn’t include time shift utilities, or I would have just restored the pre-update snapshot):

  1. Mounted and chroot’d into the partition, checked /boot/grub-btrfs.cfg and that all looks fine.

  2. Mounted and chroot’d into the partition, checked the output of efibootmgr -v and that shows the default is set to the device with grub installed, and the file is \EFI\GARUDA\GRUBX64.EFI

  3. From the live-usb, run Garuda Boot Repair and repaired the grub configuration file. This found all the entries I was expecting but didn’t restore normal operation. I tried this first.

Just wondering what my next steps are?

Fixed it:

Re-ran garuda boot repair and re-installed Grub into ESP. Then re-ran the grub config repair option.

I don’t get a graphical grub, instead getting a bunch of ‘out or memory’ errors, but at least it boots.

Search in forum for

You will find the solution.

4 Likes

Understood, thanks for the information.