Failed unmounting /root

Hey all, been using Garuda for a few years now and have run across an strange issue that wasn’t causing any problems until I tried updating today via sudo Pacman -Syu.

Whenever I restart my computer an error message appears in the terminal during shutdown that reads
[FAILED] Failed unmounting /root
This appears for a few seconds and then the computer reboots as normal. No other problems have come up and I’ve been using it like this for I can’t even remember how long.

Today I went and updated my system. Everything appeared to go smoothly and there was a Kernel update to

linux-lts-6.6.18-1 linux-lts-headers-6.6.18-1 linux-zen-6.7.6.zen1-1 linux-zen-headers-6.7.6.zen1-1

I restarted my computer after the update. I logged in just fine to find but then noticed that I had no connection to the internet. Running ip -a showed that I had an ipv6 address but no longer an ipv4 one. Well that’s weird I thought. I tried setting a manual IP address but still could get no connectivity. While I am unsure if the two problems are related, it was the first sign that something was up with whatever update I tried to do. Restoring from a timeshift snapshot to before the upgrade fixed things to the point I can use my machine at least.

So my question is basically what the heck is going on with unmounting /root when I shutdown. My best guess is that the kernel update is breaking because of the /root unmounting failure.

Googling has just turned up some people mentioning a failure to unmount /oldroot but not /root on shutdown.

Here’s the content of my /etc/fstab file that has /root in it along with some comments that have been created/modified by garuda-hotfxes

# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=4037-812C                            /boot/efi      vfat    umask=0077 0 2
UUID=ee2d80b5-d68a-423a-8222-20094ce9b132 / btrfs subvol=/@,defaults,noatime,space_cache,noautodefrag,compress=zstd 0 1 #Modified_by_garuda-hotfixes(1)
UUID=ee2d80b5-d68a-423a-8222-20094ce9b132 /home btrfs subvol=/@home,defaults,noatime,space_cache,noautodefrag,compress=zstd 0 2 #Modified_by_garuda-hotfixes(1)
UUID=ee2d80b5-d68a-423a-8222-20094ce9b132 /root btrfs subvol=/@root,defaults,noatime,space_cache,noautodefrag,compress=zstd 0 2 #Modified_by_garuda-hotfixes(1)
UUID=ee2d80b5-d68a-423a-8222-20094ce9b132 /srv btrfs subvol=/@srv,defaults,noatime,space_cache,noautodefrag,compress=zstd 0 2 #Modified_by_garuda-hotfixes(1)
UUID=ee2d80b5-d68a-423a-8222-20094ce9b132 /var/cache btrfs subvol=/@cache,defaults,noatime,space_cache,noautodefrag,compress=zstd 0 2 #Modified_by_garuda-hotfixes(1)
UUID=ee2d80b5-d68a-423a-8222-20094ce9b132 /var/log btrfs subvol=/@log,defaults,noatime,space_cache,noautodefrag,compress=zstd 0 2 #Modified_by_garuda-hotfixes(1)
UUID=ee2d80b5-d68a-423a-8222-20094ce9b132 /var/tmp btrfs subvol=/@tmp,defaults,noatime,space_cache,noautodefrag,compress=zstd 0 2 #Modified_by_garuda-hotfixes(1)
UUID=e00c2b78-2f22-430f-9d5a-4811280db73f swap           swap    defaults,noatime 0 0

#Downloads Drive (Western Digital RED 3TB drive)
UUID="141afebf-72a8-47cb-9514-d2c1cf5f5662" /home/user/Downloads btrfs defaults,noatime,noautodefrag 0 1 #Modified_by_garuda-hotfixes(1)

#Games Drive (1TB NVME Drive 2)
UUID="05306880-059c-489e-b5b7-d0826a1b931b" /games btrfs defaults,noatime 0 1

#Documents Drive
UUID="ef2965e8-a6f9-4245-966a-d5a224d5fa52" /home/user/Documents btrfs defaults,noatime,space_cache,noautodefrag 0 1 #Modified_by_garuda-hotfixes(1)

#Disc Drive
/dev/sr0 /mnt/cdrom udf,iso9660 noauto,user,ro 0 0

And the contents of garuda-inxi

  Kernel: 6.7.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=ee2d80b5-d68a-423a-8222-20094ce9b132 rw rootflags=subvol=@
    quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=e00c2b78-2f22-430f-9d5a-4811280db73f loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_x11 tools: avail: xscreensaver vt: 2 dm: SDDM
    Distro: Garuda base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI: American Megatrends v: 5102 date: 05/31/2023
  Device-1: hidpp_battery_0 model: Logitech MX Ergo Multi-Device Trackball
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
  Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
    L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 3603 high: 4866 min/max: 2200/5083 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3400 2: 3711
    3: 3722 4: 3400 5: 4209 6: 3596 7: 4257 8: 3732 9: 3600 10: 3600 11: 3400
    12: 3400 13: 3400 14: 3400 15: 3400 16: 3400 17: 3592 18: 3400 19: 4866
    20: 3400 21: 3400 22: 3702 23: 4290 24: 3636 25: 3600 26: 3400 27: 3400
    28: 3400 29: 3400 30: 3400 31: 3400 32: 3400 bogomips: 217603
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    vendor: Gigabyte driver: amdgpu v: kernel arch: RDNA-1 code: Navi-1x
    process: TSMC n7 (7nm) built: 2019-20 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: DP-1,DP-2,DP-3 empty: HDMI-A-1 bus-ID: 09:00.0
    chip-ID: 1002:731f class-ID: 0300
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2520 s-dpi: 96 s-size: 1016x666mm (40.00x26.22")
    s-diag: 1215mm (47.83")
  Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,bottom-c
    model: Asus ROG PG348Q serial: <filter> built: 2016 res: 3440x1440 dpi: 109
    gamma: 1.2 size: 798x335mm (31.42x13.19") diag: 865mm (34.1") modes:
    max: 3440x1440 min: 640x480
  Monitor-2: DP-2 mapped: DisplayPort-1 pos: top-right model: Acer XF270H B
    serial: <filter> built: 2018 res: 1920x1080 hz: 144 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  Monitor-3: DP-3 mapped: DisplayPort-2 pos: top-left model: Acer XF270H B
    serial: <filter> built: 2018 res: 1920x1080 hz: 144 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.1-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 5700 XT (radeonsi
    navi10 LLVM 16.0.6 DRM 3.57 6.7.5-zen1-1-zen) device-ID: 1002:731f
    memory: 7.81 GiB unified: no
  API: Vulkan v: 1.3.276 layers: 11 device: 0 type: discrete-gpu name: AMD
    Radeon RX 5700 XT (RADV NAVI10) driver: mesa radv v: 24.0.1-arch1.1
    device-ID: 1002:731f surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 24.0.1-arch1.1 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 09:00.1 chip-ID: 1002:ab38
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: SteelSeries ApS H Wireless
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 3-2.3:5 chip-ID: 1038:1220 class-ID: 0300
  API: ALSA v: k6.7.5-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
  Info: services: NetworkManager, smbd, sshd, systemd-timesyncd
  Local Storage: total: 5.5 TiB used: 1.3 TiB (23.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P1SSD8
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: P3CR021 temp: 43.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 3B4QFXO7 temp: 26.9 C
    scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1050MX300SSD1
    size: 978.09 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: R021 scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD30EFRX-68EUZN0 size: 2.73 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 0A82 scheme: GPT
  ID-1: / raw-size: 896.79 GiB size: 896.79 GiB (100.00%)
    used: 282.59 GiB (31.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%)
    used: 558 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 896.79 GiB size: 896.79 GiB (100.00%)
    used: 282.59 GiB (31.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 896.79 GiB size: 896.79 GiB (100.00%)
    used: 282.59 GiB (31.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 896.79 GiB size: 896.79 GiB (100.00%)
    used: 282.59 GiB (31.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 34.47 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: swap-2 type: zram size: 62.71 GiB used: 6.8 MiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 32 dev: /dev/zram0
  System Temperatures: cpu: 49.0 C mobo: 35.0 C gpu: amdgpu temp: 57.0 C
    mem: 58.0 C
  Fan Speeds (rpm): cpu: 0 case-1: 689 case-2: 703 case-3: 693 gpu: amdgpu
    fan: 0
  Power: 12v: 9.97 5v: N/A 3.3v: N/A vbat: 3.29 gpu: amdgpu watts: 37.00
  Memory: total: 64 GiB note: est. available: 62.71 GiB used: 6.64 GiB (10.6%)
  Processes: 560 Power: uptime: 25m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 25.05 GiB services: org_kde_powerdevil,upowerd
    Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 2152 libs: 507 tools: pamac,paru,yay Compilers:
    clang: 16.0.6 gcc: 13.2.1 Shell: garuda-inxi default: Zsh v: 5.9
    running-in: tilix inxi: 3.3.33
Garuda (2.6.23-1):
  System install date:     2021-04-29
  Last full system update: 2024-02-13
  Is partially upgraded:   Yes
  Relevant software:       timeshift NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:            

If any more information is needed I’m happy to provide it. I’d love to figure this out rather than reinstall the system since apparently I’ve been running this install since 2021 which I had no idea until I was posting this haha.

1 Like

Three years without a new installation! Respect.


I’d try upgrading everything but the kernel for a test, even if it complains “partial upgrade” it should work fine. If the network still works then the problem is likely with the kernel version. As far as I can tell 6.7.6 did not touch the igb driver though.
Aside, I think the “unmount root” thing may well be unrelated.

edit: quite likely Networkmanager 1.46.0-1 Update Breaks internet connectivity


8 posts were split to a new topic: Failed unmounting

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.