Failed to start Network Manager

Today morning I changed my router dns to opendns and then clear the dns cache with systemd-resolve --flush-caches. It didn't work on first try and I did something for that, but I don't remember well what I did. However then it worked well and now when I turn on the computer there is a error message in the booting saying Failed to start Network Manager and can't connect to wifi. How to fix this?

Edit 1:
Here is the output of systemctl status NetworkManger

Γ— NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
└─NetworkManager-ovs.conf
Active: failed (Result: exit-code) since Fri 2021-11-12 19:46:31 +0530; 7min ago
Docs: man:NetworkManager(8)
Process: 5853 ExecStart=/usr/bin/NetworkManager --no-daemon (code=exited, status=1/FAILURE)
Main PID: 5853 (code=exited, status=1/FAILURE)
CPU: 27ms

Nov 12 19:46:31 noname systemd[1]: NetworkManager.service: Scheduled restart job, restart counter is at 5.
Nov 12 19:46:31 noname systemd[1]: Stopped Network Manager.
Nov 12 19:46:31 noname systemd[1]: NetworkManager.service: Start request repeated too quickly.
Nov 12 19:46:31 noname systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
Nov 12 19:46:31 noname systemd[1]: Failed to start Network Manager.

Edit 2:
Here is my inxi -Faz

System:
Kernel: 5.14.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=31462efd-23b4-43d9-9128-7cb5083a1f03 rw [email protected] quiet
splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1
resume=UUID=37a06802-8265-4d92-901e-28812d45594f loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: SAMSUNG product: Samsung DeskTop System v: CAAAAAAF
serial: <filter> Chassis: SAMSUNG ELECTRONICS CO., LTD type: 3
serial: <filter>
Mobo: SAMSUNG model: Samsung DeskTop System serial: <filter> BIOS: SAMSUNG
v: 00PE date: 11/12/2009
CPU:
Info: Quad Core model: Intel Core2 Quad Q6600 bits: 64 type: MCP
arch: Core Merom family: 6 model-id: F (15) stepping: B (11) microcode: BA
cache: L2: 4 MiB
flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 19153
Speed: 2394 MHz min/max: 1600/2400 MHz Core speeds (MHz): 1: 2394 2: 2394
3: 2394 4: 2394
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled
Type: mds
status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 4 Series Integrated Graphics vendor: Samsung Co
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:2e32 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.6x8.0")
s-diag: 338mm (13.3")
Monitor-1: VGA1 res: 1024x768 dpi: 63 size: 410x230mm (16.1x9.1")
diag: 470mm (18.5")
OpenGL: renderer: Mesa DRI Intel G41 (ELK) v: 2.1 Mesa 21.2.4
direct render: Yes
Audio:
Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: Samsung Co
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:27d8
class-ID: 0403
Sound Server-1: ALSA v: k5.14.14-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Samsung Co driver: r8169 v: kernel port: 2000 bus-ID: 04:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: down mac: <filter>
Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u
bus-ID: 1-8:6 chip-ID: 148f:7601 class-ID: 0000 serial: <filter>
IF: wlp0s29f7u8 state: down mac: <filter>
Drives:
Local Storage: total: 409.88 GiB used: 65.41 GiB (16.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3320820AS
size: 298.09 GiB block-size: physical: 512 B logical: 512 B
speed: <unknown> type: N/A serial: <filter> rev: D scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 model: AITC KSM 120GB size: 111.79 GiB
block-size: physical: 512 B logical: 512 B speed: <unknown> type: SSD
serial: <filter> rev: 2A0 scheme: MBR
Partition:
ID-1: / raw-size: 103.43 GiB size: 103.43 GiB (100.00%)
used: 65.41 GiB (63.2%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-2: /home raw-size: 103.43 GiB size: 103.43 GiB (100.00%)
used: 65.41 GiB (63.2%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-3: /var/log raw-size: 103.43 GiB size: 103.43 GiB (100.00%)
used: 65.41 GiB (63.2%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/tmp raw-size: 103.43 GiB size: 103.43 GiB (100.00%)
used: 65.41 GiB (63.2%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.8 GiB used: 26.8 MiB (0.7%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.36 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sdb2 maj-min: 8:18
Sensors:
System Temperatures: cpu: 66.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 192 Uptime: 21m wakeups: 0 Memory: 3.8 GiB
used: 1.75 GiB (46.2%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 12.0.1 Packages: 1367 pacman: 1362 lib: 338 flatpak: 5
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole
inxi: 3.3.08

Edit 3:
As I was going through journalctl -xeu NetworkManager.service, I found this. Is this the cause of the problem?

β–‘β–‘ Subject: Unit succeeded
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ The unit NetworkManager.service has successfully entered the 'dead' state.
Nov 11 22:32:20 noname systemd[1]: Stopped Network Manager.
β–‘β–‘ Subject: A stop job for unit NetworkManager.service has finished
β–‘β–‘ Defined-By: systemd
β–‘β–‘ Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
β–‘β–‘
β–‘β–‘ A stop job for unit NetworkManager.service has finished.
β–‘β–‘
β–‘β–‘ The job identifier is 4808 and the job result is done.

Edt 4:
Here is another unit in journalctl.

Nov 12 19:21:25 noname NetworkManager[523]: Failed to read configuration: /etc/NetworkManager/conf.d/no-systemd-resolved.conf: Key file does not start with a group

I don't think I'll be able to help you, but I just wanted to refer you to the wiki page where you could double-check something, e.g. /etc/resolv.conf symlink, /etc/NetworkManager/conf.d/dns.conf, etc.
Just in case...
https://wiki.archlinux.org/title/NetworkManager#DNS_management

PS: please always remember to provide your inxi -Faz

1 Like

Most likely not the issue here, but the system should be updated.
We are at 5.14.16 now.

Yeah I need to update, but how to do it without wifi.

Reading WiFi (and without thinking...) I thought your Ethernet was available and working, sorry...
Have you tried with a live USB (if network works there), chroot and update?

No. I mean can we update the system with a live usb?

Yes, if you chroot from the live USB into your system (there is a tool in the live USB or a tutorial in the forum). But of course you must have connectivity.

1 Like

Or use WiFi/USB tethering with your cell, if possible.

1 Like

I have fixed the problem
I deleted the /etc/NeNetworkManager/conf.d/no-systemd-resolved.conf

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.