Failed to retrieve file chaotic-aur.db from geo-mirror.chaotic.cx

System:
Kernel: 5.18.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=534ff39c-38b3-45da-9637-b80d11db71ad rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.1 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 81N7 v: Lenovo IdeaPad S340-14IWL
serial: <superuser required> Chassis: type: 10 v: Lenovo IdeaPad S340-14IWL
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN
serial: <superuser required> UEFI: LENOVO v: ALCN32WW(V2.09)
date: 01/15/2021
Battery:
ID-1: BAT1 charge: 25.1 Wh (60.5%) condition: 41.5/52.5 Wh (79.0%)
volts: 11.5 min: 11.2 model: Celxpert L18C3PF7 type: Li-ion
serial: <filter> status: discharging cycles: 893
CPU:
Info: model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Whiskey Lake
gen: core 8 built: 2018 process: Intel 14nm family: 6 model-id: 0x8E (142)
stepping: 0xB (11) microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 812 high: 861 min/max: 400/3900 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 828 4: 861
5: 800 6: 800 7: 800 8: 814 bogomips: 28800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Lenovo
driver: i915 v: kernel arch: Gen9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:3ea0 class-ID: 0300
Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
bus-ID: 1-6:2 chip-ID: 13d3:56b2 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: BOE Display 0x07d3 built: 2018 res: 1920x1080
hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2)
v: 4.6 Mesa 22.1.2 direct render: Yes
Audio:
Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:9dc8 class-ID: 0403
Sound Server-1: ALSA v: k5.18.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.0 running: no
Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth:
Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-10:3
chip-ID: 0cf3:e500 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 90.84 GiB (19.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN520 SDAPMUW-512G-1101 size: 476.94 GiB block-size:
physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
serial: <filter> rev: 20240001 temp: 44.9 C scheme: GPT
Partition:
ID-1: / raw-size: 200 GiB size: 200 GiB (100.00%) used: 90.78 GiB (45.4%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 59.8 MiB (11.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 200 GiB size: 200 GiB (100.00%)
used: 90.78 GiB (45.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 200 GiB size: 200 GiB (100.00%)
used: 90.78 GiB (45.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 200 GiB size: 200 GiB (100.00%)
used: 90.78 GiB (45.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.49 GiB used: 7.2 MiB (0.1%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 51.0 C pch: 50.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 253 Uptime: 2h 24m wakeups: 55 Memory: 7.49 GiB
used: 3.34 GiB (44.5%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 Packages: pacman: 1458 lib: 389
Shell: fish v: 3.4.1 running-in: konsole inxi: 3.3.18
Garuda (2.6.4-1):
System install date:     2022-06-21
Last full system update: 2022-06-23
Is partially upgraded:   Yes
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

i am getting error that failed to retrieve chaotic-aur.db from geo-mirror.chaotic.cx and i have seen same error and solution in another forum thread but i tried that solution didn't worked
i tried following commands

  1. paru
  2. upd
  3. update
  4. garuda-update
  5. in garuda assistant refresh keyrings and refresh mirrors and then system update
    so every time i got that error

Is it the same message as in the linked thread? Please always paste the exact terminal output (as text).
If so, just ignore it, I guess it will be fixed on the other side.

3 Likes

But My packages is not updating rather system

And yes i was about to ask someone when i usually update everything with paru or yay command they garuda system maintenance shows that system is partially upgraded and it is harmfull to some packages so what is the correct method of updating system with all apps downloaded

Please post the full output of garuda-update as text (I see the garuda-inxi was properly formatted :wink:, thanks)

1 Like
garuda-update
[sudo] password for ****:      
:: Synchronizing package databases...
core is up to date
extra is up to date
community                               6.7 MiB  2.32 MiB/s 00:03 [------------------------------------] 100%
multilib is up to date
chaotic-aur                          1918.8 KiB   787 KiB/s 00:02 [------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronizing package databases...
core                                  156.4 KiB   376 KiB/s 00:00 [------------------------------------] 100%
extra                                1719.1 KiB  1308 KiB/s 00:01 [------------------------------------] 100%
community                               6.7 MiB  2.69 MiB/s 00:02 [------------------------------------] 100%
multilib                              170.5 KiB   455 KiB/s 00:00 [------------------------------------] 100%
chaotic-aur                          1918.8 KiB  1250 KiB/s 00:02 [------------------------------------] 100%
error: failed retrieving file 'chaotic-aur.db' from geo-mirror.chaotic.cx : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
spawn pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (12) candy-icons-git-r901.a7266d7-1  ckbcomp-1.208-1  geoip-database-20220621-1
lib32-openssl-1:1.1.1.p-1  libidn-1.40-1  libpulse-16.1-1  linux-firmware-20220610.7b71b75-1
linux-firmware-whence-20220610.7b71b75-1  linux-lts-5.15.49-1  linux-lts-headers-5.15.49-1
openssl-1.1.1.p-1  sof-firmware-2.1.1.a-1

Total Installed Size:  466.16 MiB
Net Upgrade Size:       -1.18 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
ckbcomp-1.208-1-any is up to date
error: failed retrieving file 'ckbcomp-1.208-1-any.pkg.tar.zst.sig' from mirror.albony.xyz : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
warning: failed to retrieve some files
error: failed to commit transaction (download library error)
Errors occurred, no packages were upgraded.

I believe the root cause of this (and probably consequently of your partial upgrade status) is in a networking issue rather than chaotic-aur status or relevant configuration (e.g. mirror.albony.xyz seems to have been always operational today from the statistics).
Give a look at the post below and try applying those suggestions. Unfortunatly the post was never confirmed as a solution, but I saw the same suggestions in other threads for your wifi card (I'm linking this one because it provides several options).

In my opinion the partial upgrade is due to a previous update with this issue (e.g. it seems to me that in this case ckbcomp was actually installed, but then the transaction stopped). If so, this should be fixed automatically by garuda-update when we manage to have it complete successfully.
Of course, unless you set any package in the IgnorePkg line in your /etc/pacman.conf (but I don't think this is the case)

2 Likes

Hi there, welcome to the community.

In /etc/pacman.d/mirrorlist , comment all the lines ( or simply delete all the lines ) and add

Server = http://in-mirror.garudalinux.org/archlinux/$repo/os/$arch
Server = https://in-mirror.garudalinux.org/archlinux/$repo/os/$arch

Similarly, comment out all mirrors except in-mirror.garudalinux.org in /etc/pacman.d/chaotic-mirrorlist

And run

sudo pacman -Syyuu

And paste the output here.

5 Likes

Thank you guys for helping out with it but it was resolved on its own may be mirror was under maintenance but mr Naman i would like to ask what is best way to update and upgrade system with all the packages that i don't get partial update warning usually i use paru command without any options and also yay sometimes . so what is best way that i don't encounter partial update warning???

garuda-update -a

The -a option is used to update also the AUR, so avoiding the additional use of paru or yay.

6 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.