Atheros QCA9377 - Slow wireless speed

I've tried a lot of distros, but internet speed barely reaches 500kb while it reaches 30 mbps on windows on the dual boot.
As of now I've tried Power management settings.

Dell i5 3567
Qualcomm athenos wireless wifi network chip.

Hi there, welcome!
Please provide your system specs via inxi -Fza as text, formatted with 3 ~ before and after the text block.


We neither have any influence on the download speed nor do we install brakes.
If the servers are in high demand, as is the case with Arch or Garuda, traffic jams can occur :wink:


Several common Atheros cards have a multitude of different fixes.

Without knowing your specs we really can only make general recommendations.

As your wifi driver module(s) are included in the kernel the first place to start is with testing alternate kernels. Have a look at other posts on the forum in the Networking category to see which kernels are most often reccomended for troubleshooting purposes.

Run inxi -Faz in the terminal. Find your Atheros wifi chip model and search the forum for fixes for your specific model. Post all fixes you have attempted and the results.

Be sure to post the output of inxi -Faz.

Welcome to Garuda.

           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=03687889-237e-45ad-a9bf-d6c6f7aff21b 
           rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A serial: <filter> Chassis: type: 9 
           serial: <filter> 
           Mobo: Dell model: 0D53F5 v: A00 serial: <filter> UEFI: Dell v: 2.10.0 date: 05/10/2019 
Battery:   ID-1: BAT0 charge: 19.9 Wh (94.3%) condition: 21.1/41.4 Wh (51.0%) volts: 17.2 min: 14.8 
           model: SMP DELL VN3N047 type: Li-ion serial: <filter> status: Charging 
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake 
           note: check family: 6 model-id: 8E (142) stepping: 9 microcode: EA cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21599 
           Speed: 3100 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 3100 2: 3101 3: 3101 4: 3102 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:5916 class-ID: 0300 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] 
           vendor: Dell driver: radeon v: kernel alternate: amdgpu bus-ID: 01:00.0 chip-ID: 1002:6660 
           class-ID: 0380 
           Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:32 
           chip-ID: 1bcf:28c0 class-ID: 0e02 
           Display: x11 server: X.Org 1.20.12 compositor: gnome-shell driver: loaded: ati,intel,radeon 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :1 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 21.1.5 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403 
           Sound Server-1: ALSA v: k5.13.5-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.32 running: yes 
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell 
           driver: ath10k_pci v: kernel port: e000 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel 
           port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200 
           IF: enp3s0 state: down mac: <filter> 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-8:9 chip-ID: 0cf3:e009 
           class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter> 
Drives:    Local Storage: total: 946.35 GiB used: 7.15 GiB (0.8%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10JPVX-75JC3T0 size: 931.51 GiB 
           block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 
           serial: <filter> rev: 1A02 scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Generic model: SD MMC size: 14.84 GiB 
           block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> rev: 1.00 scheme: MBR 
Partition: ID-1: / raw-size: 93.48 GiB size: 93.48 GiB (100.00%) used: 7.11 GiB (7.6%) fs: btrfs 
           dev: /dev/sda8 maj-min: 8:8 
           ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 41.9 MiB (43.6%) fs: vfat 
           dev: /dev/sda2 maj-min: 8:2 
           ID-3: /home raw-size: 93.48 GiB size: 93.48 GiB (100.00%) used: 7.11 GiB (7.6%) fs: btrfs 
           dev: /dev/sda8 maj-min: 8:8 
           ID-4: /var/log raw-size: 93.48 GiB size: 93.48 GiB (100.00%) used: 7.11 GiB (7.6%) fs: btrfs 
           dev: /dev/sda8 maj-min: 8:8 
           ID-5: /var/tmp raw-size: 93.48 GiB size: 93.48 GiB (100.00%) used: 7.11 GiB (7.6%) fs: btrfs 
           dev: /dev/sda8 maj-min: 8:8 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 5.67 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 44.0 C mobo: 41.0 C gpu: radeon temp: 34.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 245 Uptime: 11h 15m wakeups: 2 Memory: 5.67 GiB used: 2.12 GiB (37.5%) Init: systemd 
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1124 lib: 301 
           Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.06~~~

These is my setup

Many fixes you could test on this thread:

Kernel boot parameters are likely your best bet.

Try these options individually or in combination.:






I would also disable IPv6 and test alternate kernels.

Welcome to Garuda, I hope you don't mind I edited your thread title to include your adapter model.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.