Failed to prepare transaction

Do note this is on a fresh install
Hello.

System:    Kernel: 5.13.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=0c2d4a81-1edf-4680-a1bd-07f0cf763f3c  
rw [email protected] quiet
cryptdevice=UUID=f4009b95-432a-4cb6-9755-d14e47d349ff:luks-f4009b95-432a-4cb6-9755-d14e47d349ff
root=/dev/mapper/luks-f4009b95-432a-4cb6-9755-d14e47d349ff splash rd.udev.log_priority=3
vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Razer product: Blade Pro v: 2.56 serial: <filter> Chassis: type: 9  
serial: <filter>  
Mobo: Razer model: Blade Pro serial: <filter> UEFI: Razer v: 2.02 date: 02/22/2018  
Battery:   ID-1: BAT0 charge: 54.8 Wh (95.8%) condition: 57.2/70.2 Wh (81.4%) volts: 12.7 min: 11.4  
model: Razer Blade Pro type: Unknown serial: <filter> status: Discharging  
CPU:       Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MCP arch: Kaby Lake family: 6  
model-id: 9E (158) stepping: 9 microcode: EA cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 22399  
Speed: 3738 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 3738 2: 3715 3: 3507 4: 3740  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported  
Type: l1tf mitigation: PTE Inversion  
Type: mds mitigation: Clear CPU buffers; SMT disabled  
Type: meltdown mitigation: PTI  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel HD Graphics 630 vendor: Razer USA driver: i915 v: kernel bus-ID: 00:02.0  
chip-ID: 8086:591b class-ID: 0300  
Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Razer USA driver: nouveau v: kernel  
bus-ID: 01:00.0 chip-ID: 10de:1c20 class-ID: 0300  
Device-3: Sunplus Innovation USB Camera type: USB driver: uvcvideo bus-ID: 1-9:7  
chip-ID: 1bcf:2c98 class-ID: 0e02  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel,nouveau  
unloaded: modesetting alternate: fbdev,nv,vesa display-ID: :0 screens: 1  
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2") s-diag: 1052mm (41.4")  
Monitor-1: eDP1 res: 1920x1080 hz: 120 dpi: 128 size: 380x210mm (15.0x8.3") diag: 434mm (17.1")  
Monitor-2: HDMI-1-2 res: 1920x1080 hz: 60 dpi: 102 size: 476x268mm (18.7x10.6")  
diag: 546mm (21.5")  
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes  
Audio:     Device-1: Intel CM238 HD Audio vendor: Razer USA driver: snd_hda_intel v: kernel  
bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403  
Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 01:00.1  
chip-ID: 10de:10f1 class-ID: 0403  
Device-3: Astro Gaming Astro A50 type: USB driver: hid-generic,snd-usb-audio,usbhid  
bus-ID: 1-6:4 chip-ID: 9886:002c class-ID: 0300  
Sound Server-1: ALSA v: k5.13.13-zen1-1-zen running: yes  
Sound Server-2: sndio v: N/A running: no  
Sound Server-3: JACK v: 1.9.19 running: no  
Sound Server-4: PulseAudio v: 15.0 running: yes  
Sound Server-5: PipeWire v: 0.3.34 running: yes  
Network:   Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Razer USA driver: alx  
v: kernel port: d000 bus-ID: 3b:00.0 chip-ID: 1969:e0b1 class-ID: 0200  
IF: enp59s0 state: down mac: <filter>  
Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Rivet Networks  
driver: ath10k_pci v: kernel port: d000 bus-ID: 3c:00.0 chip-ID: 168c:003e class-ID: 0280  
IF: wlp60s0 state: up mac: <filter>  
IF-ID-1: anbox0 state: down mac: <filter>  
Bluetooth: Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb v: 0.8 bus-ID: 1-7:5  
chip-ID: 0cf3:e300 class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>  
Drives:    Local Storage: total: 6.37 TiB used: 57.46 GiB (0.9%)  
SMART Message: Unable to run smartctl. Root privileges required.  
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WDBRPG5000ANC-WRSN  
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD  
serial: <filter> rev: 102000WD temp: 44.9 C scheme: MBR  
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM015-2E8174 size: 1.82 TiB  
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: SDM1 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital model: WD My Passport 264F
size: 465.73 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
rev: 2005 scheme: MBR
ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital model: WD My Book 25EE
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B type: N/A serial: <filter> rev: 4009
scheme: GPT
Partition: ID-1: / raw-size: 465.35 GiB size: 465.35 GiB (100.00%) used: 57.43 GiB (12.3%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-f4009b95-432a-4cb6-9755-d14e47d349ff
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 26.2 MiB (27.3%) fs: vfat
dev: /dev/sda3 maj-min: 8:3
ID-3: /home raw-size: 465.35 GiB size: 465.35 GiB (100.00%) used: 57.43 GiB (12.3%) fs: btrfs
dev: /dev/dm-0 maj-min: 254:0 mapped: luks-f4009b95-432a-4cb6-9755-d14e47d349ff
ID-4: /var/log raw-size: 465.35 GiB size: 465.35 GiB (100.00%) used: 57.43 GiB (12.3%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-f4009b95-432a-4cb6-9755-d14e47d349ff
ID-5: /var/tmp raw-size: 465.35 GiB size: 465.35 GiB (100.00%) used: 57.43 GiB (12.3%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0 mapped: luks-f4009b95-432a-4cb6-9755-d14e47d349ff
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.7 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 62.5 C mobo: 29.8 C gpu: nouveau temp: 66.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 255 Uptime: 1h 46m wakeups: 1 Memory: 62.7 GiB used: 5.12 GiB (8.2%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 2023 lib: 568
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

every time I attempt to install anything from the "add/remove software" I am greeted with "Failed to prepare transaction"> target not found: phantomjs.

Last I checked phantomjs was deprecated and dead. I have -tried- installing it anyways only to be met with that same message. How do fix?

so....nothing I have googled has turned up any meaningful results for this so here I am. Trust me I'm not any happier about asking for help from this forum then you are to see it. But, "Needs must when the devil drives."

1 Like

no.....meaningful....results.....

1 Like

And you provide no meaningful information for us to help properly. What packages are you updating? Whats the rest of the output?

1 Like

im not updating anything. this happens when i try to install anything....like the post said.

and that is the entire output.

What are you trying to install

Exact package name

why does the word ANYTHING keep getting skipped?

1 Like

Never install software if not up-to-date.

2 Likes

facepalm....thanks for the tip.

Well you are trolling ?

2 Likes

do you want a screenshot?

No, we do not like screenshots from terminal.
BTW, use terminal, not pamac.

2 Likes

If you had done what I wrote, your "problem" would have been solved long ago.

To avoid partial installations, the first thing to do after a fresh installation is to bring the system up to date and, if necessary, update the mirrors.

Have fun with Arch :smiley:

4 Likes

2 Likes

Yes you are mad and respectless. I guess you know better than everyone else here so good luck figuring it out :blush:

3 Likes