Failed to prepare transaction II

https://forum.garudalinux.org/t/failed-to-prepare-transaction-invalid-or-corrupt-database/21836/10

Is this possibly why GNS3 and Dynamips preventing installation of other programs and failing to update, giving me following messages: "failed to prepare transaction", "target not found"?

I had to uninstall these apps using Stacer as Chaotic would not remove them, triggering the same message.

Now I can't install, and am given the same message.

Seems to be my only problem package. Thanks in advance.

Just noticed. Also getting this message in Discover, which is prompting an update for python-pynput: chaotic-aur/python-pynput: unexpected error.

Possibly the same problem?

Please try garuda-update from a terminal and paste the output here to better understand what's going on

2 Likes

:: Synchronizing package databases...
garuda is up to date
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur is up to date
blackarch is up to date

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Synchronizing package databases...
garuda 95.6 KiB 89.3 KiB/s 00:01 [------------------------------------------] 100%
core 157.2 KiB 548 KiB/s 00:00 [------------------------------------------] 100%
extra 1719.8 KiB 1843 KiB/s 00:01 [------------------------------------------] 100%
community 7.0 MiB 3.55 MiB/s 00:02 [------------------------------------------] 100%
multilib 170.9 KiB 244 KiB/s 00:01 [------------------------------------------] 100%
chaotic-aur 2.3 MiB 740 KiB/s 00:03 [------------------------------------------] 100%
blackarch 3.7 MiB 1089 KiB/s 00:03 [------------------------------------------] 100%
spawn pacman -Su
:: Starting full system upgrade...
there is nothing to do

Checking for plugin updates
Nothing to install / update

System updated! :penguin:

FYI: I ran garuda-update after I restored a disk image of an earlier version of Garuda, and now GNS3 and Dynamips update, uninstall, and reinstall no problem, but GNS3 still doesn't load. Still getting the same python-pynput error.

python-pynput isn't or isn't anymore in the Chaotic AUR repo.
Try installing it with an helper, e.g.

paru python-pynput
3 Likes

Should he uninstall the chaotic-aur version first? I always do but not sure if I am suppose to.

It should not be necessary. The underlying pacman should take care of the replace.
It won't hurt anyway.

1 Like

This is the output and then just stops. Nothing happens, and the python-pynput update/error is still happening in Discover.

╰─λ paru python-pynput
2 aur/python-pynput 1.7.6-2 [+20 ~3.54] [Installed: 1.7.6-1]
Python library to monitor and control user input devices
1 blackarch/python-pynput 1.7.6-1 [122.61KiB 764.65KiB] [Installed]
Monitor and control user input devices.
:: Packages to install (eg: 1 2 3, 1-3):
:: 2
:: Resolving dependencies...
:: Calculating conflicts...
:: Calculating inner conflicts...

Repo Make (4) python-pep517-0.13.0-1 python-build-0.8.0-2 python-installer-0.5.1-1
python-wheel-0.37.1-1
Aur (1) python-pynput-1.7.6-2

:: Proceed to review? [Y/n]: y

:: Downloading PKGBUILDs...
PKGBUILDs up to date
/home/**********/.cache/paru/clone/python-pynput/.gitignore

Ignore everything

But not these files...

!.gitignore
!PKGBUILD
!.SRCINFO
!setup.patch

/home/**********/.cache/paru/clone/python-pynput/PKGBUILD

Maintainer: Mark Wagie

Contributor: Juliette Monsel <j_4321 at protonmail dot com>

pkgname=python-pynput
_name=${pkgname#python-}
pkgver=1.7.6
pkgrel=2
pkgdesc="Python library to monitor and control user input devices"
arch=('any')
url="GitHub - moses-palmer/pynput: Sends virtual input commands"
license=('LGPL3')
depends=('python-xlib' 'python-six' 'python-evdev')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
'setup.patch')
sha256sums=('3a5726546da54116b687785d38b1db56997ce1d28e53e8d22fc656d8b92e533c'
:

Tried to uninstall python-pynput from chaotic, but wouldn't because it was a dependency for guiscrcpy. Uninstalled guiscrcpy from chaotic, and problem solved. Reinstalled and same problem. Installed guiscrcpy flatpak from Discover and no python-pynput error. So I guess I'll stick with the flatpak.

Would have never figured out where to find python-pynput without you guys. Thanks.

I was originally moved to this room from:

Even though no more error messages for GNS3 and Dynamips, GNS3 still won't run. Was it possibly removed from Chaotic? Sad if so. It is by far the easiest way to get GNS3 up and running. Is there a list of packages removed from chaotic? I hadn't used GNS3 for several months and maybe that's why I missed the issue. I dunno, any thoughts? Thanks.

We know that, it's under your first post, it was moved because your post is not an announcement.

Please mark the solution.

Is there a page that explains the meaning/reason for links under first post? It's not clear to those who don't know.

There was no solution specifically for the choatic AUR problem. Do I mark my own comment about changing to flatpak?

Are you sure you didn't stop at the PKGBUILD review during the paru process above?
You should exit that preview with button q then confirm the installation with Y.
Edit: I see now you probably solved the problem with a flatpak.

1 Like

Just to be clear so as not to unecessarily burden anyone. What exactly do you mean it was moved because its not an annoucement? Is there a post explaining this? Just want to be better. Thanks.

Had no idea. Let me try. Will post momentarily. Thanks.

That was it. Never used paru. Was expecting a prompt or something to continue, so I just thought it was hanging.

1 Like

A help request is just not an announcement, what is there to explain?

It would only fill the forum unnecessarily with posts if every action of a moderator would be explained. Apart from that it would make the readability more difficult. Similarly, if you write a new post every minute, without simply editing the old one if you still think of something, as long as no one else responded to it.

2 Likes

I guess I'm just stupid to see that distinction anywhere. Sorry to inconvenience you with my utter ignorance.

In the meantime. Is there a solution for GNS3, or no? Seems like I'm the only person to have ever posted about GNS3 on this forum.

Please, open new request, this one is solved.

@firephynix