Failed to allocate a zstd buffer

Ran garuda update. Restart pc and kaboom i can't boot. I saw this post Failed allocate zstd buffer
But no solution was marked and preety old so i am creating a new.
I have zero idea about boot things. So please be kind.

Try reinstalling grub from a live system as described here: Grub fails after update - #3 by librewish

Connect to the forum from the live system and paste the terminal output into the thread if you need guidance or feedback.

2 Likes

Hey, have you tried booting a snapshot?

2 Likes

no options from the grub menu works, not even shutdown and restart.

i don't a medium to live system currently.
from bios or uefi (the menu you get by pressing f12) i selected the first boot option which take me to the grub which worked absolutely fine. As far as i know, my motherboard always booted the first option cause that is how boot order should work.
i have to do this everytime i start my machine.

(i press power on button, leave my machine, see grub menu counting 5 to 1, says failed to allocate a zstd buffer and no options works.
i press restart button, leave my machine, see....
but if I
i press restart button, press f12, selects first boot option, see grub counting 5 to 1, boots to garuda)

as i can work in my machine now like this, is there any log or command that should i run to help you investigate or to fix it?

sudo grub-install --efi-directory=/boot/efi && update-grub

2 Likes
[[email protected] ~]# sudo grub-install --efi-directory=/boot/efi && update-grub
Installing for x86_64-efi platform.
Installation finished. No error reported.
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda-dr460nized/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-zen-fallback.img
fgrep: warning: fgrep is obsolescent; using grep -F
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/[email protected]/EFI/Microsoft/Boot/bootmgfw.efi
Found Garuda Linux on /dev/nvme0n1p2
Found Ubuntu 20.04.4 LTS on /dev/nvme0n1p2
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2022-09-21 21:48:56 | @/.snapshots/463/snapshot                 | post | alltray libwnck libxres |
Found snapshot: 2022-09-21 21:48:55 | @/.snapshots/462/snapshot                 | pre  | pacman -S alltray       |
Found snapshot: 2022-09-21 19:39:43 | @/.snapshots/461/snapshot                 | post | polybar                 |
Found snapshot: 2022-09-21 19:39:42 | @/.snapshots/460/snapshot                 | pre  | pacman -S polybar       |
Found snapshot: 2022-09-21 19:24:21 | @/.snapshots/459/snapshot                 | post | cmatrix                 |
Found snapshot: 2022-09-21 19:24:20 | @/.snapshots/458/snapshot                 | pre  | pacman -Rsn cmatrix     |
Found snapshot: 2022-09-21 18:54:36 | @/.snapshots/457/snapshot                 | post | spotify                 |
Found snapshot: 2022-09-21 18:54:34 | @/.snapshots/456/snapshot                 | pre  | pacman -S spotify       |
Found snapshot: 2022-09-21 18:31:05 | @/.snapshots/455/snapshot                 | post | luit xbitmaps xterm     |
Found snapshot: 2022-09-21 18:31:04 | @/.snapshots/454/snapshot                 | pre  | pacman -Rsn xterm       |
Found snapshot: 2022-09-15 10:05:32 | @_backup_20221509100720383_before-restore | N/A  | N/A                     |
Found 11 snapshot(s)
Unmount /tmp/grub-btrfs.0SLcmasdlQ .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done

i guess it's allright now, but why it detects ubuntu on the same partition of garuda.

Docker containers? Systemd nspawn? One of the two maybe?

3 Likes

no idea about systemd nspawn, it is docker then.