Failed allocate zstd buffer

Hello,

as of todays update my system's unable to boot. I need assistance, but I'm unable to give a lot of information about said system, only that I've been updating it daily and that it is in good working order. The error I'm getting is

Failed allocate zstd buffer

right after

booting garuda linux

and that's it. I cant load any fallback or snapshot because of that same error. I've searched a bit for it and it seems to be a grub error, maybe? There has been a kernel update today, so maybe something went wrong with that?

This indeed stems from the recent grub issues, it has been resolved via a rerun of grub-install.

grub-install --version
grub-install (GRUB) 2:2.06.r322.gd9b4638c5-1


inxi -Faz
System:
  Kernel: 5.19.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=66e5d40a-2370-44f3-b3b6-ddff5b2046cf rw [email protected]
    ipv6.disable=1 quiet splash rd.udev.log_priority=3
    vt.global_cursor_default=0
    resume=UUID=e5f09ca4-2e13-4405-b97d-9a69816c4515 ipv6.disable=1
    loglevel=3 ibt=off
  Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: bspwm
    v: 0.9.10 vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: B550 AORUS PRO V2
    serial: <superuser required> UEFI: American Megatrends LLC. v: F14e
    date: 10/14/2021
CPU:
  Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3 gen: 4
    built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x21 (33)
    stepping: 0 microcode: 0xA201016
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 2436 high: 3800 min/max: 2200/4850 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2200 2: 3140
    3: 3800 4: 2200 5: 2200 6: 2200 7: 2787 8: 2200 9: 2200 10: 2200 11: 2200
    12: 2200 13: 2853 14: 2200 15: 2200 16: 2200 bogomips: 121362
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] vendor: ZOTAC
    driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-07) arch: Ampere code: GAxxx process: TSMC n7
    (7nm) built: 2020-22 pcie: gen: 2 speed: 5 GT/s lanes: 16 link-max:
    gen: 4 speed: 16 GT/s bus-ID: 07:00.0 chip-ID: 10de:2504 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: Picom v: git-c4107
    driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x572mm (40.00x22.52")
    s-diag: 1166mm (45.9")
  Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 140
    size: 697x392mm (27.44x15.43") diag: 800mm (31.48") modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
Audio:
  Device-1: NVIDIA GA106 High Definition Audio vendor: ZOTAC
    driver: snd_hda_intel bus-ID: 1-6.3:6 v: kernel pcie: chip-ID: 19f7:0015
    gen: 4 class-ID: 0300 speed: 16 GT/s serial: <filter> lanes: 16
    bus-ID: 07:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: RODE Microphones RØDE NT-USB Mini type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.19.4-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 06:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
RAID:
  Device-1: sink type: zfs status: ONLINE level: raidz1-0 raw: size: 49.1 TiB
    free: 32.6 TiB allocated: 16.5 TiB zfs-fs: size: 32.58 TiB free: 21.57 TiB
  Components: Online:
  1: sda maj-min: 8:0 size: 16.37 TiB
  2: sdb maj-min: 8:16 size: 16.37 TiB
  3: sdc maj-min: 8:32 size: 16.37 TiB
Drives:
  Local Storage: total: raw: 50.93 TiB usable: 34.4 TiB used: 12.03 TiB
    (35.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Corsair model: MP600 PRO XT
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: EIFM31.2 temp: 31.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MG09ACA18TE
    size: 16.37 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0104 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: MG09ACA18TE
    size: 16.37 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0104 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Toshiba model: MG09ACA18TE
    size: 16.37 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0104 scheme: GPT
Partition:
  ID-1: / raw-size: 1.75 TiB size: 1.75 TiB (100.00%) used: 1.02 TiB (57.9%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 592 KiB
    (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 1.75 TiB size: 1.75 TiB (100.00%) used: 1.02 TiB
    (57.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 1.75 TiB size: 1.75 TiB (100.00%) used: 1.02 TiB
    (57.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.75 TiB size: 1.75 TiB (100.00%) used: 1.02 TiB
    (57.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 10 (default 60) cache-pressure: 50 (default 100)
  ID-1: swap-1 type: zram size: 62.71 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 69.05 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 42.5 C mobo: N/A gpu: nvidia temp: 49 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 455 Uptime: 3m wakeups: 0 Memory: 62.71 GiB used: 4.32 GiB
  (6.9%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages: 1571 pacman: 1552 lib: 351
  flatpak: 19 Shell: fish v: 3.5.1 running-in: alacritty inxi: 3.3.20```
1 Like

I ran garuda-update sometime after this, and guess what, as I started my computer today it again didn't boot. Had to rerun grub-install. Wtf is happening, what did you guys do?

Could it be related to the hardware constellation?
I have updated three PCs, two very old ones and one "new" one, without any problems; I had to repair my two "new" notebooks once via chroot. Since then I have run updates several times without any problems.
Could it also be that if the latest grub was already installed, the system then hangs?

And we guys here are just trying to fix the error caused by the grub update.

Try living without updates for a few days until the grub developers fix the bug, please.

1 Like

Will do, thanks for your hard work!

I don't know if it's due to my configuration, I just know that it's been smooth sailing so far with garuda. I had tried other distros before, some of which weren't able to boot at all. I thinks it's got something to do with my mainboard/nvme combination.

2 Likes

I just ran into this issue also, how do I fix it? I can't get into the system.

2 Likes

Looks like i started running into this problem after enabling hibernate & the resume function in grub. If a grub-install doesn't fix it, then just keep rebooting until it works... until grub fixes the problem.

1 Like
  1. boot from live cd
  2. mount root system
  3. mount /proc /sys /dev into mounted root system
  4. chroot into root system
  5. run "mkinitcpio -P"
  6. done