Experience as Nvidia and Laptop Newbie

Hi Everyone,

So, I am here with an interesting experience. I got my first Laptop, HP Omen 15. Also, this is my first NVIDIA device.Interesting start for 2022, isn't it? First of all, my new laptop's inxi -Faz

✦  ╰─λ inxi -Faz
System:
  Kernel: 5.15.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=e99e1554-282d-482c-af98-1b2c5cb9c3d5 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1
    resume=UUID=52c4c4e3-15a4-4169-a025-60eb990956f7 loglevel=3
  Desktop: Cinnamon 5.0.7 tk: GTK 3.24.31 wm: muffin vt: 7
    dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HP product: OMEN Laptop 15-en1xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 88D1 v: 75.31 serial: <superuser required> UEFI: AMI
    v: F.06 date: 05/05/2021
Battery:
  ID-1: BAT0 charge: 19.2 Wh (27.7%) condition: 69.4/69.4 Wh (100.0%)
    volts: 12.1 min: 11.6 model: HP Primary type: Li-ion serial: <filter>
    status: Charging cycles: 3
CPU:
  Info: model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3 family: 0x19 (25) model-id: 0x50 (80) stepping: 0
    microcode: 0xA50000B
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 2913 high: 4275 min/max: 1200/3200 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 2645 2: 3120
    3: 4275 4: 2514 5: 2235 6: 3549 7: 2948 8: 2592 9: 2189 10: 2395 11: 2871
    12: 3057 13: 2912 14: 2874 15: 3045 16: 3401 bogomips: 102206
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]
    vendor: Hewlett-Packard driver: nvidia v: 495.46
    alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2520
    class-ID: 0300
  Device-2: AMD Cezanne vendor: Hewlett-Packard driver: amdgpu v: kernel
    bus-ID: 06:00.0 chip-ID: 1002:1638 class-ID: 0300
  Device-3: Quanta HP Wide Vision HD Camera type: USB driver: uvcvideo
    bus-ID: 1-3:2 chip-ID: 0408:5425 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org 1.21.1.2 driver: loaded: modesetting,nvidia
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 142
    size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
    vendor: Hewlett-Packard driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x bus-ID: 06:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 06:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.12-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: e000 bus-ID: 02:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 03:00.0
    chip-ID: 8086:2723 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 8087:0029 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 953.87 GiB used: 9.47 GiB (1.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLB1T0HBLR-000H1 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: HPS0NEXF temp: 30.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 75.2 GiB size: 75.2 GiB (100.00%) used: 9.47 GiB (12.6%)
    fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 883 MiB size: 881.3 MiB (99.80%)
    used: 580 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-3: /home raw-size: 75.2 GiB size: 75.2 GiB (100.00%)
    used: 9.47 GiB (12.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 75.2 GiB size: 75.2 GiB (100.00%)
    used: 9.47 GiB (12.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 75.2 GiB size: 75.2 GiB (100.00%)
    used: 9.47 GiB (12.6%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.58 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-2: swap-2 type: zram size: 15.06 GiB used: 2.5 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: amdgpu temp: 43.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 394 Uptime: 26m wakeups: 2 Memory: 15.06 GiB
  used: 3.46 GiB (23.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1265 lib: 311 Shell: Zsh v: 5.8
  running-in: gnome-terminal inxi: 3.3.11
  • So, first of all, I booted into windows 10, because it is necessary to get registered for Warranty, and also because Omen software center is available only for windows.
    Well, I had to spend 3 straight hours, downloading and updating on a 100 mbps connection, just to get to latest version of windows. Because for some weird reasons, windows updates in a way such that first, I had to update to windows 10 21H1, then 21h2 then to windows 11. I got the justification on why I am using Linux.
    Now, I had windows 11 on my laptop. And I felt uncannily at home. Windows 11 has copied a whole lot of UI from Linux. The best example is sliders. I can bet windows got inspiration from Linux. And that slide to increase volume / brightness, it was not there in windows 10, but is in windows 11, though it has been for years in Linux. Also. fan is almost always on, and still temperature is not very cool on windows, even on idle. I don't know why so much load even in idle. This leads to decrease in battery life too.
    Only benefit I saw of windows is that it has Omen control center, that is necessary for the laptop fans to work properly, and control keyboard back lights easily.

  • Now, I booted in Garuda Linux Cinnamon Edition, and saw the beauty back. So, I had almost no experience with NVIDIA. I booted using NVIDIA drivers. And I don't know how, but it worked flawlessly ! I really wasn't expecting that. I hadn't thought that I had to do absolutely nothing. And I got 144 Hz, the max display option, by default. And an option to switch between hybrid / integrated / nvidia mode. It is really easy and flawless experience.
    Everything else, like camera, mic, keyboard, touchpad, speakers, blutooth, wifi etc. worked fine too without any single issue, except CPU sensors / fan . it was as a whole a lovely experience, and completely newbie friendly.
    Regarding fan, only issue I felt was that RPM is not shown in Linux kernel, 5.15. But it is already fixed in 5.16. Also, sensors don't show temperature of individual cores. But I guess it is okay. Also not shown in windows, at least I couldn't find how to. So its not an issue at all.

  • Also, Linux has some really cool pro over windows. Besides around 5 - 10 % percent more performance and better battery life, it is interesting to note that Linux is able to predict battery life, which was not able in Windows 10 / 11. And fans were maintaining windows equivalent temperatures at much lower RPM and noice.

Things I want to improve to get improved in Linux is,

  • Three and four finger gesture support by default. At least it is not present in Cinnamon right now. I will make sure to add this.

That's all.

So, I hope that very few of you will actually read it completely :sweat_smile:
And yeah, here are some benchmarks

https://browser.geekbench.com/user/418253
All windows benchmarks are done with charging on and fans max out, though Linux never reached even third of max RPM. I was afraid that Windows may otherwise harm hardware. Me never trust proprietary software.
I will edit and add new experience, if any.

And Happy New Year Everyone. Stay safe and stay happy.

11 Likes

I read it! :smiley:

Do you mean in terms of discharging or its total lifetime? I'm curious..

1 Like

Been running Garuda on two machines with Nvidia cards for three months and I also say they work great as long as I stay away from anything Wayland. :smiley:

I am not a huge fan of Windows now, but it sure takes a huge fan to run windows :rofl: . I remember my idle temps on my main machine being so darn high for no good reason.

Didn't they even copy the slogan of KDE? :rofl:

3 Likes

Discharging. But this may affect long term too, because faster Discharging also means more battery cycles. But obviously, it is new laptop and battery health is 100%

Yeah a lot of other things too. But I compared UI only. So :man_shrugging:

3 Likes

And here in linux ,here I sometimes get confused that even my fans are working or not because even when I am rendering a video and doing browsing at same time still i get this:

 ╭─[email protected] in ~
 ╰─λ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +41.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +39.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +39.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +38.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +37.0°C  (high = +100.0°C, crit = +100.0°C)

dell_smm-isa-0000
Adapter: ISA adapter
Processor Fan:    0 RPM

BAT0-acpi-0
Adapter: ACPI interface
in0:          12.45 V
curr1:       1000.00 uA

iwlwifi_1-virtual-0
Adapter: Virtual device
temp1:        +42.0°C

ucsi_source_psy_USBC000:001-isa-0000
Adapter: ISA adapter
in0:           5.00 V  (min =  +5.00 V, max =  +5.00 V)
curr1:         0.00 A  (max =  +0.00 A)

pch_skylake-virtual-0
Adapter: Virtual device
temp1:        +40.5°C

nouveau-pci-0100
Adapter: PCI adapter
GPU core:    900.00 mV (min =  +0.60 V, max =  +1.20 V)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +25.0°C  (crit = +107.0°C)


 ╭─[email protected] in ~ took 153ms
 ╰─λ

wollah! it's 0 RPM :stuck_out_tongue_winking_eye:
And still everything is going smooth :laughing:
It's not less than a miracle :slightly_smiling_face:

4 Likes

I definitely prefer Linux over macOS on my Mid 2015 MacBook Pro. It runs smoother and I like that I can change just about anything I want and Apple can't do anything about it. That and this computer is now 7 years old (almost) and will likely not be supported much longer with OS updates and security patches.

4 Likes

I booted using NVIDIA drivers. And I don't know how, but it worked flawlessly ! I really wasn't expecting that. I hadn't thought that I had to do absolutely nothing. And I got 144 Hz, the max display option, by default.

Almost as if a certain someone has an Nvidia laptop and got frustrated with the out of the box experience in Manjaro more than a year ago who later decided to join the Garuda team :eyes: :stuck_out_tongue:

6 Likes

What issue did you have with Manjaro with Nvidia? I had similar experience with Garuda and Manjaro on my desktop with my displays working perfectly on fresh install, since they included the proprietary drivers for the live media. But, that's been in the last few months when I started using Linux as main operating system.

My only issues with Nvidia on linux have been not getting to try out wayland or sway... I really dont like X11 for multimonitor with mixed resolutions.

Hmm almost as if the same person did the work on Manjaro's end as did the work on Garuda's end :eyes:
Wonder why it works perfectly on both :stuck_out_tongue:

4 Likes

Well, thank you for your service. :slight_smile: I didn't read your original message correctly at all and missed the tone haha

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.