Ethernet hung on "Setting network address", never connects

inxi -Faz
System:    Kernel: 5.10.82-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=6a4af797-f4ba-4b69-a457-97f651b8524d
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 iommu=soft
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: Micro-Star model: X570-A PRO (MS-7C37) v: 3.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: H.C2 date: 12/29/2020
CPU:       Info: 6-Core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3 family: 19 (25)
model-id: 21 (33) stepping: 0 microcode: A201009 cache: L1: 384 KiB L2: 3 MiB L3: 32 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 88799
Speed: 3684 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 3684 2: 3731
3: 3692 4: 3643 5: 3711 6: 3698 7: 3636 8: 3712 9: 3656 10: 3741 11: 3612 12: 3604
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT]
vendor: XFX Limited XFX Speedster MERC 319 driver: amdgpu v: kernel bus-ID: 2f:00.0
chip-ID: 1002:73bf class-ID: 0300
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting,radeon alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3000x1920 s-dpi: 96 s-size: 791x506mm (31.1x19.9") s-diag: 939mm (37")
Monitor-1: DisplayPort-0 res: 1920x1080 hz: 144 dpi: 82 size: 598x337mm (23.5x13.3")
diag: 686mm (27")
Monitor-2: DisplayPort-1 res: 1080x1920 hz: 60
OpenGL: renderer: AMD Radeon RX 6800 XT (SIENNA_CICHLID DRM 3.40.0 5.10.82-1-lts LLVM 13.0.0)
v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT] driver: snd_hda_intel
v: kernel bus-ID: 2f:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI X570-A PRO driver: snd_hda_intel
v: kernel bus-ID: 31:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Licensed by Sony Entertainment America Rocksmith Guitar Adapter type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2 chip-ID: 12ba:00ff class-ID: 0300
Device-4: C-Media USB Audio Device type: USB driver: hid-generic,snd-usb-audio,usbhid
bus-ID: 1-2:3 chip-ID: 0d8c:0012 class-ID: 0300
Sound Server-1: ALSA v: k5.10.82-1-lts running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI X570-A PRO driver: r8168 v: 8.049.02-NAPI modules: r8169 port: d000
bus-ID: 27:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp39s0 state: down mac: <filter>
Device-2: NetGear A6210 type: USB driver: mt76x2u bus-ID: 8-2:2 chip-ID: 0846:9053
class-ID: 0000 serial: <filter>
IF: wlp49s0f3u2 state: up mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Drives:    Local Storage: total: 3.76 TiB used: 49.05 GiB (1.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8000NP size: 119.24 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: C2.2.1
temp: 42.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDH3 1T00 size: 931.51 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 00RL scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HUA723030ALA640 size: 2.73 TiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: AA10
scheme: GPT
ID-4: /dev/sdc maj-min: 8:32 type: USB model: USB DISK 3.0 size: 7.38 GiB block-size:
physical: 512 B logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 20.87 GiB (17.5%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 20.87 GiB (17.5%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 20.87 GiB (17.5%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 118.95 GiB size: 118.95 GiB (100.00%) used: 20.87 GiB (17.5%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.27 GiB used: 3 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 30.8 C mobo: N/A gpu: amdgpu temp: 50.0 C mem: 50.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:      Processes: 382 Uptime: 4h 40m wakeups: 0 Memory: 31.27 GiB used: 6.37 GiB (20.4%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1829 lib: 547
Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09

My WiFi USB dongle works fine, I have a terrible connection that has bad lag. I have been able to use my Ethernet connection on Windows 10 prior to switching to linux with no issues. Linux Mint and Manjaro worked fine with the ethernet until Manjaro updated something and it stopped working. Garuda has never worked.

I have already changed the drivers by blacklisting the r8169 module and installing the r8168 module. This has made it so that the network manager went from not seeing the ethernet adapter to now attempting to connect every 10 seconds or so, hanging up on "Setting network address" then coming up with an error message stating "Connection 'Wired Connection 1' deactivated

Any help is appreciated

First of all i think you need to update your system

2 Likes

From this thread, since you are using the LTS kernel:

"I think i have solve my problem, by this way :

Install lts kernel and use it

Install r8168-lts

(With r8168-dkms and zen kernel i wasn't able to get it working)"

I noticed that too, I just updated my bios after I posted that

1 Like

Attempted this, now it switched back to the r8169 drivers. Will attempt to blacklist it again

Alright, I'm dumb. How do I force a device to use a specific driver? When I do "lspci -v" I get

27:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
Subsystem: Micro-Star International Co., Ltd. [MSI] X570-A PRO motherboard
Flags: bus master, fast devsel, latency 0, IRQ 83
I/O ports at d000 [size=256]
Memory at fc704000 (64-bit, non-prefetchable) [size=4K]
Memory at fc700000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: r8168
Kernel modules: r8169, r8168

which seems wrong, as I've removed and blacklisted r8169 and I thought I removed r8168 as well.

If you blacklist r8169 the kernel will load r8168 (if it is installed) and vice versa. You could not have uninstalled r8168 as it is still being used (unless you did not reboot).

1 Like

I'm a linux noob 100%. You tell me commands to run and what they do, I'll run em. I'm fairly certain I blacklisted 8169 but it still shows in the listed Kernel modules on lspci -v. I don't know if that means anything, but I thought I also removed it entirely.

The are literally thousands of posts about the r8168 Realtek adapter online as it is the most widely used Ethernet adapter in existence. There is no shortage of information on this subject. The best way to lose your newbie status is to learn how to search for and find your own answers.

See:

I would start by searching how to use the modprobe command. The modprobe command enables you to unload and load various different drivers for your adapter.

2 Likes

Just out of curiosity, what package is providing the r8169 driver? I do not see anything in the Arch repos, the AUR, nor the Chaotic AUR. I could easily have missed it. :slight_smile:

R8169 is not provided by a package. It has been included by default in the kernel for many years.

5 Likes