RTL8111/8168/8411 PCI Express Gigabit Ethernet - Disconnecting randomly

Hi dear community ! :slight_smile:

First, here is my inxi -Faz :

System:    Kernel: 5.13.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=86700a51-f7ab-443a-9348-cffe5258a13b rw 
           [email protected] quiet rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 ipv6.disable_ipv6=1 
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: B550M DS3H v: x.x serial: <filter> UEFI: American Megatrends LLC. v: F13g 
           date: 03/25/2021 
CPU:       Info: 6-Core model: AMD Ryzen 5 PRO 4650G with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 family: 17 (23) 
           model-id: 60 (96) stepping: 1 microcode: 8600106 cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 88637 
           Speed: 3307 MHz min/max: 1400/3700 MHz boost: enabled Core speeds (MHz): 1: 3307 2: 3225 3: 3720 4: 3000 5: 3673 
           6: 3912 7: 3553 8: 3103 9: 3820 10: 3570 11: 3467 12: 3475 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: Gigabyte driver: amdgpu v: kernel bus-ID: 05:00.0 
           chip-ID: 1002:1636 class-ID: 0300 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.0x11.2") s-diag: 1055mm (41.5") 
           Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 96 size: 510x287mm (20.1x11.3") diag: 585mm (23") 
           Monitor-2: HDMI-A-1 res: 1920x1080 hz: 60 dpi: 96 size: 510x287mm (20.1x11.3") diag: 585mm (23") 
           OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.12-zen1-1-zen LLVM 12.0.1) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel v: kernel bus-ID: 05:00.1 chip-ID: 1002:1637 
           class-ID: 0403 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Device-3: GN Netcom Jabra SPEAK 410 type: USB driver: jabra,snd-usb-audio,usbhid bus-ID: 1-2:2 chip-ID: 0b0e:0410 
           class-ID: 0300 serial: <filter> 
           Sound Server-1: ALSA v: k5.13.12-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8168 v: 8.048.03-NAPI 
           modules: r8169 port: f000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-2: TP-Link 802.11ac WLAN Adapter type: USB driver: rtl8821au bus-ID: 1-4:3 chip-ID: 2357:011f class-ID: 0000 
           serial: <filter> 
           IF: wlp1s0f0u4 state: dormant mac: <filter> 
Drives:    Local Storage: total: 232.89 GiB used: 69.25 GiB (29.7%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M8250G size: 232.89 GiB block-size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: S5Z42105 temp: 34.9 C scheme: GPT 
Partition: ID-1: / raw-size: 232.63 GiB size: 232.63 GiB (100.00%) used: 69.25 GiB (29.8%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw-size: 232.63 GiB size: 232.63 GiB (100.00%) used: 69.25 GiB (29.8%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-4: /var/log raw-size: 232.63 GiB size: 232.63 GiB (100.00%) used: 69.25 GiB (29.8%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
           ID-5: /var/tmp raw-size: 232.63 GiB size: 232.63 GiB (100.00%) used: 69.25 GiB (29.8%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 7.16 GiB used: 47.5 MiB (0.6%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 32.1 C mobo: 25.0 C gpu: amdgpu temp: 28.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 315 Uptime: 34m wakeups: 0 Memory: 7.16 GiB used: 3.27 GiB (45.7%) Init: systemd v: 249 tool: systemctl 
           Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1399 lib: 346 Shell: fish v: 3.3.1 running-in: konsole 
           inxi: 3.3.06

So my problem is , I have my internet randomly disconnecting.

I have installed r8168-dkms like i have see on internet, yeah people with the same card blacklist the r8169 and install the r8168-dkms version.

I have read tons of thing and i dont know how to do now :cry:

What i have try :

dsable IPv6 / disable functionality and i think its not realy beter, i think i have no change. Randomly the card keep disconnect.

booting with IOMMU on same no result.

screenshot of my bios

i have try to install the drivers from realtek same card disconnect randomly

Other thing, I have read if you enable your boot lan in the bios, its can help.

To be precise: there's a known BIOS bug on a number of Gigabyte boards. For few users it helped to update BIOS or enable "LAN Boot ROM" option in BIOS.

I have enabled but nothing.

When appen the only thing i can do its to try to unload/reload different modprobe :

sudo systemctl stop NetworkManager; sudo ip link set enp3s0 down; sudo modprobe -r r8168; sleep 3; sudo modprobe r8169; sudo ip link set enp3s0 up; sudo systemctl start NetworkManager

Or

sudo systemctl stop NetworkManager; sudo ip link set enp3s0 down; sudo modprobe -r r8169; sleep 3; sudo modprobe r8168; sudo ip link set enp3s0 up; sudo systemctl start NetworkManager

Sometime its come back, but most of the time its make me crazy and i shtudown the pc.

What can i do ? What i am supose to do ? ^^
Lts kernel can be beter for my network card ?

Tell me if i am loosing some information, or if i should provide additional information.

Thank you for have reading about my problem, hope i can find some help.

Best regards.

Does i should, give a try with this : [SOLVED] No Ethernet with Kernel 5.10.21-1-lts / Kernel & Hardware / Arch Linux Forums ?

I dont want to destroye everything, and reinstall again ...

What does this mean?

Your LAN connection drops, websites stop loading, your DSL line keeps disconnecting, or... ?

1 Like

Sorry if whas explain that bad, but english is not my native language.

I mean : All my connection is fail. Ping (for example) 192.168.0.1 is network Network is unreachable

Hi
Have you tried also with
iommu=soft
?

1 Like

Hi @filo

Yes sure, i have methodically follow the instruction. And when i have boot with iommu=soft i whas not having internet directly. So i removed and try another thing. Now i am on lts kernel with r8168-lts and i got internet for now. I keep testing. If in few hours i still got internet i think i will be ok ?

I have to go, i will be back in 3h. Time i am not at @home i will lauch ping -4 google.com > /tmp/ping.log

See if i am not loosing it.
Thx for the help its realy apriciate :wink:

1 Like

Hi all,

Sorry to reply just now, but i got some problem IRL. I have to take care of it first, so i have to be patient with my @computer problem's

Sorry for the inconvenient, i will be back soon as possible.

Best regards.

Hello :slight_smile:

I think i have solve my probelm, by this way :

Install lts kernel and use it

Install r8168-lts

(With r8168-dkms and zen kernel i wasn't able to get it working)

I have keep my NO-IPV6 setup, but soon i will try with IPV6 enabled.

Best regards.

2 Likes

Then I'll take permission to mark it as solved! :slight_smile:
I still read "I think" but still a few days have passed ...

2 Likes

Well ... My problem is back ... Randomy i loose internet. What i cane do, or what i shoud look to solve my problem ?

(I have tested the ethernet cable with a another OS/PC and he's working correctly)

Best regards.

As a suggestion,
I would use a live image and see if it continues to happens! To rule out hardware/network issues.

It happen the same in live cd. I have to run :

sudo systemctl stop NetworkManager; sudo ip link set cardname down; sudo modprobe -r r8169; sleep 3; sudo modprobe r8169; sudo ip link set cardname up; sudo systemctl start NetworkManager and be patient. Sometime he's come back ...

Um! ok
Can you use alive image of say ubuntu or mint to try? To check hardware.

Have you tried as per
https://wiki.archlinux.org/title/Network_configuration/Ethernet#Realtek_RTL8111/8168B
Using r8168 (not the -lts) and Blacklist r8169?

1 Like

Yes sure @TilliDie :slight_smile:

But if i remember it whas not working perfectly on debian system. I whas testing on buster. I will try the last ubuntu and tell you. Give me just the time to download and make a usb bootoble ^^

1 Like

@filo Ok so i remove the lts version and install the normal version ? r8169 is blacklisted

The zen kernel should still be there if you did not unistall it manually.
Boot with it at the grub advanced options, uninstall the -lts version, the dkms version, whatever you have and start try that one...

This is starting to look like it hardware issuse, If that is the case the easy thing to do is drop a nic on your motherboard and disable onboard nic.
Ive had to do this a few times in the past.

1 Like

@filo Yes i have remove the zen kernel. So i will give a try again with zen + r8168 (normal) and unistall the lts version.

@TilliDie I have read so mutch thing on Realtek RTL8111/8168/8411, so many people have problem with this card...

But i will give a try with zen kernel + r8168 normal driver and after (if the same) i will try ubuntu see what appen. But ubuntu use directly r8619. To get it working i have to install r8168 or dkms version.

So its the same on any distribution ?

If i buy something like this : https://www.addictivetips.com/ubuntu-linux-tips/linux-usb-network-adapter/ I won't be bothered anymore?

2 Likes

@fcinq I,m sorry i have never used a usb network adapter i,ve always just installed pci nics but on your board you might have to go usb route as room maybe an issue . If this issue cannot be solved by drivers

1 Like