Error with installation of vmware

i was installing the vmware workstation pro 12 (i need this version because my cpu architecture is old), and i´ve installed the archive VMware-Workstation-Full-12.5.7-5813279.x86_64.bundle.

after that, I Tried to open the program, and nothing happens. the result of the command ¨whreis vmware¨ is ¨/bin/vmware¨, so i guess the path is correct, the file is in the correct place, but opening it with vscode i found something interesting: ¨[...]The new Ubuntu menu system[...]¨.

considering that part of the code, i guess that the program are compiled for the ubuntu (not sure, thats why i`m here), and if that its why it not opens, how can i make it work?

any clue helps :slight_smile:

edit: i´m using garuda X64, with zen kernel 5.11.15, nvidia graphics card with the 465.24.02 driver version and gnome 40.

Read

please
and post

inxi -Fxxxza

as text! Even if you personally think it is unnecessary.

and
:slight_smile:

Use Repo, AUR, chaotic-aur for Arch software. Oops GNOME :frowning:

2 Likes

there it is:

System: Kernel: 5.11.15-zen1-2-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 parameters: BOOT_IMAGE=/vmlinuz-linux-zen root=UUID=9230f6a1-625b-45bf-9732-ef1bd1c76595 rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 mitigations=off Desktop: GNOME 40.1 tk: GTK 3.24.28 wm: gnome-shell dm: GDM 40.0 Distro: Garuda Linux base: Arch Linux Machine: Type: Desktop Mobo: ASUSTeK model: P7H55D-M EVO v: Rev 1.xx serial: <filter> BIOS: American Megatrends v: 1604 date: 07/22/2010 CPU: Info: Quad Core model: Intel Xeon X3440 bits: 64 type: MT MCP arch: Nehalem family: 6 model-id: 1E (30) stepping: 5 microcode: A cache: L2: 8 MiB flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53359 Speed: 3335 MHz min/max: N/A Core speeds (MHz): 1: 3335 2: 1756 3: 3335 4: 3335 5: 3335 6: 3335 7: 3335 8: 3335 Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled Type: l1tf mitigation: PTE Inversion; VMX: vulnerable Type: mds status: Vulnerable; SMT vulnerable Type: meltdown status: Vulnerable Type: spec_store_bypass status: Vulnerable Type: spectre_v1 status: Vulnerable: __user pointer sanitization and usercopy barriers only; no swapgs barriers Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled Type: srbds status: Not affected Type: tsx_async_abort status: Not affected Graphics: Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] driver: nvidia v: 465.24.02 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1380 class-ID: 0300 Display: x11 server: X.Org 1.20.11 compositor: gnome-shell driver: loaded: nvidia display-ID: :0 screens: 1 Screen-1: 0 s-res: 2880x1210 s-dpi: 96 s-size: 762x320mm (30.0x12.6") s-diag: 826mm (32.5") Monitor-1: DVI-I-0 res: 1440x900 hz: 60 dpi: 87 size: 419x262mm (16.5x10.3") diag: 494mm (19.5") Monitor-2: HDMI-0 res: 1440x900 hz: 60 dpi: 99 size: 370x232mm (14.6x9.1") diag: 437mm (17.2") OpenGL: renderer: NVIDIA GeForce GTX 750 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 465.24.02 direct render: Yes Audio: Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56 class-ID: 0403 Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fbc class-ID: 0403 Device-3: Nam Tai E&E Products or OmniVision Sony Playstation Eye type: USB driver: ov534,snd-usb-audio bus-ID: 2-1.6:9 chip-ID: 1415:2000 class-ID: 0102 Sound Server-1: ALSA v: k5.11.15-zen1-2-zen running: yes Sound Server-2: JACK v: 0.125.0 running: no Sound Server-3: PulseAudio v: 14.2 running: yes Sound Server-4: PipeWire v: 0.3.25 running: yes Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK M4A785/P7P55 driver: r8169 v: kernel port: c800 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> Drives: Local Storage: total: 1.29 TiB used: 998.73 GiB (75.7%) SMART Message: Required tool smartctl not installed. Check --recommends ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: P3-256 size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: SSD serial: <filter> rev: 1A scheme: MBR ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3160318AS size: 149.05 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC44 scheme: MBR ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD10EZEX-00BN5A0 size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: MBR Partition: ID-1: / raw-size: 43.95 GiB size: 43.95 GiB (100.00%) used: 25.08 GiB (57.1%) fs: btrfs dev: /dev/sda6 maj-min: 8:6 ID-2: /boot raw-size: 476 MiB size: 476 MiB (100.00%) used: 310 MiB (65.1%) fs: btrfs dev: /dev/sda3 maj-min: 8:3 ID-3: /home raw-size: 49.51 GiB size: 49.51 GiB (100.00%) used: 43.34 GiB (87.5%) fs: btrfs dev: /dev/sda7 maj-min: 8:7 ID-4: /var/log raw-size: 43.95 GiB size: 43.95 GiB (100.00%) used: 25.08 GiB (57.1%) fs: btrfs dev: /dev/sda6 maj-min: 8:6 ID-5: /var/tmp raw-size: 43.95 GiB size: 43.95 GiB (100.00%) used: 25.08 GiB (57.1%) fs: btrfs dev: /dev/sda6 maj-min: 8:6 Swap: Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) ID-1: swap-1 type: zram size: 1.95 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram0 ID-2: swap-2 type: zram size: 1.95 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram1 ID-3: swap-3 type: zram size: 1.95 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram2 ID-4: swap-4 type: zram size: 1.95 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram3 ID-5: swap-5 type: zram size: 1.95 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram4 ID-6: swap-6 type: zram size: 1.95 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram5 ID-7: swap-7 type: zram size: 1.95 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram6 ID-8: swap-8 type: zram size: 1.95 GiB used: 256 KiB (0.0%) priority: 32767 dev: /dev/zram7 ID-9: swap-9 type: partition size: 24.21 GiB used: 0 KiB (0.0%) priority: 1024 dev: /dev/sda5 maj-min: 8:5 Sensors: System Temperatures: cpu: 58.0 C mobo: 42.0 C gpu: nvidia temp: 37 C Fan Speeds (RPM): cpu: 1591 psu: 0 case-1: 2057 gpu: nvidia fan: 33% Power: 12v: 12.10 5v: N/A 3.3v: 3.39 vbat: N/A Info: Processes: 353 Uptime: 3h 04m wakeups: 0 Memory: 15.59 GiB used: 4.67 GiB (29.9%) Init: systemd v: 248 tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1583 lib: 470 Shell: fish v: 3.2.1 running-in: alacritty inxi: 3.3.04

Paid-for commercial proprietary software: ask the company for support.

Otherwise: AUR (en) - vmware-workstation12

2 Likes

well, in fact i don´t paid, i´m just trying to use windows programs that only can run on VM (like some games with anti-cheat), with old hardware, and the vmware is the only program that can make it with the vram feature.

i´m trying to migrate to linux, but it´s hard to not use the dual-boot for some things

edit: anyway, thanks

Oh.  

3 Likes