Error after plasma update

I warmly welcome,
I have been using Dragon for a short time, after yesterday's update I get errors like this:

lut 18 12:21:13 kwin_x11[3666]: kwin_xkbcommon: XKB: Couldn't process include statement for 'pl(\0)'
lut 18 12:21:13 kwin_x11[3666]: kwin_xkbcommon: XKB: Abandoning symbols file "(unnamed)"
lut 18 12:21:13 kwin_x11[3666]: kwin_xkbcommon: XKB: Failed to compile xkb_symbols
lut 18 12:21:13 kwin_x11[3666]: kwin_xkbcommon: XKB: Failed to compile keymap

What can I do about it? Any tips?

Hey there! :slight_smile:
Is kwin starting up correctly? Or where do you get these logs from? Need some more information please :thinking:

2 Likes

Logs are from journalctl , kwin starts normally, keyboard stutters on the BACK key - deletes only one character ...

Then all are well.

Important messages are from level 3

journalctl -b -p3

If something is misbehaving, explain properly and post text info/logs (not images).
Reporting bugs | Garuda Linux wiki

2 Likes

these are logs from level 3

journalctl -b -p3 --no-pager --no-hostname

-- Journal begins at Mon 2021-02-08 15:15:46 CET, ends at Thu 2021-02-18 13:52:10 CET. --
lut 18 12:21:09 THINK systemd-tmpfiles[514]: Failed to write file "/sys/module/pcie_aspm/parameters/policy": Operation not permitted
lut 18 12:21:10 THINK gpsdctl[542]: gpsd_control(action=add, arg=/dev/ttyUSB0)
lut 18 12:21:13 THINK kwin_x11[3666]: kwin_xkbcommon: XKB: Couldn't process include statement for 'pl(\0)'
lut 18 12:21:13 THINK kwin_x11[3666]: kwin_xkbcommon: XKB: Abandoning symbols file "(unnamed)"
lut 18 12:21:13 THINK kwin_x11[3666]: kwin_xkbcommon: XKB: Failed to compile xkb_symbols
lut 18 12:21:13 THINK kwin_x11[3666]: kwin_xkbcommon: XKB: Failed to compile keymap

Describe other noticed problems.
Also post

localectl
locale
inxi -Fxxxza
2 Likes
  System Locale: LANG=pl_PL.UTF-8
       VC Keymap: pl2
      X11 Layout: pl
       X11 Model: pc105
     X11 Variant: intl
     
LANG=pl_PL.UTF-8
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC=pl_PL.UTF-8
LC_TIME=pl_PL.UTF-8
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY=pl_PL.UTF-8
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER=pl_PL.UTF-8
LC_NAME=pl_PL.UTF-8
LC_ADDRESS=pl_PL.UTF-8
LC_TELEPHONE=pl_PL.UTF-8
LC_MEASUREMENT=pl_PL.UTF-8
LC_IDENTIFICATION=pl_PL.UTF-8
LC_ALL=
System:    Kernel: 5.10.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=71295644-65de-4d5b-904a-10df2a7b01a5 rw 
           [email protected] net.ifnames=0 snd_hda_codec_hdmi.enable_silent_stream=0 quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.21.0 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: LENOVO product: 20RD003KMH v: ThinkPad E15 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: LENOVO model: 20RD003KMH serial: <filter> UEFI: LENOVO v: R16ET29P (1.15 ) date: 12/03/2020 
Battery:   ID-1: BAT0 charge: 44.6 Wh condition: 44.8/45.7 Wh (98%) volts: 12.3/11.1 model: Celxpert 5B10W138 type: Li-poly 
           serial: <filter> status: Unknown cycles: 39 
CPU:       Info: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
           model-id: 8E (142) stepping: C (12) microcode: DE L2 cache: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33599 
           Speed: 796 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 796 2: 800 3: 800 4: 799 5: 800 6: 788 7: 799 8: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds mitigation: TSX disabled 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9b41 
           class ID: 0300 
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus ID: 1-8:3 chip ID: 04f2:b6d9 class ID: 0e02 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1182x380mm (46.5x15.0") s-diag: 1242mm (48.9") 
           Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           Monitor-2: DP1-8 res: 2560x1440 hz: 60 dpi: 123 size: 530x300mm (20.9x11.8") diag: 609mm (24") 
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:     Device-1: Intel Comet Lake PCH-LP cAVS vendor: Lenovo driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:02c8 class ID: 0403 
           Sound Server: ALSA v: k5.10.16-zen1-1-zen 
Network:   Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:02f0 
           class ID: 0280 
           IF: wlan0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 2000 
           bus ID: 04:00.0 chip ID: 10ec:8168 class ID: 0200 
           IF: eth0 state: down mac: <filter> 
Bluetooth: Device-1: Intel type: USB driver: btusb v: 0.8 bus ID: 1-10:8 chip ID: 8087:0026 class ID: e001 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 1.36 TiB used: 46.76 GiB (3.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 2B2QEXM7 temp: 34.9 C 
           scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 1TB size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 1B6Q scheme: GPT 
Partition: ID-1: / raw size: 66.5 GiB size: 66.5 GiB (100.00%) used: 34.61 GiB (52.0%) fs: btrfs dev: /dev/nvme0n1p3 
           maj-min: 259:3 
           ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) used: 30 MiB (5.9%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw size: 66.5 GiB size: 66.5 GiB (100.00%) used: 34.61 GiB (52.0%) fs: btrfs dev: /dev/nvme0n1p3 
           maj-min: 259:3 
           ID-4: /var/log raw size: 66.5 GiB size: 66.5 GiB (100.00%) used: 34.61 GiB (52.0%) fs: btrfs dev: /dev/nvme0n1p3 
           maj-min: 259:3 
           ID-5: /var/tmp raw size: 66.5 GiB size: 66.5 GiB (100.00%) used: 34.61 GiB (52.0%) fs: btrfs dev: /dev/nvme0n1p3 
           maj-min: 259:3 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-5: swap-5 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-6: swap-6 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-7: swap-7 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-8: swap-8 type: zram size: 1.93 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 55.0 C mobo: 0.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 266 Uptime: 1h 58m wakeups: 11 Memory: 15.44 GiB used: 4.65 GiB (30.1%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 clang: 11.0.1 Packages: pacman: 1807 lib: 549 Shell: fish v: 3.1.2 running in: konsole inxi: 3.3.01

It looks like a configuration problem. How did you configure keyboard layout?
Was it changed recently?
Haven't you noticed this issue since installation?
When did you install Garuda?

Post

cat /etc/X11/xorg.conf.d/*keyboard.conf
2 Likes

Check and set

$ localectl list-x11-keymap-layouts | grep pl
pl

$ localectl list-x11-keymap-variants pl      
csb
dvorak
dvorak_altquotes
dvorak_quotes
dvp
legacy
qwertz
ru_phonetic_dvorak
szl

# Run
sudo localectl --no-convert set-x11-keymap pl,us pc105 , grp:alt_shift_toggle
2 Likes

I installed the system about 3 weeks ago.
Early on, I had no problems with the keyboard.
I have an extra keyboard besides my laptop

cat /etc/X11/xorg.conf.d/*keyboard.conf

# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "pl"
        Option "XkbModel" "pc105"
EndSection

Run this command

2 Likes

After rebooting the system I have this :
cat /etc/X11/xorg.conf.d/*keyboard.conf
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "pl,us"
Option "XkbModel" "pc105"
Option "XkbVariant" ","
Option "XkbOptions" "grp:alt_shift_toggle"
EndSection
Keyboard operation unchanged - BACK only moves 1 time

As in the system settings, I will choose the keyboard
'intl' - it's ok, but after rebooting it is back to the default keyboard...

What System settings?
Garuda settings, or KDE/Plasma settings > Keyboard layout?
What are those settings?

1 Like

KDE/Plasma settings > Keyboard layout
same is how i set Garuda settings

As explained, your configuration was wrong.
Don't select variant intl.
This seems your issue.
In Plasma Keyboard layout, uncheck Custom layout, save and relogin to check for certain.

Y0218_002

1 Like

I think the problem is here

kwin_xkbcommon: XKB: Failed to compile keymap

This is not a problem, it's a symptom.
If you follow suggested troubleshooting, we may find the problem. :wink:
Report your findings, not your assumptions, so we can help. Assumptions have no value on their own... :man_shrugging:

3 Likes

Sorry to revive this topic, but I thought others might be interested in the solution. This seems to be a bug with Plasma 5.21 update. I have the same error messages in my journalctl log, although my keyboard seems to be working fine.

Refer to this page for more details and a temporary fix.
https://bbs.archlinux.org/viewtopic.php?id=263764

It seems you haven't read the above posts. The issue is fixed.
There was a mistake in keyboard layout settings.
The linked topic does not have any solution in general. The issue is user specific.

3 Likes