Error after plasma update in /.config/kxkbrc

Hi,

I tried your solution and it didn't work for me. After unchecking and restarting, I still get those journalctl errors and the setting comes back, i.e. unchecking doesn't stick.

However, when I tried the solution suggested in the link I provided, it works. No more errors in journalctl. So, basically setting "VariantList=basic" in ~/.config/kxkbrc file fixes the problem.

Since you closed the topic, I thought I inform you. You might want to take a second look at this issue and your solution.

Thanks for the notice.
You should know that not all issues or solutions are for every case the same, so the proper thing to do is to start a new topic with your specific issue details.

We are talking about a KDE possible bug. By definition, KDE/Plasma is a Graphical/Desktop Environment and any supposed edit file solution is totally NOT a solution.
By experience and as Archwiki clearly warns, Plasma/KDE updates will often require local settings cleanup. This implies that there maybe changes in configuration/settings text files format and arrangement, that could make old files incompatible with new packages versions.

So, first we should do a KDE/Plasma cleanup and settings re-application, when we face such issues after updates.

If we believe there is an error or a bug concerning plasma config (clean/new) files and settings, then we file a bug report upstream, so it can be fixed ASAP.

For example, in your case,

  • Cleanup plasma config, (or better rename/back them up)
  • Logout/login and reconfigure suspected setting.

Check the file in suspicion.

If you want help, post relevant info and logs.

1 Like

Hi petsam,

Thank you for your response and making this a separate topic.

Actually, I didn't upgrade my KDE Plasma version. Because I installed Garuda using the latest ISO (dated 20210225) which already has Plasma 5.21 and I get the mentioned kwin errors related to xkb in my journalctl. So, the config files are original Plasma 5.21 versions, not older ones.

What helped me solve this issue (although these errors didn't cause any problem with my keyboard) is the suggestion (setting "VariantList=basic" in ~/.config/kxkbrc file) mentioned in the given Arch forum link.

This looks like a Plasma 5.21 bug and I am sure it will be fixed in future updates (as many people complain about this). Until then, I just thought I share it in Garuda forum to let others know about this temporary fix as well in case your solution doesn't work for them (as it didn't work for me).

That's all. Thanks again...

But you are not helping trace the real issue.
I tried to explain. Maybe my Greek-English didn't help you understand what is expected from Open Source Software users.

Please contribute to Open Source Software. It's the least we can do, since we use it for free :wink:

1 Like

Your English seems fine and I think I can understand what you say. I will try to create a KDE bug report if it's not already reported and if I can do all the research and gather the required info to trace it.

In the meantime, I just wanted to contribute by sharing my experience and the temporary fix that helped me. But for some reason, every time I try to contribute to Garuda forum, I get strange reaction from Garuda team/moderators.

I understand you guys might get overloaded for your volunteer work and might be frustrated with people not doing their research and simply asking questions. However, as you can see, I did not ask for anything and don't expect anybody to do anything for me. Simply wanted to maybe help others by sharing what I experienced. But, I regret it already.

1 Like

I regret you misunderstand and that you are absolutely sure you don't.

Because you think you have the same bug and you think you have found a workaround for all similar cases, does not mean it is true.
For the 3rd time I ask you to do what is supposed to be done and you are welcome to keep not listening.

Post terminal input and output of what you do and file contents prior and after your actions.
Or whatever you want, but I can't help with it.

2 Likes