Enabling g-hyprland on old Garuda Hyprland installs

Hey all,

Disclaimer: I’m new to Garuda and I’ve been using Garuda Hyprland for 3 months now, I love it!

After seeing the what’s new video on Garuda Hyprland, I decided to give it a try, only to realize I was unable to open G-Hyprland at all on my system. After sending a dumb question in the comments, AnkurAlpha was kind enough to help me and asked me to post this to the forums as it seems to be a common issue.

a simple workaround would be:

run :

upd -a
cp /etc/skel/.local/bin/keyhint.sh ~/.local/bin/keyhint.sh

And paste this in your hypr config :
bind = $mainMod SHIFT, G, exec, footclient -e ~/.local/bin/bear/implement_gum.sh enable

Now, I’ve been trying this workaround and started to find a few things that may help others who are going through the same as me:

  1. Updating Garuda Hyprland does not install Gum & Bear, which means the workaround above may not work
  2. I’ve manually installed both and I’m in the process of testing the workaround again. I’ll update this post if I find any other dependencies as I won’t be able to continue testing this for a few hours.

I’d like to thank AnkurAlpha for being so helpful to a random stranger on a YouTube comment and hopefully I’ll be able to get this sorted out and share my learnings here :slight_smile:

Obligatory garuda-inxi below:

System:
  Kernel: 6.8.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 clocksource: tsc
    avail: hpet,acpi_pm parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=535caf4e-ff57-47bb-9e90-38467e71d06a rw rootflags=subvol=@ quiet loglevel=3 ibt=off
  Desktop: Hyprland v: 0.40.0-1-ga3309b51 with: waybar tools: avail: lxlock,swayidle,swaylock
    vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: B550I AORUS PRO AX serial: <superuser required>
    uuid: <superuser required> UEFI: American Megatrends LLC. v: F16d date: 05/11/2022
CPU:
  Info: model: AMD Ryzen 7 5700X3D bits: 64 type: MT MCP arch: Zen 3+ gen: 4 level: v3 note: check
    built: 2022 process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x21 (33) stepping: 2
    microcode: 0xA20120A
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 96 MiB desc: 1x96 MiB
  Speed (MHz): avg: 3185 high: 4042 min/max: 2200/4148 boost: enabled scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 3220 2: 3233 3: 3792 4: 3233 5: 3234 6: 3238
    7: 3222 8: 3234 9: 2200 10: 3233 11: 4042 12: 2200 13: 3227 14: 3201 15: 3230 16: 3233
    bogomips: 95811
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Navi 33 [Radeon RX 7700S/7600/7600S/7600M XT/PRO W7600] vendor: ASUSTeK
    driver: amdgpu v: kernel arch: RDNA-3 code: Navi-33 built: 2023+ pcie: gen: 4 speed: 16 GT/s
    lanes: 8 ports: active: HDMI-A-1 empty: DP-1, DP-2, DP-3, Writeback-1 bus-ID: 08:00.0
    chip-ID: 1002:7480 class-ID: 0300
  Device-2: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2.3:6 chip-ID: 046d:08e5 class-ID: 0102
    serial: <filter>
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 23.2.6 compositor: Hyprland
    v: 0.40.0-1-ga3309b51 driver: X: loaded: amdgpu unloaded: modesetting,radeon
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 1
  Monitor-1: HDMI-A-1 model: PA278QV serial: <filter> built: 2021 res: 2560x1440 hz: 60 dpi: 109
    gamma: 1.2 scale: 1 size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi device: 1 drv: swrast
    surfaceless: drv: radeonsi wayland: drv: radeonsi x11: drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.6-arch1.2 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon RX 7600 (radeonsi navi33 LLVM 17.0.6 DRM 3.57
    6.8.9-zen1-1-zen) device-ID: 1002:7480 memory: 7.81 GiB unified: no
  API: Vulkan v: 1.3.279 layers: 7 device: 0 type: discrete-gpu name: AMD Radeon RX 7600 (RADV
    NAVI33) driver: mesa radv v: 24.0.6-arch1.2 device-ID: 1002:7480 surfaces: xcb,xlib,wayland
    device: 1 type: cpu name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
    v: 24.0.6-arch1.2 (LLVM 17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Audio:
  Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s
    lanes: 8 bus-ID: 08:00.1 chip-ID: 1002:ab30 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Logitech C920 PRO HD Webcam driver: snd-usb-audio,uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-2.3:6 chip-ID: 046d:08e5 class-ID: 0102
    serial: <filter>
  API: ALSA v: k6.8.9-zen1-1-zen status: kernel-api tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver
: r8169 v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 1 bus-ID: 05:00.0 chip-ID: 14c3:0608 class-ID: 0280
  IF: wlp5s0 state: down mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Bluetooth:
  Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-8:3 chip-ID: 0e8d:0608 class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2 lmp-v: 11 status:
    discoverable: no pairing: no class-ID: 6c0104
Drives:
  Local Storage: total: 931.51 GiB used: 316.45 GiB (34.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: WD BLACK SN770 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD
    serial: <filter> fw-rev: 731030WD temp: 46.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 316.45 GiB (34.0%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 584 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 316.45 GiB (34.0%) fs: btrfs
    dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 316.45 GiB (34.0%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 316.45 GiB (34.0%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 31.24 GiB used: 0 KiB (0.0%) priority: 100 comp: zstd
    avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 48.8 C mobo: 40.0 C gpu: amdgpu temp: 43.0 C mem: 56.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Info:
  Memory: total: 32 GiB available: 31.24 GiB used: 5.63 GiB (18.0%)
  Processes: 358 Power: uptime: 22m states: freeze,mem,disk suspend: deep avail: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume image: 12.49 GiB
    services: upowerd Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1417 libs: 453 tools: octopi,pacseek,paru Compilers: gcc: 13.2.1
    Client: shell wrapper v: 5.2.26-release inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-03-09
  Last full system update: 2024-05-04
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            

Hi there, welcome to the forum!
This is probably unrelated, but should be fixed

Normally this is fixed by garuda-update (aka update, aka upd). Try it again
Or are you holding back any package on purpose?

3 Likes

I just had 5 packages appearing as available to be updated, I did run garuda-update yesterday (Last full system update: 2024-05-04) and just ran it again:

:: Synchronizing package databases...
 garuda is up to date
 core is up to date
 extra is up to date
 multilib is up to date
 chaotic-aur                                                      1691.4 KiB  2.81 MiB/s 00:01 [-------------------------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵

:: Synchronizing package databases...
 garuda downloading...
 core downloading...
 extra downloading...
 multilib downloading...
 chaotic-aur downloading...
spawn pacman -Su
:: Starting full system upgrade...
warning: xdg-desktop-portal-hyprland-git: local (1:r322.22e7a65-1) is newer than chaotic-aur (1.3.1.r20.g1f228ba2-1)
 there is nothing to do

System updated! 🐧

I’m still unable to run G-Hyprland unfortunately, I’ll try to continue debugging later today :slight_smile:

Maybe have a look there.

/etc/skel/.config/gum_implementation/

and

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.