Elantech touchpad no tap-to-click

Hi,
I have (I think) solved an issue where my touchpad would sometimes not respond on boot, but now I have lost tap-to-click and I don't know why.

I have tried the solutions in this post:

I have also created /etc/modprobe.d/psmouse.conf as recommended in:

https://wiki.archlinux.org/title/Laptop#Elantech

(however, I did not check the journalctl for that entry before trying it, so maybe I should delete it since it didn't solve the problem either way).

It is relevant that I unsuccessfully tried to give myself tap-to-click functionality according to this:

Enable tap-to-click on Arch Linux | xtrymind (and others)

and as a result, I have edited /etc/X11/xorg.conf/30-touchpad.conf so that it currently says

    Section "InputClass" 

            Identifier "libinput touchpad catchall" 

            Driver "libinput" 

            MatchIsTouchpad "on" 
            
            MatchDevicePath "/dev/input/event"

            Option "Tapping" "on" 
            
#            Option "TappingDrag" "on"
            
#            Option "AccelProfile" "linear" 
            
#            Option "AccelSpeed" "0.4" 

            Option "TappingButtonMap" "lmr" 

            Option "ClickMethod" "buttonareas"

    EndSection

I have had several other blocks of text inside this file, but nothing gives me tap-to-click. This makes me think that it's being controlled by some other driver, even though I have tried to disable it via modprobe as in the Arch Wiki above.

Not sure where to go next.

inxi -Faz
System:    Kernel: 5.13.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=a2f9b7ce-1d14-45ec-960d-80f6deb84e9b 
           rw [email protected] quiet 
           cryptdevice=UUID=ed9fb91f-024a-4397-9ad0-e4eabee27366:luks-ed9fb91f-024a-4397-9ad0-e4eabee27366 
           root=/dev/mapper/luks-ed9fb91f-024a-4397-9ad0-e4eabee27366 splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 pcie_aspm=off 
           ath10k_core.skip_otp=y 
           Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: Acer product: Nitro AN515-42 v: V1.18 serial: <filter> 
           Mobo: RR model: Freed_RRS v: V1.18 serial: <filter> UEFI: Insyde v: 1.18 date: 06/18/2020 
Battery:   ID-1: BAT1 charge: 29.4 Wh (97.7%) condition: 30.1/48.9 Wh (61.5%) volts: 16.1 min: 15.2 
           model: LG 0x41,0x43,0x31,0x34,0x42,0x38,0x007A type: Li-ion serial: <filter> status: Charging 
           Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A status: N/A 
CPU:       Info: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP 
           arch: Zen family: 17 (23) model-id: 11 (17) stepping: 0 microcode: 810100B cache: L2: 2 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31942 
           Speed: 2150 MHz min/max: 1600/2000 MHz boost: disabled Core speeds (MHz): 1: 2150 2: 1559 
           3: 1446 4: 1616 5: 1704 6: 2102 7: 2055 8: 2610 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] 
           vendor: Acer Incorporated ALI driver: amdgpu v: kernel bus-ID: 01:00.0 chip-ID: 1002:67ef 
           class-ID: 0380 
           Device-2: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
           vendor: Acer Incorporated ALI driver: amdgpu v: kernel bus-ID: 04:00.0 chip-ID: 1002:15dd 
           class-ID: 0300 
           Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 3-1:2 chip-ID: 04f2:b5f7 
           class-ID: 0e02 
           Display: x11 server: X.Org 1.20.13 compositor: gnome-shell driver: loaded: amdgpu,ati 
           unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.41.0 5.13.10-zen1-1-zen LLVM 12.0.1) 
           v: 4.6 Mesa 21.1.6 direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Acer Incorporated ALI 
           driver: snd_hda_intel v: kernel bus-ID: 04:00.1 chip-ID: 1002:15de class-ID: 0403 
           Device-2: AMD Family 17h HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403 
           Sound Server-1: ALSA v: k5.13.10-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: no 
           Sound Server-4: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI 
           driver: r8169 v: kernel port: 2000 bus-ID: 02:00.1 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp2s0f1 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Lite-On 
           driver: ath10k_pci v: kernel port: 2000 bus-ID: 03:00.0 chip-ID: 168c:003e class-ID: 0280 
           IF: wlp3s0 state: up mac: <filter> 
           IF-ID-1: enp4s0f3u1c4i2 state: down mac: <filter> 
Bluetooth: Device-1: Lite-On type: USB driver: btusb v: 0.8 bus-ID: 1-4:2 chip-ID: 04ca:3016 
           class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 876 GiB (94.0%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 033 scheme: GPT 
Partition: ID-1: / raw-size: 931.25 GiB size: 931 GiB (99.97%) used: 876 GiB (94.1%) fs: btrfs 
           dev: /dev/dm-0 maj-min: 254:0 mapped: luks-ed9fb91f-024a-4397-9ad0-e4eabee27366 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 708 KiB (0.3%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
           ID-3: /home raw-size: 931.25 GiB size: 931 GiB (99.97%) used: 876 GiB (94.1%) fs: btrfs 
           dev: /dev/dm-0 maj-min: 254:0 mapped: luks-ed9fb91f-024a-4397-9ad0-e4eabee27366 
           ID-4: /var/log raw-size: 931.25 GiB size: 931 GiB (99.97%) used: 876 GiB (94.1%) fs: btrfs 
           dev: /dev/dm-0 maj-min: 254:0 mapped: luks-ed9fb91f-024a-4397-9ad0-e4eabee27366 
           ID-5: /var/tmp raw-size: 931.25 GiB size: 931 GiB (99.97%) used: 876 GiB (94.1%) fs: btrfs 
           dev: /dev/dm-0 maj-min: 254:0 mapped: luks-ed9fb91f-024a-4397-9ad0-e4eabee27366 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 30.27 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 54.2 C mobo: N/A 
           Fan Speeds (RPM): N/A 
           GPU: device: amdgpu temp: 53.0 C device: amdgpu temp: 43.0 C watts: 15.11 
Info:      Processes: 347 Uptime: 1h 42m wakeups: 4 Memory: 30.27 GiB used: 5.54 GiB (18.3%) Init: systemd 
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1756 lib: 541 
           Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: gnome-terminal inxi: 3.3.06

Hello.
Did you tried lts-kernel?
And you are using libinput right?

Also see(link given in archwiki)

https://bbs.archlinux.org/viewtopic.php?id=248740

Hope these links help you.

I am using linux-lts and libinput, yes. And I have the /etc/modprobe.d/elan.conf file with a line that says elantech_smbus=0 synaptics_intertouch=0
This has not solved the issue with the mouse occasionally not working, and it has also not solved the issue of tap-to-click going away.

Here's my journalctl for a recent boot where the mouse didn't work again:

This line worries me:

Sep 04 12:46:50 sappur-nitroan51542 modprobe[356]: libkmod: kmod_config_parse: /etc/modprobe.d/elan.conf line 1: ignoring bad line starting with 'elantech_smbus=0'

So I will change the elan.conf file to say options psmouse elantech_smbus=0 instead and see if that does anything different on the next boot.

I have rebooted and the mouse still has no tap-to-click like it did before, but I can't know if it fixed the other issue for sure. The journal no longer has the bit about a "bad line" so that's a good sign.

It still hasn't worked, but I have an update. If I try to put on tapping using

xinput set-prop "ELAN0504:01 04F3:3091 Touchpad" "libinput Tapping Enabled" 1

it gives me an error that tapping isn't a recognized property:

 property 'libinput Tapping Enabled' doesn't exist, you need to specify its type and format 

This happens whether I do "tapping on" or "tapping enabled" or even "tapping true"

When I do xinput list-props "ELAN0504:01 04F3:3091 Touchpad"
it gives me this list:

Device 'ELAN0504:01 04F3:3091 Touchpad':
	Device Enabled (153):	1
	Coordinate Transformation Matrix (155):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	Device Accel Profile (284):	1
	Device Accel Constant Deceleration (285):	2.500000
	Device Accel Adaptive Deceleration (286):	1.000000
	Device Accel Velocity Scaling (287):	12.500000
	Synaptics Edges (309):	129, 3106, 126, 2220
	Synaptics Finger (310):	25, 30, 0
	Synaptics Tap Time (311):	180
	Synaptics Tap Move (312):	175
	Synaptics Tap Durations (313):	180, 180, 100
	Synaptics ClickPad (314):	1
	Synaptics Middle Button Timeout (315):	0
	Synaptics Two-Finger Pressure (316):	282
	Synaptics Two-Finger Width (317):	7
	Synaptics Scrolling Distance (318):	79, 79
	Synaptics Edge Scrolling (319):	0, 0, 0
	Synaptics Two-Finger Scrolling (320):	1, 0
	Synaptics Move Speed (321):	1.000000, 1.750000, 0.050050, 0.000000
	Synaptics Off (322):	0
	Synaptics Locked Drags (323):	0
	Synaptics Locked Drags Timeout (324):	5000
	Synaptics Tap Action (325):	0, 0, 0, 0, 0, 0, 0
	Synaptics Click Action (326):	1, 3, 2
	Synaptics Circular Scrolling (327):	0
	Synaptics Circular Scrolling Distance (328):	0.100000
	Synaptics Circular Scrolling Trigger (329):	0
	Synaptics Circular Pad (330):	0
	Synaptics Palm Detection (331):	0
	Synaptics Palm Dimensions (332):	10, 200
	Synaptics Coasting Speed (333):	20.000000, 50.000000
	Synaptics Pressure Motion (334):	30, 160
	Synaptics Pressure Motion Factor (335):	1.000000, 1.000000
	Synaptics Grab Event Device (336):	0
	Synaptics Gestures (337):	1
	Synaptics Capabilities (338):	1, 0, 0, 1, 1, 0, 0
	Synaptics Pad Resolution (339):	32, 32
	Synaptics Area (340):	0, 0, 0, 0
	Synaptics Soft Button Areas (341):	1617, 0, 1923, 0, 0, 0, 0, 0
	Synaptics Noise Cancellation (342):	19, 19
	Device Product ID (277):	1267, 12433
	Device Node (276):	"/dev/input/event9"

So I have googled around for the 325: "Synaptics Tap Action" but I have no idea how to modify this besides by trial and error.

EDIT: I HAVE SOLVED IT! I used trial and error on the xinput command. For any else with this issue, the command I used was

xinput set-prop "ELAN0504:01 04F3:3091 Touchpad" "Synaptics Tap Action" 0, 0, 0, 0, 1, 0, 0

So the 5th 0 should be changed to 1

Guess what. I also just learned that I never uninstalled xf86-input-synaptics. I have uninstalled that and changed the conf file above to what I had before and now it's working again. Geez.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.