Efistub Not Working

Hello Garuda users.

I'm a new Garuda user who switched from Manjaro. Previously I managed to use efistub on the Manjaro distro. In the same way why I failed to use efistub on Garuda distro, is it because of btrfs file system?
I tried adding rootflags but it still fails to boot.

This is the command I used to create the efistub:

$ efibootmgr -d /dev/sda -p 1 -c -L "Garuda" -l /vmlinuz-linux-zen -u "resume=UUID=e4ea5eef-411d-409f-88cd-3d339aa6c5cc root=UUID=087dbc54-86c8-4523-a952-5191181b284b rootflags=subvol=ROOT rw quiet splash fbcon=nodefer rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3 initrd=/initramfs-linux-zen.img"

I also tried using efistub-git, but it still fails.

Please help.
Thank you

Welcome :slight_smile:

Please post your

garuda-inxi

image

EFIstub kernels???

Thanks for the quick reply​:wink:

This is the output of garuda-inxi:

$ System:
Kernel: 5.19.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=cc5e68e7-4fe7-40e6-87d9-dde142078ba6 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Aspire V5-132 v: V2.05
serial: <superuser required>
Mobo: Acer model: Angel_CY v: V2.05 serial: <superuser required>
UEFI: Phoenix v: 2.05 date: 09/04/2013
Battery:
ID-1: BAT0 charge: 16.9 Wh (95.5%) condition: 17.7/30.1 Wh (58.7%)
volts: 13.0 min: 11.4 model: SANYO AC13C34 type: Li-ion serial: <filter>
status: charging
CPU:
Info: model: Intel Celeron 1019Y bits: 64 type: MCP arch: Ivy Bridge
built: 2012-15 process: Intel 22nm family: 6 model-id: 0x3A (58)
stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 2 MiB
desc: 1x2 MiB
Speed (MHz): avg: 925 high: 977 min/max: 800/1000 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 977 2: 873
bogomips: 3990
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 3rd Gen Core processor Graphics vendor: Acer Incorporated
ALI driver: i915 v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13
ports: active: eDP-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0156 class-ID: 0300
Device-2: Chicony HD WebCam (Acer) type: USB driver: uvcvideo
bus-ID: 2-1.4:3 chip-ID: 04f2:b3f6 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: AU Optronics 0x215c built: 2013 res: 1366x768
hz: 60 dpi: 136 gamma: 1.2 size: 256x144mm (10.08x5.67")
diag: 294mm (11.6") ratio: 16:9 modes: 1366x768
OpenGL: renderer: Mesa Intel HD Graphics 2500 (IVB GT1) v: 4.2 Mesa
22.1.7 direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Acer
Incorporated ALI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1e20 class-ID: 0403
Sound Server-1: ALSA v: k5.19.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
vendor: Lite-On driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0036 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth:
Device-1: Lite-On Atheros AR3012 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-1.4:7 chip-ID: 04ca:300b class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:
Local Storage: total: 465.76 GiB used: 97.96 GiB (21.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD5000LPVX-22V0TT0 size: 465.76 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 1A01 scheme: GPT
Partition:
ID-1: / raw-size: 27.34 GiB size: 27.34 GiB (100.00%) used: 7.05 GiB
(25.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 333.4 MiB
(66.8%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 63.08 GiB size: 63.08 GiB (100.00%) used: 272.3 MiB
(0.4%) fs: btrfs dev: /dev/sda4 maj-min: 8:4
ID-4: /var/log raw-size: 27.34 GiB size: 27.34 GiB (100.00%) used: 7.05
GiB (25.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 27.34 GiB size: 27.34 GiB (100.00%) used: 7.05
GiB (25.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 5.68 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 5.96 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
System Temperatures: cpu: 66.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 203 Uptime: 3h 53m wakeups: 2 Memory: 5.68 GiB used: 2.25 GiB
(39.6%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pacman: 1169 lib: 303 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
Garuda (2.6.6-1):
System install date:     2022-09-01
Last full system update: 2022-09-02
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            systemd-vconsole-setup.service

Btw, the UUID I'm using is same as the output from garuda-inxi not the same as the one I posted

Please read

1 Like

How exactly? Are you getting an error or a problem when booting?

Try

[email protected]
4 Likes

Are you sure this is right? The -l flag is for specifying the loader ( the default is \EFI\arch\grub.efi).

1 Like

Thanks very much. this is the solution​:pray:

I'm not sure, just following what the internet says​:rofl:

You are welcome :innocent:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.