Dying light 2/ Wayland / nvidia prime issues

For about 3 hours now, ive been trying to play dying light 2 on my laptop.
The game used to work on me when I used endeavoros on wayland.
I tried to install wayland on garuda. Installed all of the needed packages to my knowledge, plasma-wayland session, wlroots etc. When I select KDE on wayland from the login screen, I am granted a black screen.
I assume these problems come from my intel onboard graphics, they have been the root of 99% of my problems since switching from windows.
https://wiki.archlinux.org/title/NVIDIA_Optimus#Use_NVIDIA_graphics_only
I tried following this, it didn't work.
I wish I could just rip the intel graphics out of this laptop
My specs and output of garuda-inxi are bellow

System:
Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3304b4fa-2a9b-471b-aff3-d72993864ec5 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: 1: GDM 2: SDDM note: stopped Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Laptop System: Alienware product: Alienware Area-51m R2 v: 1.17.0
serial: Chassis: type: 10 serial:
Mobo: Alienware model: Alienware Area-51m R2 v: A00
serial: UEFI: Alienware v: 1.17.0 date: 06/07/2022
Battery:
ID-1: BAT1 charge: 78.6 Wh (97.0%) condition: 81.0/90.0 Wh (89.9%)
volts: 12.7 min: 11.4 model: COMPAL PABAS0241231 type: Li-ion
serial: status: charging
ID-2: hidpp_battery_0 charge: 91% condition: N/A volts: 4.1 min: N/A
model: Logitech G703 LIGHTSPEED Wireless Gaming Mouse w/ HERO type: N/A
serial: status: discharging
CPU:
Info: model: Intel Core i7-10700 bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 5 microcode: 0xF4
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3538 high: 4606 min/max: 800/4800 scaling:
driver: intel_pstate governor: powersave cores: 1: 2900 2: 4499 3: 2900
4: 4600 5: 1845 6: 4606 7: 4602 8: 4600 9: 2900 10: 2900 11: 2900 12: 2369
13: 4600 14: 2900 15: 4600 16: 2900 bogomips: 92796
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: retbleed mitigation: Enhanced IBRS
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: Dell driver: i915
v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
active: none empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:9bc5 class-ID: 0380
Device-2: NVIDIA TU104BM [GeForce RTX 2070 SUPER Mobile / Max-Q]
vendor: Dell driver: nvidia v: 525.60.11 alternate: nouveau,nvidia_drm
non-free: 525.xx+ status: current (as of 2022-12) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 8
link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1ed1 class-ID: 0300
Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 1-7:5 chip-ID: 0bda:5538 class-ID: 0e02 serial:
Device-4: Tobii AB EyeChip type: USB driver: uvcvideo bus-ID: 1-9:7
chip-ID: 2104:030e class-ID: 0e02 serial:
Display: x11 server: [X.Org](http://X.Org) v: 21.1.5 with: Xwayland v: 22.1.6
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 128 s-size: 762x221mm (30.00x8.70")
s-diag: 793mm (31.24")
Monitor-1: DP-0 pos: left res: 1920x1080 dpi: 128
size: 380x220mm (14.96x8.66") diag: 439mm (17.29") modes: N/A
Monitor-2: DP-1 pos: primary,right res: 1920x1080 dpi: 90
size: 544x303mm (21.42x11.93") diag: 623mm (24.52") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 525.60.11 renderer: NVIDIA GeForce RTX 2070
Super/PCIe/SSE2 direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel
bus-ID: 1-2.3:6 v: kernel chip-ID: 1038:12d7
alternate: snd_soc_skl,snd_sof_pci_intel_cnl class-ID: 0300
bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU104 HD Audio vendor: Dell driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f8 class-ID: 0403
Device-3: SteelSeries ApS Arctis 7X type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks
driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlo1 state: up mac:
Device-2: Realtek Killer E3000 2.5GbE vendor: Dell driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: 3000 bus-ID: 06:00.0
chip-ID: 10ec:3000 class-ID: 0200
IF: enp6s0 state: up speed: 100 Mbps duplex: full mac:
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:10 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address:
Drives:
Local Storage: total: 4.34 TiB used: 3.59 TiB (82.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: PC SN730 NVMe WDC 512GB size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial:
rev: 11170012 temp: 37.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 256GB
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: 4B6Q scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate model: BUP Portable
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B type: N/A
serial: rev: 1707 scheme: GPT
Partition:
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 391.74 GiB (82.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 391.74 GiB (82.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 391.74 GiB (82.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 391.74 GiB (82.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.11 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 40.0 C pch: 41.0 C mobo: N/A gpu: nvidia
temp: 39 C
Fan Speeds (RPM): N/A
Info:
Processes: 407 Uptime: 2m wakeups: 3 Memory: 31.11 GiB used: 3.6 GiB (11.6%)
Init: systemd v: 252 default: graphical tool: systemctl Compilers:
gcc: 12.2.0 Packages: 1676 pm: pacman pkgs: 1622 libs: 436
tools: octopi,paru pm: flatpak pkgs: 54 Shell: fish v: 3.5.1 default: Bash
v: 5.1.16 running-in: yakuake inxi: 3.3.24
Garuda (2.6.10-1):
System install date: 2022-11-23
Last full system update: 2022-12-17
Is partially upgraded: No
Relevant software: NetworkManager
Windows dual boot: Probably (Run as root to verify)
Snapshots: Snapper
Failed units:

_*,,,,,,,*
*โ•“โ•—โ•ฃโ•ซโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ••โ•—โ•—โ”*
โ•ฅโ•ขโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฅ,
โ•—โ• โ• โ• โ• โ• โ• โ• โ•โ•œโ•œโ•œโ•œโ•โ•ขโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ”
โ•ฃโ• โ• โ• โ• โ• โ• โ• โ• โ•ขโ•ฃโ•ขโ•—โ•• , `"โ•˜โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•”โ•ฅ_          [email protected] โ•’โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ••โ•™โ•ฅโ•ฅโ•œ   `"โ•œโ• โ•ฌโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฅ, -------------
โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•—โ•ฅโ•ฅโ•ฅโ•ฅโ•—โ•—โ•ฌโ• โ• โ• โ• โ• โ• โ• โ•โ•™โ• โ• โ•ฃโ• โ• โ• โ• โ•ขโ” OS: Garuda Linux
โ•ฃโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฅโ•ฌโ•ฃโ• โ• โ• โ• โ• โ• โ• โ• โ•— Host: Alienware Area-51m R2 1.17.0
โ•’โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•— Kernel: 6.0.12-zen1-1-zen
โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•  Uptime: 3 mins
โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฌ ```"โ•œโ•โ•ขโ• โ• โ•ก Packages: 1622 (pacman), 54 (flatpak)
โ•’โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฃ, โ•˜โ• โ•ช Shell: bash
โ•žโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ขโ” โ•œ DE: Plasma 5.26.4
`โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•—             WM: KWin 
,โ•ฌโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• "โ••            WM Theme: Sweet-Dark
 โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•—              Terminal: yakuake 
โ•^โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•โ•ฃโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ก              CPU: Intel i7-10700 
(16) @ 4.8GHz โ•”โ•œ`โ•žโ”˜โ•ขโ•›โ•œ โ•กโ•ขโ• "โ•šโ• โ• โ•œโ•โ”Œโ•žโ•ž"โ•ขโ• โ• โ• โ• โ• โ• โ• โ• โ• โ• โ•ฃโ•ฉโ•ขโ•ช GPU: NVIDIA GeForce RTX 2070 SUPER Mobile / Max-Q
โ•œโ•’" `โ•œ    ` โ•œโ•™โ•• โ””โ•ฃโ• โ• โ• โ• โ•• โ•žโ•™โ•– GPU: Intel CometLake-S GT2 [UHD Graphics 630]
โ• โ• โ•  Memory: 3.17GiB / 31.11GiB

I don't think wlroots is needed in KDE.
It doesn't necessarily mean that it causes problems, but I'd remove it.
If I remember correctly you need also sddm-git, and probably a few tweaks mentioned here:

1 Like

This is unlikely. Your integrated GPU will work out of the box with no configuration needed, Wayland or not because support for it has been built into the kernel. It is your other GPU which is the source of your grief. It wasn't that long ago that Nvidia didn't work on Wayland at all, in fact.

Take a look through this guide to see if it is helpful for getting the GPUs straightened out: Switching between integrated and dedicated graphics | Garuda Linux wiki

It looks like you have switched to using GDM, which is an unusual choice for a KDE system. Is this part of your troubleshooting effort, or something else?

Instead of logging in through one of your display managers, switch to a TTY and log in, then run:

startplasma-wayland

I'm curious if it throws any error message, or other meaningful output instead of just a black screen.

Edit

Just a couple more thoughts regarding Plasma/Wayland/Nvidia from ArchWiki (KDE - ArchWiki):

To enable support for Wayland in Plasma, also install the plasma-wayland-session package. If you are an NVIDIA user, also install egl-wayland if it is not already installed, and if the session does not start with the proprietary nvidia driver, also enable the DRM kernel mode setting. If that does not work, too, check the instructions on the KDE wiki.

2 Likes

Sorry it took me awhile to reply,
im not sure what this means, if I changed it it was unintentional.
"

dm: 1: GDM

"
I ended up getting the game to launch in x11 using this launch argument
VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json

"This is unlikely. Your integrated GPU will work out of the box with no configuration needed, Wayland or not because support for it has been built into the kernel. It is your other GPU which is the source of your grief. It wasn't that long ago that Nvidia didn't work on Wayland at all, in fact."
I think I was misunderstood here, i've used wayland on this pc under endeavor before and had no problem. I mean't other issues with the IGPU like DL2 not launching or Wine hanging using my HDMI port
Still havent figured out that one.... I found someone with a solution but I havent figured it out
https://forum.winehq.org/viewtopic.php?t=35507#p136159

After this im going to try getting wayland up and running with your tips above, thanks for the detailed reply!

after more research tried the tips above, tried to switch to sddm-git and got another black screen while booting, also now that I know what it is, I tried installing gnome to see if wayland worked on it, seems that when I removed it not everything was removed. which is why GDM was listed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.