During boot I have to wait around 2 minutes for 'a start job is running for Wait for Network to be configured'. How to fix?

Hello. I did a reinstall after using Garuda for a good while, and I get an issue I've never had before.
During boot I have a message saying 'a start job is running for Wait for Network to be configured' which takes a good two minutes to complete. Is there something I can do to speed this up?

inxi -Faz

System:
  Kernel: 5.15.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=1e990d50-f7c1-4ded-a883-784141da6847 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B350-PLUS v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 3401
    date: 12/04/2017
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes status:
CPU:
  Info: model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen
    family: 0x17 (23) model-id: 1 stepping: 1 microcode: 0x8001129
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 3047 high: 3232 min/max: 1550/3500 boost: disabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3113 2: 2998
    3: 2859 4: 3012 5: 3044 6: 3232 7: 3116 8: 3050 9: 3134 10: 2934 11: 2975
    12: 3108 bogomips: 83843
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Full AMD retpoline, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Vega 10 XL/XT [Radeon RX Vega 56/64] vendor: Sapphire Limited
    driver: amdgpu v: kernel bus-ID: 0a:00.0 chip-ID: 1002:687f class-ID: 0300
  Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1601 s-dpi: 96 s-size: 1182x422mm (46.5x16.6")
    s-diag: 1255mm (49.4")
  Monitor-1: DisplayPort-0 res: 2560x1080 hz: 60 dpi: 81
    size: 798x334mm (31.4x13.1") diag: 865mm (34.1")
  Monitor-2: DisplayPort-1 res: 1920x1080 hz: 60 dpi: 102
    size: 477x268mm (18.8x10.6") diag: 547mm (21.5")
  OpenGL: renderer: AMD Radeon RX Vega (VEGA10 DRM 3.42.0 5.15.8-zen1-1-zen
    LLVM 13.0.0)
    v: 4.6 Mesa 21.3.1 direct render: Yes
Audio:
  Device-1: AMD Vega 10 HDMI Audio [Radeon Vega 56/64] driver: snd_hda_intel
    v: kernel bus-ID: 0a:00.1 chip-ID: 1002:aaf8 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 0c:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: RODE Microphones RODE NT-USB type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-4:3 chip-ID: 19f7:0003
    class-ID: 0300
  Sound Server-1: ALSA v: k5.15.8-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.41 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000
    bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth:
  Device-1: ASUSTek Broadcom BCM20702A0 Bluetooth type: USB driver: btusb
    v: 0.8 bus-ID: 1-3:2 chip-ID: 0b05:17cb class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.61 TiB used: 1.47 TiB (56.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 36.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1500LM006 HN-M151RAD
    size: 1.36 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0008 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT120BX100SSD1
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: MU01 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 860 QVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
Partition:
  ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 55.22 GiB (23.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 55.22 GiB (23.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 55.22 GiB (23.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 55.22 GiB (23.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.62 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 36.0 C
    mem: 31.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1202
Info:
  Processes: 435 Uptime: 7m wakeups: 2 Memory: 15.62 GiB
  used: 4.93 GiB (31.6%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: 1956 pacman: 1941 lib: 546 flatpak: 15
  Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: kitty inxi: 3.3.10

I haven't tried anything yet, as I'm not sure if this is a specific Garuda thing or a general thing.

Edit: picture of the boot screen

Could you please provide your
systemd-analyze blame
If it shows an high value for
systemd-networkd-wait-online.service
Maybe you could try disabling that service. Just an idea from:

4 Likes

systemd-analyze blame indeed shows a high value for that item

2min 59ms systemd-networkd-wait-online.service
   5.699s man-db.service
   5.402s NetworkManager-wait-online.service
   4.952s linux-modules-cleanup.service
   1.689s updatedb.service
    925ms fwupd.service
    638ms grub-btrfs-snapper.service
    385ms media-windows-games_hdd.mount
    314ms dev-nvme0n1p2.device
    223ms ldconfig.service
    192ms systemd-tmpfiles-setup.service
    187ms ModemManager.service
    173ms media-rpi_smb-home.mount
    173ms [email protected]
    172ms media-rpi_smb-shows.mount
    172ms media-rpi_smb-stash.mount
    167ms media-windows-games_ssd.mount
    154ms home-sylvester-Games.mount
    153ms snapper-boot.service
    152ms systemd-logind.service
    151ms logrotate.service
    107ms systemd-journal-flush.service
     92ms dev-zram0.swap
     91ms systemd-remount-fs.service
     90ms udisks2.service
     79ms systemd-networkd.service
     75ms systemd-udev-trigger.service
     75ms systemd-modules-load.service
     71ms plymouth-start.service
     68ms boot-efi.mount
     67ms polkit.service
     59ms systemd-timesyncd.service
     57ms systemd-journald.service
     56ms upower.service
     55ms NetworkManager.service
     50ms bluetooth.service
     49ms avahi-daemon.service
     49ms smb.service
     48ms systemd-rfkill.service
     46ms systemd-tmpfiles-clean.service
     43ms packagekit.service
     36ms lvm2-monitor.service
     34ms systemd-udevd.service
     34ms lm_sensors.service
     30ms colord.service
     27ms systemd-machined.service
     26ms nmb.service
     25ms [email protected]
     23ms root.mount
     23ms systemd-sysusers.service
     22ms [email protected]
     22ms home.mount
     22ms [email protected]\x2duuid-ADCA\x2dC5B0.service
     21ms plymouth-deactivate.service
     21ms systemd-vconsole-setup.service
     21ms srv.mount
     21ms plymouth-quit-wait.service
     20ms cups.service
     20ms plymouth-quit.service
     19ms garuda-pacman-lock.service
     17ms plymouth-read-write.service
     16ms pamac-daemon.service
     12ms [email protected]
     11ms systemd-binfmt.service
     11ms dev-binderfs.mount
     10ms dev-hugepages.mount
     10ms dev-mqueue.mount
     10ms [email protected]
      9ms sys-kernel-debug.mount
      9ms systemd-journal-catalog-update.service
      9ms systemd-random-seed.service
      9ms sys-kernel-tracing.mount
      9ms kmod-static-nodes.service
      8ms var-cache.mount
      8ms uresourced.service
      8ms dev-loop0.device
      8ms [email protected]
      8ms accounts-daemon.service
      8ms [email protected]
      6ms systemd-tmpfiles-setup-dev.service
      6ms var-log.mount
      5ms var-tmp.mount
      5ms systemd-update-utmp.service
      3ms systemd-sysctl.service
      3ms rtkit-daemon.service
      3ms systemd-update-done.service
      3ms systemd-user-sessions.service
      2ms proc-sys-fs-binfmt_misc.mount
      2ms tmp.mount
      1ms sys-kernel-config.mount
      1ms sys-fs-fuse-connections.mount

I've disabled the service. Thanks :slight_smile:

1 Like

Just FYI:

Sometimes I have found a systemd mount unit would avoid this issue rather than using fstab (when mounting network drives).

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.