Saving 2 min by disabling Systemd-networkd-wait-online.service

I shaved 2 mins off of my computers boot time by disabling this service and saw no real difference in my PC. I don't know why it was there, I think it was supposed to wait for network to be configured, but it took a whole 2 MINS to do its job. now instead of taking 3 mins to boot, now my PC only takes one minute. Has anyone tried this before and faced problems? Should I re-enable this service?

Yes, but if you search in forum :wink:
For me, it is 6.4 sec. for NetworkManager-wait-online.service

Startup finished in 16.662s (firmware) + 7.589s (loader) + 2.408s (kernel) + 9.485s (userspace) = 36.146s reached after 9.485s in userspace



I believe the service you mentioned and the service I disabled are different. Are they both there for the same reason? If so, why do you need 2 different services to do the same thing? And why does systemd's service take literal MINUTES and NetworkManager-wait-online.service be done in like 3 seconds?
I think it is because there is a 2 min timeout on the service I mentioned, But why does the service exist in the first place?

1 Like

Unless systemd-networkd is being used to configure the network then this service shouldn't be enabled.

1 Like

Right, I thought you made a mistake Typo. Sorry.

1 Like

Using the default boot process my system takes 6.5 secs to cold boot to he desktop using a haskwel i5. on any linux system I just don't understand how things get so screwed up on certain systems its not logical. I use Gnome by the way if that makes any difference.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.