Dragonized post installation error

Hello Garuda,

After I finish installing Garuda Dragonized latest version and try to install base-devel package as the first step the system hangs. When I try to reboot there is only a blank screen.

Command: sudo pacman -Sy base-devel
Version: Latest (sorry I did not check the numbers.)
Hardware: Lenovo laptop x270

This behavior is replicated on Oracle VM as well. In fact I first tried installing Garuda on a Virtualbox. Everything worked fine on the vm till I tried to install the base-devel package. Later I tried installing it on the hardware. But I get the same blank screen error after I try to install base-devel package.

What do they mean by using the latest version?
It could be the penultimate version tomorrow.
Post full ISO name, please

Garuda using in VM is not recommend.

I installed "last" version

garuda-dr460nized-linux-zen-210225.iso](https://builds.garudalinux.org/iso/garuda/dr460nized/210225/garuda-dr460nized-linux-zen-210225.iso

without problems and it work after update too.

Read

please
and post

inxi -Fxxxza

as text.

and
:slight_smile:

1 Like

Why? Who told you you need to install this?
Do you know something we don't?
Are you sure you have read Garuda Installation Instructions any time this year?

2 Likes

It is a standard procedure I follow for any new distro installs. I like to have a development environment with all the build tools. So ... if I am not supposed to do this. What else is there that I am not supposed to do? Do you have a comprehensive list of things to not do? Besides, it still does not answer my main issue of why a standard install procedure for setting up OS for basic development tools should break an OS.

garuda-dr460nized-linux-tkg-bmq-210107.iso

I am aware that it is not meant to the used as a vm, but why not ? It seemed to do well till I ran the command for installing the build tools. Because on virtualbox you do need to install the guest utils and sometimes it causes issues when there are no build tools. Fedora has those problems. But I guess this version comes pre - installed with virtualbox guest utils as well. Anyways I tried doing a traditional install as well on a 128gb usb drive with 32gb ram and I had the same issue when I tried to install base-devel. So the issue seems to reproducible fairly easily. As with inxi command ... I deleted everything and moved out. I no longer have the system. I was giving it a quick try...

Also I never really read any installation instructions ....ever ....

This attitude is not accepted in Garuda.
Solve your issues with your own extreme intelligence.

2 Likes

Surely you know doing this
Is destroying system

You are partially upgrading

Always use
sudo pacman -Syu

5 Likes