Dr460nized - problem changing keyboard layout

In the keyboard settings I added a second keyboard layout and a shortcut to change it, but it doesn't work. In fact, the usual small layout icon in the top panel doesn't show. So I have no means to change the keyboard layout.

I sadly dont use 2 keyboard layouts at all so I dont know how this "usually" works but I tried adding one myself and couldnt change layout either, idk why though.
You could possibly try other methods to set your keymap, eg. via

2 Likes

OK. Thanks.

I still can't make the keyboard layout work.
I followed the instruction on arch wiki page. I modified the 00-keyboard.conf file following the instructions but it didn't fix the problem.
I also tried this command to change the layout, but it spat out the following error message.
─mak at jmak-inspiron137378 in ⌁
╰─λ setxkbmap -model pc104 -layout us,hu -variant ,dvorak -option grp:alt_shift_toggle

Error loading new keyboard description

Okay. Another thing that crossed my mind is Fcitx, would that work here @librewish? You might have some more experience with keyboard layouts in KDE :yum:

1 Like

Check (post) your config at

$HOME/.config/kxkbrc

Were there any error messages from KDE, when setting new config?
Does your setting page look similar to this?

Post the command, together with the output and use CODE format (pre-formated text) in post editor window.

2 Likes

I managed to make it work.

I had to modify the /etc/X11/xorg.conf.d/ 00-keyboard.conf file to make it work.

However, changing the keyboard layout by using the dialogue box doesn't work.

My keyboard box looks like yours. I added a second layout but - as I said before - there is no way to switch between the two. The shortcut for the layout switcher is ctr+alt+k, but it does nothing. The keyboard indicator icon doesn't show up in the top panel either.

There is no error message in the kxkbrc file.

Its a config file :slight_smile:

cat .config/kxkbrc 
[Layout]
DisplayNames=
LayoutList=de
LayoutLoopCount=-1
Model=
ResetOldOptions=false
ShowFlag=false
ShowLabel=true
ShowLayoutIndicator=true
ShowSingle=false
SwitchMode=Global
Use=true

So he wrote

Post your config or mark this thread as solved.

That's amazing. But still, we have to see if there is a bug in Garuda tools, or in KDE System Settings, so we can fix it or report it, because other users may have the same problem.

Please, explain and post what you have done exactly, on what files and what sequence. After changing system settings, you need to reboot, for them to engage.

If dual keyboard layout was fixed on system side (00-keyboard.conf), then KDE would normally list both layouts as default (before overriding), after reboot.
kxkbrc contains KDE settings (in GUI).
At the end, the final settings the system uses, are shown if you run

localectl

Help us fix a possible bug.

1 Like

I modified the /etc/X11/xorg.conf.d/00-keyboard.conf file like this:
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "us,hu"
Option "XkbVariant" ",qwerty"
Option "XkbOptions" "grp:alt_shift_toggle"
EndSection

And this is the output of localectl:
localectl
System Locale: LANG=en_CA.UTF-8
VC Keymap: us
X11 Layout: us,hu
X11 Variant: ,qwerty
X11 Options: grp:alt_shift_toggle
╭─mak at jmak-inspiron137378 in ⌁
╰─λ

This is the content of the kxkbrc file:
[Layout]
DisplayNames=,,,
LayoutList=us,hu(101_qwerty_comma_dead),hu(101_qwerty_comma_dead),hu
LayoutLoopCount=-1
Model=pc86
ResetOldOptions=false
ShowFlag=false
ShowLabel=true
ShowLayoutIndicator=true
ShowSingle=false
SwitchMode=Global
Use=true

Now, KDE settings works as well. The problem was that I used the "Alternative shorcut" to try to switch between the keyboard layouts. As soon as, I entered a value for the "Main shortcut" the switch worked.
But still there is no keyboard icon in the top panel.

1 Like

This command contains a mistake, dvorak should not be there (just a comma, without params, guessing qwerty is the default).
There is no dvorak variant in hu layout.

$ localectl list-x11-keymap-variants hu

101_qwerty_comma_dead
101_qwerty_comma_nodead
101_qwerty_dot_dead
101_qwerty_dot_nodead
101_qwertz_comma_dead
101_qwertz_comma_nodead
101_qwertz_dot_dead
101_qwertz_dot_nodead
102_qwerty_comma_dead
102_qwerty_comma_nodead
102_qwerty_dot_dead
102_qwerty_dot_nodead
102_qwertz_comma_dead
102_qwertz_comma_nodead
102_qwertz_dot_dead
102_qwertz_dot_nodead
nodeadkeys
qwerty
standard

And now it is obvious there is a difference between system and KDE settings.

There are 2 languages, HU having 2 variants, of which, one variant is twice (total 4 choices).
If you need both HU variants, alter "Show Layout" options to see which combination satisfies your needs (and shows the flag in TaskBar).
If you only need one HU variant, delete the other one.

Double check in TaskBar visibility options (right-click on arrow, configure) and verify Keyboard Layout (NOT Keyboard Indicator) is not disabled.

3 Likes

There is no "Keyboard Layout" entry in the Taskbar.
These are the entries that I have there:

Garuda Setting Manager
Notifications
Clipboard
Vaults
Audio Volume
Buttery and Brightness
Disks and Devices
Kde Connect
Keyboard Indicator

1 Like

Do you mean that there is nothing else, or this list is the only enabled?
It would be very strange if there is no entry for Keyboard Layout to enable.
If you can't find it, please, maximize the window and get a screenshot (PrtSc ) and post it here.
Check for this:

I found the problem (edition bug @dr460nf1r3 ?).
Go to System Settings => Startup => Background Services and enable and start the Keyboard Layout Daemon. Then the missing option will show in Task Entries.

4 Likes

Can confirm this. Thanks a lot for this fix! :partying_face:
Well idk how to call it, I disabled the services I didnt deem useful which made its way into the config. This will be shipped as default from now on :smiley:

3 Likes

Thanks a lot.
Now it works. The layout icon also appeared in the top panel.

2 Likes

A post was split to a new topic: I cannot configure multiple keyboard layouts