I cannot configure multiple keyboard layouts

I am also having this problem now in new 5.12.8.zen1.1 garuda sweetified plasma.

I want to keep English GUI language on lenovo machine with Estonian keyboard, but then be able to switch between 2-3 secondary keyboards i.e., Nepali, Tibetan Chinese keyboards depending on my work flow requirements.

In the old 2020 Garuda multimedia, this keyboard adding and switching was all working and flags would show on the indicator and keyboard switching worked.

But now in the KDE Plasma Ithere is no way to add the secondary keyboard. All i can do is change the default keyboard setting. Also, when I try to add the change keyboard widget to the dock, it says it is added but does not appear in the display, even when checking the show flags option in the layout configuration.

It is really not convenient to try to command line any menu options in Tibetan fonts and keyboards. So this issue is a big problem for switching keyboards. Maybe I can set up a new user and then only have the one language in that workspace and switch between spaces for workflows.

The only similar issue like this in the forums is related to Korean. But the KDE does not even allow me to install a Tibetan keyboard. I can try installing the ibus, but that also has its own issues. One of the advantages of Linux is that these keyboards where loaded directly in the kernels decades ago.

P.S. Keyboard Daemon background service is running.
P.S.S. There is a related bug, that when I change the default keyboard in system settings, I have to enter SU pw, but then I get the message that credentials are no good. But then the keyboard settings go into effect, contrary to the error message. It is a bug there.

Any ideas or suggestions @dr460nf1r3 can maybe find more help for this would be most welcome! :pray:t4: :pray:t4: :pray:t4:

1 Like

Read KDE documentation , Xorg configuration (Archwiki), Localization.

Fix one issue at a time.
Post what you have already done and where you still have issues.

We need actual info, not just a description in your words.
Read Garuda wiki about how to properly find solutions and post info to help us help you.


This issue was solved in the later version of Garuda that offered the IBUS language protocol at the settings selection level.

THANKS to Garuda team!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.